• no viable macs to use after switching to http

    Unsolved
    3
    0 Votes
    3 Posts
    220 Views
    A

    FYI for anyone else running into this issue - I believe the problem was that I didn’t erase the /tftpboot images when I switched from http to https. I’m not really sure why that would matter, but when I did that, then re-ran the server reinstall and selected https, the images got but back in /tftpboot and my hosts didn’t see the mac error anymore.

  • PXE boot was stuck

    Unsolved
    2
    0 Votes
    2 Posts
    165 Views
    Tom ElliottT

    @Priyankha We need a lot more details.

    FOG Version

    What bootfile is your boot server trying to send?

    Is you server sending the right FOG server for option 66/67?

    What OS are you trying to capture?

    What does the error show or maybe a screen shot? (UEFI Boot looks different from Legacy boot from Mac from arm, etc…)

    What type of machine are you trying to image?

    What have you tried?

  • Group Multicast - Dev-Branch

    Unsolved
    3
    0 Votes
    3 Posts
    205 Views
    Tom ElliottT

    @JJ-Fullmer @edvandro This should be fixed in dev-branch as well, but I agree with JJ here, please upgrade to working-1.6.

  • FOG 1.6.0-beta.2644 DHCP

    Unsolved
    10
    0 Votes
    10 Posts
    3k Views
    JJ FullmerJ

    @jmeyer Would you be willing/able to try again without bypassing it to help confirm the fix?
    @rogersk4132 thank you for testing and confirming!

  • iPXE build failing

    Unsolved
    7
    0 Votes
    7 Posts
    355 Views
    Tom ElliottT

    @astrugatch Okay thanks and sorry there was that issue.

    Can you pull and try installing again?

    Thank you!

  • Failed to Update Database and Host

    Unsolved
    22
    0 Votes
    22 Posts
    1k Views
    Tom ElliottT

    @maxcarpone I would ask you, if you’re daring/willing (it’s considered beta but uses the same pipeline with a lot more modern ui, I need people testing, and Fog_newb can likely attest the new ui look and feel though I think they ran into an issue and needed to get functional right away so the snapshotted back)

    Upgrade to working-1.6.

    I have a goal (along with @JJ-Fullmer ) to try to get working-1.6 to be master/stable branch by October.

    1.6 has been “stagnant” since around 2017 and was in relatively stable grounds back then even.

    With AI (as you undoubtly can see I’m using to help drive some things) it’s allowed us to get a lot more coding/refactoring and will hopefully present a much better experience of things on the UI side. Without testing I cannot fix UI bugs though.

    AI can do some cool things, but it doesn’t know what “wrong/right” looks like, and JJ and I are only 2 people.

    There are others on working-1.6 but more feedback is always good.

  • 1.5.10.2402 - Additional null tasks created but this time manages to start a transfer.

    Unsolved
    1
    0 Votes
    1 Posts
    102 Views
    No one has replied
  • 1.5.10.2328 - Failed to check in. Going back to 2294, all good.

    Solved
    5
    0 Votes
    5 Posts
    357 Views
    F

    @Tom-Elliott Thanks Tom. 1.5.10.2344 seems to be capturing fine. No additional null tasks were created and the PC had no problem checking in and starting the capture.

    I’d swear, not only with this version but the earlier ones that were malfunctioning during check in and creating additional tasks, I had to create the task twice. Like I went through the process of setting up a capture but nothing showed up under tasks then had to do it again.

    I can’t seem to duplicate it though. Setting up a 2nd capture for the laptop, I only had to do it once (and no additional null tasks were created).

    PC finished the capture no problem and laptop checked in and is capturing now. Looks like 2344 did it!

    Thanks again.

  • 0 Votes
    3 Posts
    186 Views
    E

    Resolved. I’m sharing FOG with as many people as I can. Love this project!

  • Regenerate certificate on each installation.

    Unsolved
    2
    0 Votes
    2 Posts
    197 Views
    M

    And I can’t add any hosts—whether via the web interface or by booting over the network—; ultimately, the new host doesn’t appear in the database…

    Failed to query: Error: SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect integer value: '' for column `fog`.`moduleStatusByHost`.`msHostID` at row 1 Error Message: Error Code: "22007", Error Message: ["22007",1366,"Incorrect integer value: '' for column `fog`.`moduleStatusByHost`.`msHostID` at row 1"], Debug: SQL: [629] INSERT INTO `moduleStatusByHost` (`msHostID`,`msModuleID`,`msState`) VALUES (:hostID_0,:moduleID_0,:state_0),(:hostID_1,:moduleID_1,:state_1),(:hostID_2,:moduleID_2,:state_2),(:hostID_3,:moduleID_3,:state_3),(:hostID_4,:moduleID_4,:state_4),(:hostID_5,:moduleID_5,:state_5),(:hostID_6,:moduleID_6,:state_6),(:hostID_7,:moduleID_7,:state_7),(:hostID_8,:moduleID_8,:state_8),(:hostID_9,:moduleID_9,:state_9),(:hostID_10,:moduleID_10,:state_10),(:hostID_11,:moduleID_11,:state_11),(:hostID_12,:moduleID_12,:state_12) ON DUPLICATE KEY UPDATE `msHostID`=VALUES(`msHostID`),`msModuleID`=VALUES(`msModuleID`),`msState`=VALUES(`msState`)
  • REFInd-Initializing - hangs

    43
    0 Votes
    43 Posts
    28k Views
    D

    Just fyi, I resolved my issues with this by turning off DMA protection in the bios/uefi.

  • Image copy hangs at start of copy - PXE boot OK

    Unsolved
    5
    0 Votes
    5 Posts
    289 Views
    T

    @Tom-Elliott I did update to version 1.6.2254 and the first multicast that worked was the first one I tried after the upgrade. This second one is now hanging like the one that prompted this thread.

    Where in the logs can I find any clues?

  • From /images/dev to /images issue

    Unsolved
    5
    0 Votes
    5 Posts
    423 Views
    C

    Encountered the same issue, version: 1.5.10

    I can successfully capture the image and then see the size of it in the web panel but then it’s not being moved to /images/ by fog. Requiring me to move them manually which works but I’m kinda concerned.

    FTP works fine even though I am afraid I don’t understand why I need FTP to move some files inside a directory on a singular server.

  • atheros ipxe woes "No configuration method succeeded"

    Unsolved
    3
    0 Votes
    3 Posts
    238 Views
    C

    @Tom-Elliott thanks Tom - using the excellent fog-docker from 88fingerslukee - so will wait to hear his response

  • Upgraded from FOG 1.5.9 to 1.5.10.1903 and having issues

    Unsolved
    28
    0 Votes
    28 Posts
    3k Views
    Tom ElliottT

    @Strahd Have you been able to make progress?

  • PXE boot menu displaying plain text without graphical UI / background in BIOS mode

    Solved
    3
    0 Votes
    3 Posts
    401 Views
    E

    @Tom-Elliott
    The fix worked perfectly! The menu issue is now resolved.

    Thanks for the support!

  • Storage Node says invalid configuration on FOG dashboard

    Solved
    5
    0 Votes
    5 Posts
    258 Views
    F

    @Tom-Elliott Hi! I updated my FOG server to latest beta-branch version: 1.6.0-beta.3197. I also updated my storage node to 1.6.0-beta.3197. This fixed the invalid path issue I was having. Thank you for the help!

    1a0e5491-b776-49fe-9fbf-d2bc40087f78-image.png

  • 0 Votes
    12 Posts
    780 Views
    F

    @Tom-Elliott Tom, looks like everything has been resolved after going from 2144 to 1.5.10.2218! No errors and I was able to capture no problem. Thanks

  • 1.6 Database update issue

    Unsolved
    4
    0 Votes
    4 Posts
    290 Views
    Tom ElliottT

    @toschulz So I suspect the problem is due to a divergence of db schema between dev-branch/stable + working-1.6

    If you can update yoru Mysql directly:

    sudo mariadb -u root fog (if no root password of course - if you have a root password add -p

    UPDATE schemaVersion SET vVersion=0;

    Then refresh your screen, click the install/update, and hopefully the error will go away.

    The way the schema is configured is it will attempt (idempotently) to rerun every single SQL query in the schema chain.

    This should fix the problem you’re seeing.

    I believe there’s a column on the login history piece being requested that may just simply be missing which would cause the issue with datatables.

  • 0 Votes
    2 Posts
    188 Views
    C

    I have figured out the issue. I was looking in the wrong place in BIOS for the secure boot setting which was on. Turning off secure boot fixed the process which runs perfectly now.

52

Online

12.8k

Users

17.7k

Topics

157.2k

Posts