Fog Client is not updating



  • Server
    • FOG Version: 1.3.0-RC-10
    • OS: Ubuntu 14.04
    Client
    • Service Version: 0.9.12 (although it varies)
    • OS: Windows 7
    Description

    The problem im having here is the client is not auto updating on any of the client computers. I do have the settings enabled on the fog server. Below is what is what i found that i think is causing the problem.

     9/23/2016 11:35 AM Client-Info Version: 0.9.12
     9/23/2016 11:35 AM ClientUpdater Running...
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/servicemodule-active.php?moduleid=clientupdater&mac=B8:AC:6F:2C:06:D0||00:00:00:00:00:00:00:E0&newService=1
     9/23/2016 11:35 AM Middleware::Communication Response: Success
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/getversion.php?client&newService=1
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/client/FOGService.msi
     9/23/2016 11:35 AM Data::RSA FOG Project cert found
     9/23/2016 11:35 AM Data::RSA ERROR: Certificate validation failed
     9/23/2016 11:35 AM Data::RSA ERROR: Trust chain did not complete to the known authority anchor. Errors: A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file. (NotTimeValid)
     9/23/2016 11:35 AM ClientUpdater ERROR: Update file is not authentic
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     9/23/2016 11:35 AM Client-Info Version: 0.9.12
     9/23/2016 11:35 AM TaskReboot Running...
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/servicemodule-active.php?moduleid=taskreboot&mac=B8:AC:6F:2C:06:D0||00:00:00:00:00:00:00:E0&newService=1
     9/23/2016 11:35 AM Middleware::Communication Response: Success
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/jobs.php?mac=B8:AC:6F:2C:06:D0||00:00:00:00:00:00:00:E0&newService=1
     9/23/2016 11:35 AM Middleware::Communication Response: No jobs
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     9/23/2016 11:35 AM Client-Info Version: 0.9.12
     9/23/2016 11:35 AM HostnameChanger Running...
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/servicemodule-active.php?moduleid=hostnamechanger&mac=B8:AC:6F:2C:06:D0||00:00:00:00:00:00:00:E0&newService=1
     9/23/2016 11:35 AM Middleware::Communication Response: Success
     9/23/2016 11:35 AM Middleware::Communication URL: http://10.20.0.9/fog/service/hostname.php?moduleid=hostnamechanger&mac=B8:AC:6F:2C:06:D0||00:00:00:00:00:00:00:E0&newService=1
     9/23/2016 11:35 AM Middleware::Communication Unknown Response: Not Allowed Here```


  • @Timo

    Did you reset the encryption data on the specific host? If not give it a try and report back.



  • Good Morning, i follow the thread, cause i’ve nearly same issues, at last i switched from Git Version 1.3. RC6 to RC11, then i’ve experienced the same issue with the Client Updater

    Tomorrow i’ve done a git pull and rerun the installfog.sh even twice, cause that was the advice from Joe Schmitt.

    Now i encounter the error on an example client “Response ERROR: Unable to get subsection Middleware::Response ERROR: Object reference not set to an instance of an object.”

    how can i fix that? the Client on Windows has updated to 0.11.5



  • @Joe-Schmitt helped me in a private chat just now. My bandwidth has returned to normal. Thanks for the awesome support as always guys.


  • Senior Developer


  • Senior Developer

    @Neil-Underwood Can you attempt stopping the httpd service for say 10 minutes. Then start it up again? This should force the constant “checkins” to fail.

    See the issue, as I see it, is the 0.9 client’s had the potential to go into what I will just call a “timeless” loop.

    So essentially the client is getting the file, trying to install, it can’t do all over again. So it’s not the update causing the problem. Just the client is doing all this very fast causing massive load to the server. Basically, stopping httpd should allow the client to “catch up” if you will.

    Hopefully this works.



  • @Tom-Elliott LOL no offense taken. Yes , I clicked save each time.


  • Senior Developer

    @Neil-Underwood I know this seems a stupid question, but I’ve seen things before. Hopefully you take no insult or offense. Did you click save after toggling the checkbox?



  • @Joe-Schmitt said in Fog Client is not updating:

    @Neil-Underwood Are you sure you disabled the new client updating and not the legacy’s?

    You can find the new client’s auto updater setting at : FOG Configuration -> FOG Settings -> FOG Client -> FOG_CLIENT_AUTOUPDATE. Once applied your network usage should return to normal very quickly.

    Yep. I’ve toggled it and rebooted in between and it is having zero effect. See the screenshots:

    0_1474920354302_Screenshot from 2016-09-26 13:04:55.png
    0_1474920587975_Screenshot from 2016-09-26 13:09:40.png


  • Senior Developer

    @Neil-Underwood Are you sure you disabled the new client updating and not the legacy’s?

    You can find the new client’s auto updater setting at : FOG Configuration -> FOG Settings -> FOG Client -> FOG_CLIENT_AUTOUPDATE. Once applied your network usage should return to normal very quickly.



  • I want to hop on here and add that I’m experiencing the same issue. Mine, however, is not responding when I disable the client updater. It’s still communicating with hosts and trying to push the client out. I came in this morning to find that FOG had tried to push out almost half a TB over the weekend. Take a look at my bandwidth usage:
    0_1474918942582_Screenshot from 2016-09-26 12:41:57.png


  • Senior Developer

    The issue with client updating has been found and a patch is being worked on. The patch will not require any additional work to be done on your side, just a simple server update once ready.


  • Moderator


  • Senior Developer

    @K.Hays . For now you can globally disable the new client’s auto updating feature to lower your bandwith. But I’d need to be able to remote into a machine with this issue inorder to be able to help further.


Log in to reply
 

364
Online

39.5k
Users

11.1k
Topics

105.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.