FOG Client Auto Updating Hotfix


  • Senior Developer

    Starting on September 7th 2016 auto updating of the new client stopped functioning properly. There was a bug in the installer validation code which made the client believe our signed installers were not authentic, that is someone forged them. We have since developed an in-place hotfix ready for immediate use that does not require a server upgrade. You are only affected if you use trunk or a 1.3.0 release candidate.

    HOW TO GET THE HOTFIX
    To patch your server and resume normal auto updating functionality please simply re-run the fog server installer (installfog.sh). You do not need to upgrade your server version, simply re-run the installer. No other actions are required.



  • Worked for me like a charm!
    Good job!


 

437
Online

41.8k
Users

12.4k
Topics

116.7k
Posts