SOLVED Dev-Branch 1.5.9-RC1.3 Ubuntu 20.4 LTS

  • Hello,

    I have noticed a problem after updating to 1.5.9-RC1.3.

    After capturing an image from a Windows 10x64 VMWare Workstation 15.5, it borks the VM. It can no longer finish loading the desktop for the default user. Restarting the VM usually ends up in the Windows frowny face or a Windows repair in which it can not be repaired.

    However the image it captures is good. If I deploy the newly captured image to a new VM or onto the same one everything works fine.

    I was able to duplicate this 3 times in a row.
    Is there more information I could provide to help determine what the cause is?

    Thank you

  • It is not happening anymore. The VM is only 18GB. It takes less than 10 minutes to capture and less than 10 minutes to update FOG. Or visa versa.

    The only weird thing I have since noticed is during the install process, when are asked to go to fog/management and hit update database, that page no longer shows up. It just displays the fog login screen. So I just go back to the installer and hit ENTER. It seems to work fine.

  • Moderator

    @Fog_Newb Wow, that was really quick testing. So you are saying that the issue reported above is not happening anymore?

  • @Sebastian-Roth

    Ok, I deleted my fogproject folder to make sure I got the newest stuff

    git clone /opt/fogproject
    cd /opt/fogproject
    git checkout dev-branch

    Ran the installer/upgrader and captured an image from the VM.
    All good!

    Thank you

  • Moderator

    @Fog_Newb Sorry, can’t see the issue from the partition layout files. You’d need to boot into Windows (or some Live Linux) and take a look at the partitions.

    But as I just updated the latest inits you can better just re-run the 1.5.9-RC1.3 installer and that should pull the new inits for you. See if the problem goes away when using the new inits.

  • d1.partitions.txt d1.fixed_size_partitions.txt d1.minimum.partitions.txt @Sebastian-Roth


    It is possible it could be the same thing that is happening there. There weren’t any errors during the capture process.

    It seems that capturing the image damages the working Windows VM. However, the image that is captured from it is fine and can be restored no problem.

    I tried 3 times in a row. Setting up a rather standard Win10x64 VM . Each time I captured and image from the VM, it would not longer boot into Windows properly.
    I will upload those files that were requested in the other thread.

    [2_1588487227132_d1.partitions](Uploading 100%) [1_1588487227132_d1.fixed_size_partitions](Uploading 100%) [0_1588487227130_d1.minimum.partitions](Uploading 100%)

  • Moderator

    @Fog_Newb It’s possible you run into the same issue reported here:

    Though I am wondering that you say the VM is not booting properly after the capture. But maybe this is due to missing disk space?!