Group Details Private

Moderators

 
  • RE: Unable to PXE Boot to Fog Menu.

    @Technolust I would set the default dhcp options to undionly.kpxe to cover all bios machines, then create a filter for arch 0007 and 0009 that will cover all of the common uefi systems. We have seen some tablets that are 64 bit processors but pinned to 32 bits and report as 32 bits during pxe booting. If you don’t plan on any 32 bit processors then don’t add the filter. Just be aware of some of the tablets if you ever get one.

    posted in FOG Problems
  • RE: Unable to pxe boot Parted Magic Parted_Magic_2018.04.30.iso

    @Steve_BBA You did find one of the limitations with memdisk, in that the iso image has to fit in the 32 bit address space and have enough space left over to run what ever kernels is on the iso image. The other limitation you will have with memdisk is that its bios mode only. There isn’t an equivalent boot environment for uefi AFAIK.

    But well done getting it worked out.

    From your initial error message was that it can’t find the initrd to boot from. This is me just guessing but I don’t see a kernel parameter in the imgargs that points to your initrd image. Also be aware that the format you used in your initial post isn’t sufficient for uefi booting. You need to use the -n <file_name> option for each line.

    ref: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/10

    posted in Linux Problems
  • RE: Problems with Optiplex 5260 in an advanced PXE environment

    @george1421 OK this problem is making my head explode.

    In your main pxe boot server, I assume you have a menu entry that points to the FOG server. The issue we have is we need to replace the in memory iPXE kernel with the FOG iPXE kernels (like what you did when you changed the dhcp option 66 and 67).

    So in your main pxe boot server for the menu entry for FOG see if this replaces iPXE with FOG’s iPXE.

    :call_fog
    set next-server <fog_server_ip>
    iseq ${platform} efi && set filename ipxe.efi || set filename undionly.kpxe
    chain tftp://${next-server}/${filename}
    

    That should chain load the fog iPXE kernel. There is an embedded script in the FOG iPXE kernel here: https://github.com/FOGProject/fogproject/blob/master/src/ipxe/src/ipxescript

    Its a generic script, the only thing we have to pay attention to is line 29.

    chain tftp://${next-server}/default.ipxe ||
    

    What that script will do is again acquire the pxe boot server {next-server} from dhcp, which will point back to your main pxe boot server, but ignores dhcp option 67 and calls default.ipxe. On your main dhcp server you need to create a new text file called default.ipxe and in it place this script

    #!ipxe
    chain tftp://<fog_server_ip>/default.ipxe
    

    That should call the fog based ipxe boot script, you will be running under the FOG iPXE kernel done by the fist chain, and the second chain will jump you into the FOG iPXE menu.

    Will it work?? Maybe /maybe not but it sounds good on paper.

    posted in General Problems
  • RE: Unable to reset web login

    The wiki page you linked earlier should allow you to log into the web console. You might have to reboot he FOG server after you reset the password in the database because of the way FOG cache’s recent activity.

    https://wiki.fogproject.org/wiki/index.php?title=Reset_WebUI_FOG_password

    From the wiki this command should do it for you.

    UPDATE users SET uPass = MD5('password') WHERE uName = 'fog';
    exit;
    

    I do have to say FOG 1.2.0 running on ubuntu 12.04 is really old. Unless you really need access to the images stored on that server, I (personally) would just spin up a new FOG server using a current build. FOG 1.2.0 doesn’t support win10, uefi firmware, nvme disks, or current hardware. If you need the images from the FOG 1.2.0 server you can copy them over to a new fog server and use them.

    posted in FOG Problems
  • RE: Unable to PXE Boot to Fog Menu.

    @Technolust Umm, there is only one iPXE boot kernel for bios (undionly.kpxe) the kernel is 32 bits so it will run on both 32 and 64 bit systems. UEFI is the unique one where there is a kernel for 32 bits (/i386/ipxe.efi) and 64 bits (/ipxe.efi). Understand there are 2 64 bit type systems arch code 0007 and arch code 0009 that you need to create a rule for. Arch type 0006 is for 32 uefi and Arch 0 is for bios.

    Just for reference:

               Type   Architecture Name
               ----   -----------------
                 0    Intel x86PC
                 1    NEC/PC98
                 2    EFI Itanium
                 3    DEC Alpha
                 4    Arc x86
                 5    Intel Lean Client
                 6    EFI IA32
                 7    EFI BC (EFI Byte Code)
                 8    EFI Xscale
                 9    EFI x86-64
    
    posted in FOG Problems
  • RE: Unable to PXE Boot to Fog Menu.

    @Technolust Without sounding snarky, it will help you more than it will help me.

    Follow this guide for configuring your dhcp server to dynamically support both bios and uefi systems that are pxe booting. https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Using_Windows_Server_2012_.28R1_and_later.29_DHCP_Policy
    By following those instructions your dhcp server will hand out the right boot file name based the type of computer it is.

    But to answer your original question the boot file for uefi 64 bit is ipxe.efi. The correct boot file for bios based systems is undionly.kpxe typically.

    posted in FOG Problems
  • RE: Problems with Optiplex 5260 in an advanced PXE environment

    Please understand I’m not faulting anything at the moment. What we have is a puzzle and I’m trying to find all of the bits that makeup this environment. I think there is a solution here, we just need to find the right combination.

    Looking back over our chat session the OP kept saying iPXE but my intuition was telling me syslinux. Then I looked back for the dhcp config file posted.

    option tftp-server-name “172.16.0.8”;
    option root-path “/data/tftpboot/”;
    next-server 172.16.0.8;
    filename “pxelinux.0”;
    
        if option arch = 00:06 {
                filename "efi32/syslinux.efi";
        } else if option arch = 00:07 {
    filename “efi64/syslinux.efi”;
                filename "ipxe.efi";
        } else if option arch = 00:09 {
    filename “efi64/syslinux.efi”;
        } else {
                filename "pxelinux.0";
        }
    }
    

    There may be some formatting errors above that chat did to the config file, but I can clearly see syslinux kernels being called. The OP also made reference to pxelinux.cfg in the chat. Which again is a syslinux thing.

    posted in General Problems
  • RE: Unable to PXE Boot to Fog Menu.

    @Technolust Before I answer you, please answer this: What dhcp server are you using (manufacturer and version)?

    posted in FOG Problems
  • RE: Problems with Optiplex 5260 in an advanced PXE environment

    @Sebastian-Roth OK I have a bit more understanding what is going on here.

    The OP has 2 iPXE boot servers. He has a main one that does other things already. He has setup a chain statement in his main pxe boot server to load boot.php from the FOG server. So the booting process is still under control of the iPXE kernel running from the primary pxe boot server (not-FOG server). If he updates his dhcp server to point to the FOG server this Optiplex 5260 pxe boots correctly. If he chain loads from his main pxe boot server to fog it fails. According to the OP the chain loading works with other hardware, just not with this specific model.

    From his existing iPXE boot server he is using this command to chain: chain http://x.x.x.x/fog/service/ipxe/boot.php?mac=${net0/mac}

    The version of iPXE running on his main pxe boot server is 1.0.0 1b104 (pretty old).

    For bios based systems the OPs using pxelinux.0 for uefi based systems its ipxe.efi (on the main pxe boot server).

    So to make this work, we need to get his main pxe boot server to load the proper iPXE kernels from the FOG server to support iPXE booting or possibly replace the iPXE boot kernels on the primary PXE boot server with the newer ones from the FOG server. The only question is if the built in iPXE script in the FOG iPXE kernels would cause his main pxe boot server problems.

    I know I talked in a circle here. I needed to get everything down in one place do see if we can come up with a solution.

    At this time I don’t feel its a FOG component level issue, but the OPs environment.

    One possible solution would be to use the FOG server as the main pxe boot server and then just migrate the menus from the existing main server to the FOG server.

    posted in General Problems
  • RE: Problems with Optiplex 5260 in an advanced PXE environment

    @Sebastian-Roth Just a second on chat with OP. He has a different configuration than we are expecting.

    posted in General Problems