multi-network cloning with 1 server



  • Networks are not physically connected.

    On first network FOG act as DHCP
    Second network has it own DHCP server.

    Everything work good on first network

    On second network dhcp options next-server and 67 are configured? so client connect and download from tftp normally, but from ipxe client is receiving address of first network.

    I tried to edit file default.ipxe and changed hardcoded ip address to dns name. After this clients from both networks can start fog menu, but from second without background image.

    The next problem is that I can not deploy the image in the second network as by pressing the button Deploy image (on client side from fog menu), client again receive hardcoced IP address of first network.

    Total I have a fully working server on the 1st network and not working in the second network.
    How to configure FOG to work in 2 networks?



  • @Sebastian-Roth I can assist with the isc-dhcp configuration. I have a box here at home with two NICs I can test on, and I have a couple of spare routers and other spare computers laying around. My availability will be limited Friday through mid next week though, I’m heading out of town to visit the folks.


  • Developer

    @vsc1t We have had several requests for multihomed support of FOG in the last months. Possibly something that we can look into but I suppose this would be a lot of work to code properly and make it work in all situations and I don’t see we have the capacity to do so. If people are interested and join in to help I would go ahead and give it a try.

    Just cross-linking the other posts here so we can get together and talk about it:
    https://forums.fogproject.org/topic/12580/multi-network-cloning-with-1-server (just came today)
    https://forums.fogproject.org/topic/11384/multicast-on-multihomed-server ( @bongasicdn7 has achieved most of it on his own - Can you elaborate more on how you initially setup FOG to make client PXE boot work?)
    https://forums.fogproject.org/topic/12463/network-bonding-with-fog ( @danuel are you still keen to make this work and willing to help?)
    https://forums.fogproject.org/topic/5695/fog-server-multi-home (old topic but for reference)



  • @Sebastian-Roth

    $ip a s
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 08:00:27:68:16:78 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.2/24 brd 192.168.1.255 scope global noprefixroute dynamic enp0s3
           valid_lft 5677sec preferred_lft 5677sec
        inet6 fe80::971a:3ed0:398c:508c/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 08:00:27:21:31:27 brd ff:ff:ff:ff:ff:ff
        inet 192.168.56.101/24 brd 192.168.56.255 scope global noprefixroute dynamic enp0s8
           valid_lft 990sec preferred_lft 990sec
        inet6 fe80::696d:9af6:dacf:126c/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    4: enp0s9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 08:00:27:e0:79:5a brd ff:ff:ff:ff:ff:ff
        inet 172.30.0.1/24 brd 172.30.0.255 scope global noprefixroute enp0s9
           valid_lft forever preferred_lft forever
        inet6 fe80::a00:27ff:fee0:795a/64 scope link 
           valid_lft forever preferred_lft forever
    

    172.30.0.1 - here FOG is DHCP server
    192.168.1.2 - there is another DHCP server.

    when a client is booting from 172.30.0.0 - ok
    when a client is booting from 192.168.1.0 - it can connect and download from TFTP. Then to continue booting client is receiving http://172.30.0.1/.../boot.php
    I changed 172.130.0.1 in file default.ipxe to the hostname of FOG.

    After this clients from both networks can start fog menu, but from 192.168.1.0 without background image.

    The next problem is that I can not deploy the image in the 192.168.1.0 network as by pressing the button Deploy image (on the client side from fog menu), client again receive hardcoded IP address 172.30.0.1

    Networks are not connected.


  • Developer

    @vsc1t said in multi-network cloning with 1 server:

    Even if DHCPd is stoped client is receiving IP address of FOG from the second network via iPXE

    From what you write I still see a lot of confusion on what you really try to achieve and what your setup looks like. Please draw a picture of your whole (network) setup and post here. As well you might run ip a s on your FOG server and post output here so we better understand.

    Second network has it own DHCP server.

    What kind of DHCP server is this? Are those two networks connected through a router or switch? Different subnets or same subnets?



  • @Sebastian-Roth

    But what you actually should look into is setting up a storage node in your other network, hmmm?!
    Yes, it sounds like the best way. Could you give me some link with instructions for setup and configure network node?



  • @Wayne-Workman No it doesn`t work. Even if DHCPd is stoped client is receiving IP address of FOG from the second network via iPXE


  • Developer

    @Fernando-Gietz @Wayne-Workman From what I read between the lines the OP is asking about setting up a so called multi-homed server, so two separate network interfaces configured to host two different subnets.

    @vsc1t Is my assumption correct? While I see that people might want to setup FOG like this I am not sure if we can guide you through the whole process of setting this up. It’s not what FOG is made for and it definitely needs some manual work. I have never done this before but I guess it can be done if you know the bits and pieces and have coding skills.

    But what you actually should look into is setting up a storage node in your other network, hmmm?!


  • Developer

    I am not expert in network but we have a multi-vlan scenario. You need to define the ip-helpers (https://learningnetwork.cisco.com/thread/75587) in the vlan. If you don’t define the iphelper in your vlan, the computers which are in the second vlan don’t reach to the ipxe server (your FOG server that is in the first vlan).



  • @vsc1t said in multi-network cloning with 1 server:

    On second network dhcp options next-server and 67 are configured? so client connect and download from tftp normally, but from ipxe client is receiving address of first networ

    Sounds like DHCP is still running on the FOG Server on the second network.

    How do you have this setup? Does the fog server have two NICs? I’m suspecting no, and if it’s no, then DHCP is still being served when you connect to the second network. You just need to turn off the DHCP service when you don’t need it, turn it back on when you do:
    systemctl stop dhcpd
    systemctl start dhcpd


 

581
Online

5.4k
Users

12.6k
Topics

118.8k
Posts