Invalid promptTime (Grace Period)



  • Hello guys, I have been playing with FOG for about 2 to 3 weeks, I have it all functional, but whenever I set the Grace Period above 600, the Client logs tell me “PM Service ERROR: Invalid promptTime, using default”, naturally the default time is 60 seconds, but I wanted to make it something like 3 or 4 hours, is there any setting anywhere that would allow me to do that? I want the tasks forced but I want people to have plenty of time to save whatever they need saved.



  • @Wayne-Workman I agree with you, in working in a lab environment in which we perform all kinds of penetration/defensive tests, I need people to be able to save their work before their stuff gets nuked. It wouldn’t hurt anything to have free control of how long the pop-up will stay up.


  • Senior Developer

    @Wayne-Workman Already on it. 0.11.6 will feature a new style shutdown prompt.



  • @george1421 said in Invalid promptTime (Grace Period):

    The user is notified every 10 minutes

    That’s a good idea. @Joe-Schmitt, could you do that?


  • Moderator

    While I don’t use this function so I can only guess what it does (like a software install or a forced reboot?). I can suggest that the user be prompted to do what ever, the user should have the option to delay it up to the maximum the admin has set for the job. I.E. your computer must be rebooted. The user is notified every 10 minutes up to the 4 hours max the admin has set. When that time is reached the action is carried out and the user can’t stop it. That is typically how managed deployments work with the commercial applications. With most commercial applications the user is allowed to adjust when the nag messages appear up to the max dwell time then the job is forced.



  • I’d say 8 hours.

    @Tom-Elliott The Web Interface should not allow a value beyond the maximum to be stored.

    In the end - really, truly - it should be whatever the Admin wants it to be. It’s integers on a monitor - what does it matter to anyone else if I want mine to be 30 seconds, and John Doe wants his to be 8 hours? I don’t care about what John Doe is doing, he’s a sys-admin doing what he thinks is best for his environment, for his use case.

    I would say no more than 8 hours allowed for any setting - because beyond that and you’re approaching tasks not getting done by the next day.

    I say - set a maximum of like 8 hours for each field, but set the defaults to something reasonable, I like what they are now - the defaults are reasonable.



  • @Joe-Schmitt if it’s an easily modifiable setting I would simply like to know where it is, I want to be able to select hours, for example 5 hour Grace time, and possibly be able to control the max delay time also, increase the 10 minutes to perhaps an hour.


  • Senior Developer

    @Joe-Schmitt 10 minutes is not enough? Personally I don’t think Developers should be a part of this.


  • Senior Developer

    @davidedpg10 You are correct that the current max prompt time is 600 seconds. @Developers @Moderators @Testers what would be a better maximum shutdown prompt time?



  • @davidedpg10 My FOG Server is Version 1.3.0-RC-8, thanks for the suggesting I state it. @george1421
    The FOG Client associated with it seems to be 0.11.5


  • Moderator

    While I don’t have an answer for you, please post what version of fog you are running that will help set the scope of the issue correctly.


 

499
Online

41.6k
Users

12.1k
Topics

114.4k
Posts