FOG Client 11.2 upgrade from 10.6



  • Windows:
    Deployed an image with client 10.6 in it to a few machines. After the client updates to 11.2, there’s a file called “C:\Program” which looks like a snippet of the updater log

     6/26/2016 8:35 PM UpdaterHelper Shutting down service...
     6/26/2016 8:35 PM UpdaterHelper Killing remaining processes...
     6/26/2016 8:35 PM UpdaterHelper Applying update...
     6/26/2016 8:35 PM UpdaterHelper Starting service...
    

    Windows 10 seems to not like that and complains @ login. Anyone else?



  • @Joe-Schmitt

    Makes sense, and I had suspected as much.

    Thanks!

    PS snapin if anyone needs it.

    Start-Transcript -path c:\SnapinLogs\CleanupUpdaterLog.log
    $strFileName="c:\program"
    If (Test-Path $strFileName){ Remove-Item $strFileName }
    Stop-Transcript
    


  • @Joe-Schmitt Ah. Much more clear.


  • Senior Developer

    This issue was addressed in v0.11.2. As I mentioned in the other thread concerning this issue, auto updating patches don’t take place until the next release. What I mean by that is since v0.10.6 was installed, v0.10.6 auto update code runs, not v0.11.2. When v0.11.2 performs an upgrade to something newer, then that patch will run.

    And again, as I mentioned in the other thread, a band-aid for your client that upgrade to v0.11.2 is to simply make a snapin script that deleted the file if it exists.

    This issue can only occur on Windows with a non root log.



  • @joe-schmitt I thought that the c:\program thing was going to be cleaned up by 0.11.2 (or 1 or 0) ?



  • just checked back on my image, having the fog log set to the default root of C, doesn’t give the windows prompt about the Program file. I do believe, Wayne, the Program file is still showing as of 0.11.2 on update.

    I turned on the auto updater for the client, and it updated from 10.6 to 11.2, it would leave the Program file there. I also had it set to do the install directory and not the root of C:


  • Testers

    @Wayne-Workman I realize it is important, but I got burned by updating quickly before. I had to recreate most of my images due to the constant failing of sysprep due to the service. I know the setupcomplete.cmd method was already best practice (I was unaware of this at the time), but 10.6 made it mandatory. I’d like to have some control over it.




  • Testers

    @Wayne-Workman I had it as well. Luckily it only affected one image for me. I was able to boot into a live CD of Puppy linux and delete it from there. Exact same situation though, 10.6 to 11.2. This could have been bad if it was all of my images. That would be over 500 PC’s to correct… I also am wondering why it is updating automatically still. I have my global client updater setting disabled, but on all of my hosts under service configuration, it is checked and grayed out.



  • @adukes40 0.11.2 was supposed to clean this up…



  • I had that as well. It seems if you told the client to put the log in the install directory, it still creates the program file in C:. I just placed the new client on my master images over the weekend, and told the log to install to C:. I am imaging right now to test this.

    It has been recommended if this does occur to have a script delete the additional “Program” file in the root of C:. I will also comment back to verify changing the location from the install directory to the default root of C causes the extra file to disappear.


 

458
Online

41.4k
Users

11.8k
Topics

112.0k
Posts