HP EliteDesk 800 G2 compatibility



  • Hi everyone,

    I’m trying to find out if the HP EliteDesk 800 G2 is able to work with FOG. We are at 1.2.0 (Kernel 3.6.3). We have been chugging along here for a little over a year with the 800 G1 models and as well as numerous HP desktops and laptops and all is still well aside from the G2’s. I am not able to register from the host and the scheduled Instant deployment fails after adding the host from the console (“Failed to mount NFS Volume”).

    Thanks in advance for any help.



  • @the_great_heed I’m using the trunk version, not 1.2.0, so I’m not sure. This will become our production FOG server since we are adding another 600-700 G2 SFFs.


  • Testers

    @the_great_heed Also, do you know if you’re booting to legacy pxe or uefi pxe?
    UEFI mode would require using a bootfile like ipxe.efi and would also require a image made with efi.
    Make sure secure boot is disabled and legacy mode is enabled in the bios boot settings.


  • Testers

    @the_great_heed I have a hp elitedesk 800 g2, it’s my personal work computer. It worked for me. I am on the trunk (so, latest kernels for sure) and I used the bootfile ipxe.kpxe and you can also try ipxe.kkpxe I believe the driver stuff would all be handled by the fog kernel, but you could also consider upgrading to the latest fog ipxe files too. Granted I would recommend just upgrading to trunk, but if you don’t want to do that (but you should want to do that), you could just download the newer ipxe boot files from here https://github.com/FOGProject/fogproject/tree/dev-branch/packages/tftp and put them in /tftpboot of your fog server. (Backing up the current ones of course)

    Also, with the g2’s there is the option to have them come with nvme drives (I think HP calls them turbo pci-e ssd’s or something like that). If that’s the case you’re going to need to update the trunk to get them to work.

    But it sounds like maybe the kernel update didn’t take. It’s probably worth noting that linux is case sensitive, so if you’re typing bzimage instead of bzImage then you’ll be getting bad juju.


  • Senior Developer

    Forgive me, but are you using a more updated kernel?

    The commands that @george1421 suggested will work, but if you’re in the directory and don’t implicitly tell the file to download TO, it will create a file of: <filename>.<number of file matching original>

    For example, in /var/www/html/service/ipxe/ if you have bzImage and you run:

    sudo wget https://fogproject.org/kernels/bzImage and bzImage is already in the location it will create the file as bzImage.1, or how many other revisions there are.

    To download it as the file you need run:
    sudo wget https://fogproject.org/kernels/bzImage -O /var/www/html/service/ipxe/bzImage
    and
    sudo wget https://fogproject.org/kernels/bzImage32 -O /var/www/html/service/ipxe/bzImage32

    My guess is you’re simply not using a newer kernel quite yet and the NIC simply isn’t being found as you’re still in the same place as when you opened this thread.



  • @the_great_heed try undionly.kkpxe



  • Not sure if this info would be relevant feedback.

    0_1464876886498_fog_config.PNG



  • @RLane Is there any other specific changes you had to make to get thus model working properly?



  • It is not @Sebastian-Roth . I’m kind of at a stand still with this one.


  • Developer

    @the_great_heed So is this solved now?



  • Right in front of me @Wayne-Workman . Thank you.



  • @the_great_heed Network boot, and it’ll either be right there in front of you or in the advanced menu.



  • Thank you @george1421 , @Wayne-Workman , @RLane . We are now using the new kernel. Unfortunately, I’m still having the issue only with this particular model. Not to sound like an ignoramous but how do I check the compatibility of the target computer by “selecting the compatibility test from the FOG iPXE boot menu”?



  • @george1421 Can confirm that this is the fix. Recently just deployed 650 EliteDesk 800 G2 SFF’s and upgrading to trunk (using the newer kernel) fixed it.


  • Moderator

    Looking at the specs for this unit it is using a newer Intel I219LM nic. You need to use a newer FOG kernel (bzImage) than 3.6.3. Since you are using 1.2.0 (stable) you can use the latest 4.5.3 kernels. You can download them manually by:

    1. On the FOG going to /var/www/html/fog/service/ipxe
    2. renaming bzImage and bzImage32 to something else
    3. Executing these commands sudo wget https://fogproject.org/kernels/bzImage and sudo wget https://fogproject.org/kernels/bzImage32
    4. Reboot the target computer.

    You should also check the compatibility of this target computer by selecting the compatibility test from the FOG iPXE boot menu.



  • The error “Failed to mount NFS Volume” sounds more server related than host related - but it could be either.

    You should check to see if you can still image with a known-good model, first.

    Here, we have some older EliteBook 8730w laptops that FOG works with fine.

    It could possibly be a kernel issue, you could try updating your kernel or updating to FOG Trunk.

    https://wiki.fogproject.org/wiki/index.php?title=Kernel_Update
    or
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk


 

604
Online

5.4k
Users

12.6k
Topics

118.8k
Posts