*Attempting to send inventory............ FOREVER?



  • On quick or full inventory submit to register device I’m getting the Attempting to send inventory error which lasts till I unplug the computer (ouch). Either way any know how to fix this or have any ideas - if you need any more feed back from me let me know. Haven’t slept yet tonight as I was hoping to test this out.



  • @george1421
    and it works! Thanks very much , 4.1.2 did the trick :)



  • @george1421
    sorry to dig up the zombie thread! I thought some context might be helpful :)
    Looking at the fog web UI it says version 1.2.0, I’m not sure if thats the “stable” release or not, I’ll see if I can find out. In any case I’m about to test the 4.1.2 and I’ll post here with results.


  • Moderator

    @Rama Wow you are reviving an long dead thread here.

    I would strongly suggest that you start a new thread since info shared in this thread is probably not valid anymore.

    BUT, some things to consider. What version of FOG are you using? If you are using FOG 1.2.0 stable then the newest kernel you may safely used is 4.1.2 (which should contain the driver you seek). Kernels 4.4.x and greater can only be used on the trunk build of fog 1.2.0 or fog 1.3.0-rc series.

    If you run a compatibility test, does it report both nic and hard drive passing the test?



  • I am having the same error with a new model HP Elitebook 840 G3. Is it possible that the NIC is simply too new and the driver isn’t in the kernel yet?
    I’ve tried the latest kernels (4.6.2 and 4.6.4) and they do not resolve the issue.
    The network hardware details are:
    Intel I219-V
    HardwareID: PCI\Ven_8086&DEV_1570&subsys_8079103C

    Some other sites are recommending a “3.16 backport kernel” as having the driver needed?

    Thanks.
    Rama


  • Senior Developer

    As another addition to this particular issue, while rather dated, it still happens today. You can actually correct this issue, if you know the kernel has the appropriate network drivers for your client machines, by looking at the /var/www/{fog||html/fog}/service/auto.register.php file.

    To help with troubleshooting if it’s this file and the web related configurations, look at your apache error logs when the host is attempting to send inventory. You can actually keep the system in this state. Once you make the configuration correct, it will actually inventory the host as expected even though it was, seemingly, stuck in a loop.



  • [quote=“Duffney, post: 508, member: 194”]Where you ever able to figure out the problem or did you have to reinstall. I am getting the same error message, I however have updated the kernel and it was successful you probably needed to update your login password.[/quote]

    Thank you. It was just that simple. After updating the Kernel I went under User Management and typed in the same password, update then boom!!!



  • Thanks Amir, it helped me too! :)



  • [SIZE=4][B][URL=‘http://fogproject.org/forum/members/chavenor.72/’]Chavenor, [/URL][/B][/SIZE]

    The cause of this issue might be related to the configuration file located at /tftpboot/pxelinux.cfg/default. Take a look at the parameter under FULL HOST REGISTRATION sub menu and make sure the IP address of the FOG Server that the host is trying to resister is the correct IP address of your FOG Server. in order to do this go to Terminal and type: sudo vi /tftpboot/pxelinux.cfg/default. If the IP address of your FOG Server is not what its suppose to be then make the changes, save your config, exit and then type: sudo /etc/init.d/networking restart.

    Hope this helped.



  • I find if the full inventory fails the quick inventory will still work most of the time. It could be you need a kernel update as suggested above me.



  • Where you ever able to figure out the problem or did you have to reinstall. I am getting the same error message, I however have updated the kernel and it was successful you probably needed to update your login password.



  • Yeah in middle of reinstall right now - going to setup RAID as well - don’t have my giga NICs cards in the mail yet but when I get them i’ll bond em up and now i’ll really be cooking. – I’ll keep you posted on this.

    Works for me!!!


  • Developer

    Without more information on your setup, it’s hard to advise.

    If you are getting errors about connecting, do some troubleshooting and try to manually connect.

    Reinstalling is always an option if you are at an unknown state.



  • I tried the latest Kernel - got this msg… The file was downloaded successfully. I did the WebUI install from another computer and not on the server.
    Error: Unable to connect to tftp server.

    Blackout - I had a bunch of issues getting everything lined up and I install the fog setup a bunch of times should I just wipe the entire computer and start from scratch from this tutorial? [url]http://community.spiceworks.com/how_to/show/373[/url]

    Thanks for you fast response - I’m excited to get this up and running!


  • Developer

    It looks like the kernel is having issues detecting your hardware. Have you tried another Hardware Set?

    I would upgrade your Kernel: WebUI > Other Information > Kernel Updates

    Grab the latest, also try the latest PS build.



  • I took video of the processes for the inventory where it hangs - you might have to slow it down a little to see all the echos. – Does everything here look right?

    Inventory Process quick.
    [media=youtube]gYlgsQBfrrM[/media]

    Inventory Process full.
    [media=youtube]WHPw2VKLT7o[/media]


Log in to reply
 

462
Online

39183
Users

10832
Topics

103075
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.