SOLVED Fog issue with new Dell optiplex 7040


  • A previous sys admin setup fog (1.0.1 on Ubuntu 14.04) for my company a few years ago. We have had no issues until we just switched to new Dell optiplex 7040’s. Now when I try to inventory the computer so I can create an image it gets stuck on the sending of inventory info. Then if I try to update the kernel from the management website I get no results.

    I have searched around for a fix for several hours but I have had no luck. Any suggestions?

    thanks


  • We were able to get the stuff figured out. YAY!

    The connection is now operational. FOG Interface displays properly.


  • @Sebastian-Roth I know the password. I have tried to enter it into the .fogsettings several times and I still get the same error when logging into fog

    0_1458849462592_upload-adc0b8e4-9a18-41cc-bc75-2101c4a402f5

  • Senior Developer

    So I guess there was a password set in your database from FOG 1.0.1… too bad that the “old” Config.class.php (upper case ‘C’) file is not where it should be.

    You need to somehow find out your DB credentials. Try connecting using the command line client:

    mysql --user=root -p
    Enter password:
    ...
    mysql --user=fog -p
    Enter password:
    ...
    

    Try different passwords (as well empty by just hitting ENTER on the password prompt) till you find the correct login credentials! As well try the password from your last screenshot (maybe with user ‘fog’).


  • @Tom-Elliott I removed the password from config.class.php but that did not work. Should I also remove the password from .fogsettings?


  • @inafog9 in the Config file remove the password from the database_password line


  • @Sebastian-Roth What should I be looking for?

    0_1458846510256_upload-e2f17cd3-8016-4252-a679-1133633e6b3f

  • Senior Developer

    Check the credentials in /var/www/html/fog/lib/fog/config.class.php


  • @Sebastian-Roth I ran both commands but I’m still not able to get past the Database Schema Installer / Updater.

  • Senior Developer

    Well there is old and new installation mixed up now… ls -al /var/www/html/fog/lib/fog/config.class.php

    And better change the ownership of the new www files: chown -R www-data:www-data /var/www/html


  • Senior Developer

    @inafog9 Please show us what you see from those two commands: ls -al /var/www and ls /var/www/fog/lib/fog

    In FOG trunk all the filenames are lower case so it might be: /var/www/fog/lib/fog/config.class.php


  • @Tom-Elliott I was looking for an answer and I noticed I do not have /var/www/fog/lib/fog/Config.class.php. Could that be my issue?


  • @Sebastian-Roth I had to use my root password to access.

  • Senior Developer

    @inafog9 Can you connect to the database using the mysql command line client? mysql --user=root -p (for empty password just hit enter on password prompt)

    Don’t empty all the mysql settings in .fogsettings!!!

    ...
    snmysqluser='root'
    snmysqlpass=''
    snmysqlhost='127.0.0.1'
    ...
    

  • @Tom-Elliott I removed the password from the file but i’m still prompted to update the database and I get the same errors. I’m not sure if there was a password used.

    0_1458838284840_upload-984031d2-a232-4389-af5d-02efaea6ed57


  • @inafog9 Check your /opt/fog/.fogsettings file. Look for the snmysqlpass= field.

    If you don’t have a mysql password set, delete the contents of that line so it reads as snmysqlpass=''


  • @Tom-Elliott I was able to get past the report section. Once it got to the database portion it said successful but lots of errors. I was not prompted to enter root password.

    pdate ID: 1 - 0
    
    Database Error:
    
    Access denied for user 'root'@'localhost' (using password: YES), Message: Check that database is running
    Database SQL:
    
    CREATE DATABASE fog
    Update ID: 1 - 1
    
    Database Error:
    
    Access denied for user 'root'@'localhost' (using password: YES), Message: Check that database is running
    Database SQL:
    
    CREATE TABLE `fog`.`groupMembers` ( `gmID` int(11) NOT NULL auto_increment, `gmHostID` int(11) NOT NULL, `gmGroupID` int(11) NOT NULL, PRIMARY KEY (`gmID`),
    KEY `new_index` (`gmHostID`),
    KEY `new_index1` (`gmGroupID`) ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1 ROW_FORMAT=DYNAMIC
    Update ID: 1 - 2
    
    Database Error:
    
    Access denied for user 'root'@'localhost' (using password: YES), Message: Check that database is running
    Database SQL:
    
    CREATE TABLE `fog`.`groups` ( `groupID` int(11) NOT NULL auto_increment, `groupName` varchar(50) NOT NULL, `groupDesc` longtext NOT NULL, `groupDateTime` datetime NOT NULL, `groupCreateBy` varchar(50) NOT NULL, `groupBuilding` int(11) NOT NULL, PRIMARY KEY (`groupID`),
    KEY `new_index` (`groupName`) ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1
    Update ID: 1 - 3
    
    Database Error:
    
    Access denied for user 'root'@'localhost' (using password: YES), Message: Check that database is running
    Database SQL:
    
    CREATE TABLE `fog`.`history` ( `hID` int(11) NOT NULL auto_increment, `hText` longtext NOT NULL, `hUser` varchar(200) NOT NULL, `hTime` datetime NOT NULL, `hIP` varchar(50) NOT NULL, PRIMARY KEY (`hID`) ) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1
    

  • @inafog9 No, you should be able to just run svn up from the root of the trunk folder: /opt/fog/trunk (or wherever it’s located).

    Running svn up in the bin won’t update all the other folders below it.


  • Sure, Do you want me to run the entire trunk upgrade again? Starting with downloading the svn?

250
Online

8.8k
Users

15.5k
Topics

144.4k
Posts