Kernel for Ubuntu 64 bit

  • @george1421 Not that I am aware of. I can try a laptop Dell E7240
    and post results.

  • Moderator

    @Tom This one is now interesting, it goes without saying that this system should not cause the kernel to panic. This is an older and stable system. It worked with fog 0.31 and that kernel (understand that 0.31 kernel was almost 8 years old).

    Can you say that all 990s are doing this or is it just then one system? This question is leading in that is the kernel not compatible with this model or is there something wrong with the hardware specifically on THIS unit.

  • @george1421 Fog version 6179

    Booting in bios mode, Bios is up to date.

    Before I had fog 3.1 on Ubuntu 10.1 - there were no issues.

    Thank you for your patience.


  • Moderator

    @Tom Lets make sure we are on the same page here. Your FOG is update to date. What is the number on the cloud on the fog management gui?

    What is actually having the kernel panic is a Dell 990, which is somewhat old. Its on par with the Optiplex 790. I can say (from my experience) that the 790s boot without issue.

    Are you booting these 990s in BIOS mode or efi? This generation of desktops were the first with EFI mode.

    Has the bios been updated on this 990 since it was purchased?

    Have you used or booted FOG before on this system or any other target computer at your location?

  • @Tom-Elliott The target machine is physical OptiPlex 990. Fog is VM.
    Not sure how to proceed?

  • Senior Developer

    @Tom change the VM OS food using Windows 7 32-bit

  • Senior Developer

    Please run ls -al /var/www/fog/service/ipxe/init* ; ls -al /var/www/fog/service/ipxe/bzImage* on your FOG server and post the output here.

  • Senior Developer

    @Tom is the panicking system a VM?

  • @george1421 Yey, my fog is up to date. I’m still getting kernel panic - not syncing.
    What can I do?



  • Moderator

    @Tom Nope thats right, except you would do that typically from svn/trunk then run the svn up command, if it is current then it will tell you latest version. Once the svn has been download you change to svn/trunk/bin and run the installer again in that directory. That will update the main fog software on your server.

    Just running the svn up command, just downloads the updated install files from svn. You still need to install the update.

  • @george1421 Here is what I’ve done:

    Navigated to svn/trunk/bin
    then svn up
    it says at revision 4754 - which is stated as the latest svn version.

    What am I doing wrong?

  • Moderator

    @Tom Once you do the svn up command then you need to change to the bin folder and run ./ (or what ever the installer is titled, long day short on brain juice). You will run through the fog install again, but all of the questions will be answered. You may have to key in a url to update the database if required.

    If you refer to the numbers in the cloud on the fog management page that should be consistent with the git number. SVN was down for a while so the numbers got out of sync.

  • Thank you all,

    First, the target is Dell OptiPlex 990.

    Here is my confusion: I installed the trunk svn from the link that is on wiki. When checking fog configuration it states:
    You are currently running version: 6098
    Latest stable version is 1.2.0
    Latest svn version is 4754
    Latest git version is 6179

    if I installed the svn version, should it say 4754?

    I tried the SVN UP command (found on wiki), and I did not get upgraded.

    Can someone please can clarify this and provide instructions how to upgrade?



  • Moderator

    @Tom said:

    @george1421Thank you, it shows 6098, I will try to upgrade

    Also please indicate what target computer you are working with both make and model.

  • Senior Developer

    FOG comes with 32 and 64 bit kernel for the clients. No need to build your own - usually. The kernel panic you see usually occurs when the initrd file was not properly downloaded with the installer script. Try upgrading to the latest and keep an eye on the output when running the installer. It should say “Downloading kernel, init…” somewhere. Hope this time those are loaded properly.

  • @george1421Thank you, it shows 6098, I will try to upgrade

  • Moderator

    What target system are you trying to quick register?

    I’d have to check to see if you are on a current version or not. I thought the numbers were higher than 6098.

    I just refreshed by dev system and 6179 is what is in the cloud on the FOG management gui page.

Log in to reply