Is this a thing? Adding Option 003 and Option 012 on windows dhcp fog server reservation options


  • Testers

    So I think I may have just accidentally discovered a way to increase the effectiveness/speed/reliability of pxe booting in windows dhcp configurations.
    Granted I did just change server boxes and OS’s, so sadly this is a discovery with a lot of variables so I’m not 100% sure that it is really a thing.

    So, on top of the already existing server wide options of 66 and 67 that point pxe boots to the FOG server and specify the pxe boot file I added a couple more configurations.

    So before, something that helped a little was having an ip reservation for the FOG server on the same subnet as the workstations it’s imaging. So I was adjusting that reservation whilst migrating my FOG server setup to a new ip address on a new box. I decided to try a couple other options set just to the fog-server reservation.

    • option 003 Router - set to the router gateway address with a secondary address of the DHCP server itself (i.e. 192.168.100.1, 192.168.100.3)
    • option 012 Host Name - set to the fog server’s host name.

    The first time I booted to pxe (on a vm that usually required a few tries before it worked) it booted up with no issues at all just as it should, faster than I had ever seen even.

    So my question is for people with a little more network experience than me. People like @Sebastian-Roth @Tom-Elliott @Wayne-Workman Would setting these options make a difference reasonably?

    I kinda think that they would since one of the problems I would see with longer pxe boots is repeated discovers and selects of one of the 3 dhcp requests in the pxe boot process trying to find a router. So is this all in my head or did I stumble on something helpful?


  • Testers

    @Arrowhead-IT It’s definitely worked for test VM’s that are used for image testing, but it’s also a more general comment for ESXi in general. Worth checking your server guests to ensure they’re all on vmxnet3.


  • Testers

    @Arrowhead-IT I did just try vmxnet3 again after we had done some dhcp configuration fixes over the weekend. It worked on the first try, I guess my problem was elsewhere. I haven’t tried unsetting the experimental options yet.


  • Testers

    @MRCUR I’ve heard that, but I couldn’t get the vmxnet adapter to boot to pxe. E1000 was the only one that worked ever for me. If you’re saying you have gotten it to work, then maybe I should try it again.


  • Testers

    @Arrowhead-IT said:

    And sadly, after trying to boot a different vm a few minutes ago, same esxi server and same type of virtual network adapter E1000 as the other, it took a few tries again to get an address in the initial pxe boot.

    You should really be using VMxnet 3 as the adapter for every guest on ESXi. VMware does not actually recommend that you use the E1000.


  • Testers

    @Wayne-Workman well, it happens on physical machines too. Maybe CentOS is just better than ubuntu for hosting fog?


  • Moderator

    @Sebastian-Roth said:

    AFAIK pxe booting (the FOG style) has nothing to do with router (all on the same subnet) or hostname/DNS. Maybe just undo/redo the settings to verify if those really make a difference.

    Maybe bare metal is just better ?


  • Testers

    @Sebastian-Roth Yeah, our dhcp does have some serious issues actually. We’re working on narrowing it down. Sometimes computers get ips from the ip phone scope, even when they have an ip reservation. Pretty sure it has to do with some incompatible firmware on one old hp switch we’re phasing out. I was just hoping to have found something that just worked around other issues.

    And sadly, after trying to boot a different vm a few minutes ago, same esxi server and same type of virtual network adapter E1000 as the other, it took a few tries again to get an address in the initial pxe boot.

    Thanks for the input though, just more confirmation that our network needs an overhaul.
    I just want to hit reset of the whole data center infrastructure and start again. But that’s not actually a good idea, I know that, people need to do their jobs or something silly like that.


  • Developer

    @Arrowhead-IT AFAIK pxe booting (the FOG style) has nothing to do with router (all on the same subnet) or hostname/DNS. Maybe just undo/redo the settings to verify if those really make a difference.

    Why would the VM take “a few tries”. This should not be the case. Maybe some missconfiguration in your DHCP setup that you fixed now?!


  • Testers

    @Wayne-Workman Thanks
    I’m on 2012 R2 dhcp ver 6.3


  • Moderator

    @Arrowhead-IT said:

    a vm that usually required a few tries

    I’ll be trying these things out next week. I will post what differences I notice.

    What version of Windows Server are you running DHCP on? I ask because there are differences. I’m running 2012 R1


  • Testers

    I also made a static A host record for the fog server hostname and ip as well as a cname for fog-server to that A record. Maybe that did something too?



353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.