• When trying to register an Optiplex 780 we are getting the following error after pxe booting to the NIC:

    “pxe-e51 no dhcp or proxydhcp offers received”

    I’ve tried changing Kernals but this didn’t help. Also, the BIOS is up-to-date.

    I’m able to register other machines with no issues.

    Thank you in advance

  • We have some Lenovos that are weird.

    Pull the power cable and patch cable, hit the power button a few times, plug everything back up and auto-magically those weird ones start working…

  • OptiPlex 780 works for me too. BIOS is stock (A01) fog is trunk. We have 330, 360, 760 and 780, no issues (the 330’s are the twitchiest, very fussy on hard drives). I have had no errors at all in FOG imaging any OptiPlex machines. In fact, ive not had a machine failed for a very long time (modern laptop, old 0.32 kernel at the time)

    DHCP is server 2012R2

  • Senior Developer

    Would be interesting to see a full DHCP (and possibly TFTP) packet trace of this. Probably best if you can connect the client to a hub which is then connected to the rest of the network. On the hub you can listen with another PC/notebook and capture all the pxe boot traffic send and received by the client. Wireshark display filter bootp || tftp would be helpful. I’ll have a look if you upload a PCAP file here.

  • With older Optiplex models (745, 755, 760, 780), I’ve had the experience, that strangely some will work with FOG (in my case 0.32), others won’t (regardless of BIOS versions). In this case, I don’t think you should put too much attention on the error message, because as you said other models on the same network are working properly with FOG. I’ve never been able to solve this problem. In a few cases, alternative kernels helped me out, but most times I wouldn’t be able to make it work.
    The only work-around I know, is to put the HDD of the PC you want to image in another PC, that is working with FOG, and then after imaging (with shutdown afterwards) is done switch it back to the original PC.

  • Moderator

    I can confirm for sure that the o780 works flawlessly with FOG with dhcp served by MS DHCP server.

  • @SBrady At home I have an Optiplex 380, gx620, and a 745. At work I’ve got Optiplex 7010s and 9020s. I know FOG works on those. In our WiKi, the 780 has been confirmed by someone as working last year: https://wiki.fogproject.org/wiki/index.php/WorkingDevices The model is not the issue.

    How many times have you tried with this device? What troubleshooting steps have been taken?

    Try to move the computer to a different network drop (a different port on the switch along with a different run).
    Try a working computer on that suspicious network run (like a laptop with WiFi turned off).
    Swap out the patch cable.
    Is the network run really close to a florescent light or power line and therefore experiencing interference?
    Have you checked the run for dropped packets? Use something like ping -n >> output.txt and look at how many are dropped, or run a throughput test with iPerf or something similar.
    Try another Optiplex 780 somewhere else.

    It could be a bad run, a bad port on the switch, a bad vlan configuration for that port.

    It could even be something as simple as a DHCP reservation that is messing with just that host (not all DHCP solutions are created equal).

    Do you have port-based security based on MAC addresses?
    Could there be a rogue DHCP?
    Is there an imaging server configured in the device’s firmware? Dell 780s support an imaging server configuration and that would probably cause an issue.

    Do you have a network hub (not a switch, a hub) ? If so, run the host through that, connect a laptop to a port on the hub and run wire-shark. See if it’s asking for DHCP or not, see if there is a response or not, if there is a response, what does it say?

    Run Wireshark on your DHCP server if you don’t have a hub. Does the problem host ever broadcast a DHCP Discovery packet? Does the server ever respond, if so, with what?

    If you look in the TFTP Troubleshooting article I linked to earlier, there are useful MAC based filters you can use in wireshark to see traffic for just that one problem host.

    We need you guys to get to trying things and reporting your findings.

  • Testers

    How is your FOG server configured for dhcp?
    Do you use a dnsmasq dhcp proxy?
    Is fog the dhcp server?
    Do you have a linux or windows dhcp server externally?

  • Moderator

    This error PXE-E51 is telling me that the client can not contact a dhcp server (period). This can be because its not plugged into the network, or there is something wrong with an upstream connection, or the network port is bad on the mobo. You are not even getting to the kernel part you are stuck at getting an IP address.

    I have see traditional spanning tree on a port cause something similar to this. All ports should be configured for fast spanning tree protocol or (I think) RSTP.

  • @Wayne-Workman Why would this only be affecting 780’s? Because I can register other computers.

  • This post is deleted!

  • We have multiple DHCP scopes on the server but only one applies to the VLAN which fog is conected .Fog and The computer are connected to the same VLAN.

  • What the error says is exactly the issue. Do you have two DHCP servers in your environment, or multiple scopes?

    Simple stuff first, is the network cable plugged in? - I’ve made that mistake lots of times.

    Also check this out: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP