• I have checked the password encryption multiple times and I have tried imaging multiple times (the image does have the fog client) and I can’t get it to join the domain. I got it to work at one of my other schools, and I set this one up the same way. I am wondering if it is a problem with the way that this domain was originally set up. For example, the domain would be xyz.local but if you login with this domain it is xyzdomain\administrator instead of just xyz\administrator. I have tried both xyz.local and xyzdomain for the domain in fog, and neither will work. I have Fog 1.2 with Ubuntu 12.04 LTS. (FWIW I had the same issue at this school when I was using Fog .32)

    Any thoughts?

  • Testers

    As for default behavior in SVN services are enabled on a pxe registered machine if you register the machine via the web interface then the default is off.

  • I personally do not use SysPrep.

    I find that maintaining several images is exceedingly easy. I keep track of about… emmm… 9 or 10 images I’d say.

    There’s just something about using a Linux utility instead of a Microsoft one that makes my day. 🙂

  • Use unattend files?

  • OoBE is what I normally do. It isn’t really a huge deal, I can just set up an extra local account, I was just hoping to avoid it to make it a little quicker.

  • Well, I don’t think FOG has anything to do with forcing you to setup another local admin account, and that’s why I suspect SysPrep.

    Maybe you chose the “Out of the box experience” option accidentally?

  • It has never been an issue before though. I have done it this way at a few different schools and don’t use answer files at any of them.

  • Because you Sys prepped the image and don’t have answer files set up?

  • So I checked in the settings on the fog server and under host management settings it did not have any of the boxes checked for services (I thought the default on these was checked). I checked the appropriate ones and I reimaged to test it out. After I named the computer and created the admin account, it rebooted to join it to the domain, but it made me set up another local admin account. Any thoughts on why it had me go through the account setup again?

    The upload a file won’t let me upload the fog log for some reason. It just doesn’t even see it as a possibility.

  • Senior Developer

    Could you upload the log file that Wayne was talking about? Usually we can tell what is wrong just by looking at that.

  • Just a stab at this but,

    take the machine you made this image from, and re-install the FOG client, Make sure the IP address is correct when it asks for it. Then make a second image from that. Then, try again.

    A simple fat-fingered entry that you didn’t realize could be causing all this… or even a bad FOG Client install, although a bad install has never happened to me personally, but it’s possible.

    Also, there’s a FOG Client log on the clients, it’s usually here: C:\fog.txt

    It’d be interesting to see what’s in there after you’ve tried to image & join to domain.

  • Developer

    i meant in Host Management>service settings, make sure the boxes are ticked that you need.
    on the client, the config file is located in program files or program files (x86) /fog/etc

  • Junkhacker: When I installed the FOG client, I believe I allowed all services, but if for some reason I didn’t, how would I go about checking that?

    Uncle Frank: These are not SSD units.

    Wayne Workman: Normally when I join clients to the domain I use xyz.local

  • I was reading through this and thinking it was a DNS issue…

    When you join clients to the domain manually, do you have to use the FQDN, or just domain name?
    Specifically, in this building you’re having issues in.

  • Senior Developer

    Do you have SSD hard drives in your clients??

  • Developer

    this is unrelated to why you’re having issues, but do not use an admin level account for the fog ad user. this account should only have privileges to join, rename, etc.
    have you checked that the hostname changer service is enabled on that host?

  • Sorry I should have specified. In the field for Domain, I have tried xyz.local and xyzdomain. The username I have only used administrator.

  • The domain name should NOT be included in the username for 1.2.0