SOLVED WebUI not deleting images in file system

  • Hey all,

    I’ve been deleting images in the GUI using the bulk delete method not realizing this isn’t the best approach as the files will still stay in the filesystem. Dug around in the forums and discovered the Delete tab inside individual images. When checking the “Delete files” option, I’m faced with the error:

    Type: 2, File: /var/www/fog/lib/fog/fogftp.class.php, Line: 464, Message: ftp_login(): Login incorrect., Host:, Username: fogproject

    I’ve seen a few posts about this and some point to the TFTP password not matching the .fogsettings. I’ve checked this and they do match. I’ve changed the TFTP password and then changed back to what matches in .fogsettings and still no luck.

    On the confirmation screen, I should be entering the fog GUI password, right? When entering any other password I do get an immediate failure, but when entering the GUI password the GUI appears to try and delete the files, but is unable.

  • Moderator

    @Chad @DJslimD1k @fry_p This is fixed in the latest dev-branch and will be in the next release - soon to come.

  • This post is deleted!
  • Moderator

    I’m still on 1.5.6 and this doesn’t work for me. Honestly it has not worked in many iterations of FOG prior either. I usually just go into the VM and manually remove them after I delete the definitions in the GUI. Thought it was just a bug on my end.

  • I’m also having this problem with version 1.5.9-RC2.9

  • v1.5.7
    bzImage Version: 4.19.48

  • Moderator

    @Chad Which version of FOG is this?