snapins not deploying from storage nodes: Version 1.5.7.4


  • Testers

    Version 1.5.7.4
    when deploying an image to a pc that is at a location with a storage node the image is pulled correctly from the storage node but when it comes to the snapins it pulls them from the master. I have verified that the location is set on the host and snapins exist on the storage node and the snapin hashes match up.

    Thanks!


  • Senior Developer

    @Sebastian-Roth Thank you for finding and fixing the issue.
    @Greg-Plamondon Thanks for reporting. This fix is also set for 1.6 now too.

    Awesome job everybody!

    Thank you,


  • Developer

    @Greg-Plamondon Thanks! So I will mark this solved then. Fix is in the dev-branch if others read this and want to update to get the fix as well.


  • Testers

    @Sebastian-Roth doing a git pull now will let you know shortly

    EDIT:

    I installed the change you made and it looks the same as when you made the changes to my system at least from a fog.log stand point.
    its is calling the IP address of the storage node.


  • Developer

    @Greg-Plamondon I just pushed a fix to dev-branch. Very similar to what we tested in your setup already. Would still be great if you could try it out just to make sure.


  • Developer

    @Greg-Plamondon Please check the chat bubble in the top right corner.

    I am fairly sure this has not worked properly in a very long time.


  • Developer

    @Greg-Plamondon Ok, I think I found what’s causing this. Give me a bit more time.


  • Testers

    @Sebastian-Roth said in snapins not deploying from storage nodes: Version 1.5.7.4:

    mysql> SELECT * FROM location;

    MariaDB [fog]> SELECT * FROM location;
    +-----+--------------------------------------------+-------+-----------------+----------------+------------+---------------------+--------------+
    | lID | lName                                      | lDesc | lStorageGroupID | lStorageNodeID | lCreatedBy | lCreatedTime        | lTftpEnabled |
    +-----+--------------------------------------------+-------+-----------------+----------------+------------+---------------------+--------------+
    |   1 | 23 - Kansas City, MO - 10MB                |       |               1 |             15 | gp1001     | 2018-03-26 13:56:25 | 1            |
    |   2 | 10 - Help Desk - Byron Center, MI          |       |               1 |             31 | gp1001     | 2018-03-21 13:36:01 | 0            |
    |   3 | 11 - Spring Lake, MI - 10MB                |       |               1 |             38 | gp1001     | 2018-03-21 13:36:46 | 1            |
    |   4 | 13 - James P. Cole BLVD - Flint, MI - 10MB |       |               1 |              7 | gp1001     | 2018-03-21 13:37:28 | 1            |
    |   5 | 14 - Lansing, MI - 5MB                     |       |               1 |              8 | gp1001     | 2018-03-21 13:37:59 | 1            |
    |   6 | 30 - Windsor, Ontario, CA - 10MB           |       |               1 |              5 | gp1001     | 2018-03-21 13:39:30 | 1            |
    |   8 | 17 - Toledo, OH - 10MB                     |       |               1 |             41 | gp1001     | 2018-03-23 16:17:04 | 1            |
    |   9 | 18 - Bertrand, MO - 3MB                    |       |               1 |             37 | gp1001     | 2018-03-26 10:17:35 | 1            |
    |  10 | 19 - Wayne, MI                             |       |               1 |             12 | gp1001     | 2018-03-26 10:29:28 | 1            |
    |  12 | 21 - White Pine, TN - 10MB                 |       |               1 |             13 | gp1001     | 2018-03-26 12:00:22 | 1            |
    |  13 | 25 - Marshall, MI - 5MB                    |       |               1 |             16 | gp1001     | 2018-03-27 08:54:57 | 1            |
    |  14 | 28 - Grand Prairie, TX - 10MB              |       |               1 |             17 | gp1001     | 2018-03-27 12:46:43 | 1            |
    |  15 | 29 - Port Huron, MI - 5MB                  |       |               1 |             27 | gp1001     | 2018-03-27 14:26:09 | 1            |
    |  16 | 33 - Coldwater, MI - VPN                   |       |               1 |             19 | gp1001     | 2018-03-27 15:41:24 | 1            |
    |  17 | 34 - Lima, OH - 10MB                       |       |               1 |             35 | gp1001     | 2018-03-27 16:03:53 | 1            |
    |  18 | 43 - Dayton, OH - 50MB                     |       |               1 |             33 | gp1001     | 2018-03-27 16:50:25 | 1            |
    |  19 | 44 - Marion, IN. - 10MB                    |       |               1 |             22 | gp1001     | 2018-03-28 10:10:30 | 1            |
    |  20 | 99 - Mobile Office - MIFI                  |       |               1 |             23 | gp1001     | 2018-03-29 16:28:13 | 1            |
    |  21 | 27 - Indianapolis, IN. - 5MB               |       |               1 |             26 | gp1001     | 2018-04-03 13:31:21 | 1            |
    |  23 | 36 - Springfield, IL - 10MB                |       |               1 |             25 | gp1001     | 2018-04-11 11:20:02 | 1            |
    |  26 | 32 - Hecla                                 |       |               1 |             29 | gp1001     | 2018-06-08 17:04:05 | 1            |
    |  25 | 10 - Byron Center                          |       |               1 |              1 | gp1001     | 2018-05-01 16:40:42 | 1            |
    |  27 | 15 - Hamtramck                             |       |               1 |             28 | gp1001     | 2018-06-11 09:38:24 | 1            |
    |  28 | 12 - Ypsilanti, MI                         |       |               1 |             30 | gp1001     | 2018-06-11 10:42:42 | 0            |
    |  30 | 31 - Grand Haven Road, Spring Lake MI -    |       |               1 |             44 | gp1001     | 2019-07-29 13:15:55 | 0            |
    |  29 | 38 - St Louis                              |       |               1 |             43 | gp1001     | 2019-05-31 16:00:28 | 1            |
    +-----+--------------------------------------------+-------+-----------------+----------------+------------+---------------------+--------------+
    26 rows in set (0.00 sec)
    
    

  • Developer

    @Greg-Plamondon Ok, setting it correct in the DB. Just wanted to make sure it is before we get into the code.

    Now this is the part that decides about which node to use when the location plugin is used:

    Please run another mysql query for us and post output here:

    mysql> SELECT * FROM location;
    

  • Testers

    @Sebastian-Roth said in snapins not deploying from storage nodes: Version 1.5.7.4:

    SELECT * FROM globalSettings WHERE settingKey LIKE ‘%SNAPIN_LOCATION_SEND_ENABLED%’;

    MariaDB [fog]> SELECT * FROM globalSettings WHERE settingKey LIKE '%SNAPIN_LOCATION_SEND_ENABLED%';
    +-----------+----------------------------------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------+----------------------+
    | settingID | settingKey                       | settingDesc                                                                                                                                                                                  | settingValue | settingCategory      |
    +-----------+----------------------------------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------+----------------------+
    |       206 | FOG_SNAPIN_LOCATION_SEND_ENABLED | This setting defines sending the location url based on the host that checks in. It tells the client to download snapins from the host defined location where available. Default is disabled. | 1            | FOG Client - Snapins |
    +-----------+----------------------------------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------+----------------------+
    1 row in set (0.00 sec)
    

    this is the fog.log on the client.

    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     10/21/2019 2:30 PM Client-Info Client Version: 0.11.16
     10/21/2019 2:30 PM Client-Info Client OS:      Windows
     10/21/2019 2:30 PM Client-Info Server Version: 1.5.7.4
     10/21/2019 2:30 PM Middleware::Response Success
     10/21/2019 2:30 PM SnapinClient Running snapin 00 - UltraVNC
     10/21/2019 2:30 PM Middleware::Communication Download: http://10fogserver.domain-name.com/fog/service/snapins.file.php?mac=00:0C:29:A6:AD:01&taskid=9092
    

    shouldnt it be the storage nodes hostname?

    Download: http://23storage.domain-name.com/fog/...
    

  • Developer

    @Greg-Plamondon Ok, let’s start in the database. Please connect to the DB on the command line:

    shell> mysql -u root -p
    Password:
    ...
    mysql> use fog;
    ...
    mysql> SELECT * FROM globalSettings WHERE settingKey LIKE '%SNAPIN_LOCATION_SEND_ENABLED%';
    ...
    

    Post the results you get here in the forums.


  • Testers

    @Sebastian-Roth any ideas on where I could start to troubleshoot this? I don’t see anything in the logs standing out.


  • Developer

    I will definitely look into this issue when I get back.


  • Moderator

    @maxcarpone said in snapins not deploying from storage nodes: Version 1.5.7.4:

    I’ve just found out that the management password of my storage node has been truncated by 1 character.
    FYI: @Developers



  • I’ve just found out that the management password of my storage node has been truncated by 1 character. After typing it again, everything is back to normal.
    That version has definitely changed my password :/

    Well I’m not sure my problem is related to the one described above, sorry for that. :|



  • Hi guys,

    Same problem with my server, I’ve just updated from 1.5.7.2 to 1.5.7.4 and snapins are not deployed anymore. It failed with return code “-1”.


  • Testers

    @Fernando-Gietz it worked before, not sure what version it changed in.


  • Developer

    Hi @Sebastian-Roth ,

    I don´t know. I don´t use Location Plugin and I don´t have expirence with it ;) but I can try to help

    @Greg-Plamondon In previous versions of FOG, the behaviour was the same?

    I have been offline several months XD


  • Developer

    @Fernando-Gietz Possible bug in the location plugin. What do you think?


Log in to reply
 

519
Online

6.3k
Users

13.7k
Topics

129.3k
Posts