1.6 Issues/Reporting


  • Senior Developer

    Hello all,

    For those that are testing 1.6 and find things, please post them here for tracking purposes.

    Thank you,



  • Favicon icon is missing (although you may have known that since it’s in working)



  • @tom-elliott

    No problem! I’ll keep that in mind. I’m testing multicasting now.

    I discovered a few things that could have been effecting multicasting performance. If this works, I’ll have to unicast most of the lab. Basically, we have some small low end consumer switches that some of these hosts are plugged in to. I had 4 hosts in that lab that are directly wired in to our smart switches (cisco). We did check to see if we had any packet loss during the previous multicast session and we did not and the cable checked out fine. So we’ll see.


  • Senior Developer

    @joe-gill I’m aware of this. The functionality idea, however:

    Individual checkboxes work only on that one element. Selected items work “en mass”. I just haven’t gotten around to making that function appropriately yet.



  • @Tom-Elliott

    One other feature that would be nice is when you check / un-check hosts from certain things, for instance groups, that it would recognize that as selecting the item. Right now you have to highlight the whole thing to select it.

    Thanks!


  • Senior Developer

    Found the issue through a remote session.

    The problem was I forgot to add MULTICAST tasks to the Deploy grouping. Once added, hosts started checking in and even started imaging YAY!.

    Found another issue in regards to the unisearch and non https. Hopefully this is all corrected for now too.

    Associated items are also now sorted in a “Associated, Name” method as opposed to just “Name” as it was before.



  • @tom-elliott

    /var/log/apache2/error.log?

    What I am seeing is this… Yet I have tasks listed in tasks…

    0_1531923721674_Screenshot_MultiCast.jpg


  • Senior Developer

    @joe-gill what’s the error you’re seeing in apache?



  • @joe-gill We need more tabs!!!



  • @tom-elliott

    I agree. Less is more here. I like the idea of sort by associated first. That would certainly work.

    Have you tested Multicast? I am testing that now. I get Attempted to check in failed.

    Thanks!


  • Senior Developer

    @joe-gill I could change the group host by sorting by the association field. The idea here for all things is to kind of be “less” is more of that makes sense. I’ll work to sort first by associated.



  • @Tom-Elliott

    I love the look and feel of the new interface. I can tell you and the group have put in a ton of effort in creating 1.6. Thank you!

    One small thing I just noticed is the icon on the browser tab needs to be updated. Ha! I liked having the FOG icon to get to in my many open tabs. Small!

    The next thing I noticed was when you open Groups/Associations/Hosts, it displays All hosts. It would be great if it showed just the hosts associated with the group with the option to display hosts that are not associated with the group. (like 1.5 did.) :-D

    0_1531920793328_Screenshot from 2018-07-18 07-32-48.png

    I’ll put it to the test!

    Again thanks!!

    Cheers!



  • @tom-elliott No worries, just trying to contribute :D Thanks for the response! Hope things are working out for you.


  • Senior Developer

    @jgallo There’s a few bugs here and there, but we really did put a lot of effort into making it much more User Friendly. So thank you for the kind words. Any issues you’re noticing, please feel free to let me know and I’ll try to fix them.


  • Senior Developer

    @dahrell The problem you’re describing was due to an oversight when we created the JS deleteSelected method.

    Essentially, the ID’s of those mac addresses (can be seen in the GUI via right click->inspect, row_id is the id of the hostMAC table reference.)

    It was removing the hosts with those same ID’s (rather than the host mac. Sorry about that.) I found the issue and made corrections for this so this item should work properly now.

    Thanks for letting me know and sorry for any trouble that caused.



  • @junkhacker Interesting because I created a Windows 10 image 1803 build and uploaded fine. Registered hosts which are Dell 9020’s and have imaged fine so far. I have not ventured into getting storage nodes and what not setup yet since we are in the middle of projects but i plan on setting up some dummy nodes and observing the replication logs. I assume they will be fine. So far the only thing I notice are little cosmetic items like words and scaling in the web UI are not as important as functionality. So far I’m very impressed. Thank you @Tom-Elliott for working on this.


  • Senior Developer

    @junkhacker et al.

    Please don’t think I’ve gone anywhere. I’m dealing with my own things and been busy trying to catch myself back up. I’m still around and still wanting to work on these things, just been too busy to respond and put a lot of effort into it lately. Sorry.

    @Matthieu-Jacquart I’m aware there may be issues with uploading files. They should work, but this might be semi related to the max filesize. (If the filesize is too large for your server too accept, it clears out all POST information.) Can you please check the php.ini file for the post_max_size and upload_max_filesize elements of your /etc/php.ini (if redhat), otherwise it should be in /etc/php/7.X/fpm/php.ini

    (The X is the version of php you’re running. If you’re using php 5, then change /etc/php/7.x to /etc/php5 or /etc/php/5.6 as/where approapriate)


  • Developer

    just reporting in problems i encountered testing 1.6
    registered new host, created new image, tried to upload image of host to the newly created image:
    image uploaded, but repeatedly failed to update database that it had finished.
    while looking at the error, i realized that invalid parameters were sent to the computer, as well
    the newly created image had a compression value set to 0 and the compression type was not assigned. i could not update these values on the image’s profile page. nor could i import a image list with corrected values.

    I don’t have time to troubleshoot further right now, but I am interested if anyone can reproduce similar problems (or i just messed up my setup somehow).



  • @tom-elliott Another problem : I tried to create new snapin, and it returns this error :
    0_1531468459844_fog.JPG

    If I tried to update existing snapin it returns green valid message but snapin file is not updated…



  • @tom-elliott Ok my problem with AD joining is solved, but still problem at the end of capture task : image stays in /dev folder and task could not complete on web interface, here is a capture of the problem
    0_1531386922623_FOG.jpg


 

405
Online

41.6k
Users

12.1k
Topics

114.4k
Posts