Group Details

FOG Hangouts

Being a member of FOG Hangouts will allow you to stay updated about the latest FOG Hangout; the when, the where, and the details. Membership in this group is automatic membership in a mailing list.

  • RE: Dell Latitude 3540

    @jgibson60 @Zourous As for a quick test you can rename the files. Make sure you remember the correct names to restore those later on.

    May I ask which version of FOG you two use?

    posted in Hardware Compatibility
  • RE: "Deploy Image" Not Working for HP Probook 450 G9

    @LLamaPie Thanks for testing and letting me know.

    posted in FOG Problems
  • RE: API wake on lan

    @Lenain That’s great to hear, glad we could get it figured out.

    posted in General
  • RE: Active Directory Fields Randomly Clearing

    @JJ-Fullmer I think I have determined this is a problem in an internal process with the api. Gonna try to narrow it down some more.

    posted in FOG Problems
  • RE: Using certificate which is not self-signed for HTTPS

    You should be able to do this without too much trouble for just the basic ssl communication like you do for any other linux server. I would suggest at install time NOT selecting ssl and then altering the config to use your custom certificate. I don’t think we’ve implemented custom certs into the install process. I use an internal CA and custom cert on the fog server for https web access, I configured it in apache after installing fog. I think there are some other places that get ssl enabled when you select ssl in the installer.
    @Sebastian-Roth might know more on how the client uses certificates.

    posted in FOG Problems
  • RE: Windows Installation Error

    @UserBxl Do you have an unattend.xml file with sysprep?
    Did you happen to open the microsoft store or any microsoft store apps before running sysprep as that can cause issues.

    This error typically means there’s an error in the unattend file or something went wrong with sysprep.

    When you see the error you may be able to hit shift+f10 to bring up a cmd console and you can try to look at sysprep log files, i.e. notepad C:\Windows\System32\sysprep\Panther\setupact.log there’s a few places they may reside, see also

    That may help point you in the right direction.

    Some common ones I’ve run into

    • Needing to provision store apps properly and make sure they are never opened before running sysprep. I run this powershell before sysprep as well
    Write-Verbose "Removing current user packages"
    		Get-AppxPackage | Remove-AppxPackage -EA 0;
    #see also
    		$allowedApps = @(
    			"Microsoft.549981C3F5F10", #cortana
    			# "Microsoft.Office.OneNote",
    			# "microsoft.windowscommunicationsapps",
    			# "Microsoft.WindowsFeedbackHub",
    			# "Microsoft.WindowsMaps",
    			# "Microsoft.WindowsSoundRecorder",
    			# "Microsoft.Xbox.TCUI",
    			# "Microsoft.XboxApp",
    			# "Microsoft.XboxIdentityProvider",
    		Write-Verbose "Removing provisioned appx packages that dont match allowed list"
    		Get-AppxProvisionedPackage -Online | Where-Object { 
    			$_.DisplayName -notin $allowedApps;
    		} | ForEach-Object {
    				if($_.PackageName) {
    					Write-Verbose "Removing provisioned package $($_.DisplayName)"
    					Remove-AppxProvisionedPackage -Online -packagename $_.PackageName;
    • Typo in the unattend i.e. missed a /> or put a setting twice
    • Typo in domain join fields like OU or domain
    • Specifying settings that aren’t compatible with one another (i.e. workgroup join and domain join)

    Hope that helps to get you started.

    posted in Windows Problems
  • RE: >FOG vs UEFI

    @Sebastian-Roth said in >FOG vs UEFI:

    @jeremyvdv Maybe this is going to help you:

    This is also on the new docs page

    @george1421 said in >FOG vs UEFI:

    @jeremyvdv If you have a windows dhcp server AND you need to pxe boot both bios and uefi based computers you might want to review this wiki page to setup dhcp profiles so your dhcp server sends the proper boot file name based on the target computer:

    This is also on the new docs page

    posted in Hardware Compatibility
  • RE: API wake on lan

    @Lenain I also made a github issue for making a function out of this

    If you’re feeling saucy feel free to fork the repo and give it a go and pull request it. I’ll get to it eventually, but it could be quite a while, life is rather busy at the moment.

    posted in General
  • RE: API wake on lan

    @Lenain Howdy, I’m the author of the FogApi powershell module and I’m happy to help.

    A few questions

    • Are you trying to send/push/deploy an image with wol enabled or are you trying to create a wake only task?
    • Have you confirmed through other means that wake on lan is working in your environment, i.e. without additional switch configuration it typically doesn’t work across different subnets. It can, you just have to allow it.
    • Here’s another alternative in powershell, you can send a magic packet to a mac address with this function
    function Send-WoL {
        param (
            $port = 9
        process {
            $MacByteArray = $Mac -split "[:-]" | ForEach-Object { [Byte] "0x$_"}
            [Byte[]] $MagicPacket = (,0xFF * 6) + ($MacByteArray  * 16)
            $UdpClient = New-Object System.Net.Sockets.UdpClient
    Send-Wol -mac "12:34:56:78:90:aa"

    If you’re trying to do a wake only task, the syntax will likely be different for the json you need to send

    You might try creating a scheduled wake on lan task manually and then get the pending task from the api to see the fields
    i.e. Get-FogObject -type objectactivetasktype -coreActiveTaskObject scheduledtask | select -expand data | select * -ExcludeProperty host | ConvertTo-Json

    I ran that and in comparing those values and assuming you don’t want it to be scheduled, this should do the trick (I tested it and it did indeed do the trick)

    $jsonData = @"
    New-FogObject -type objecttasktype -coreTaskObject host -jsonData $jsonData -IDofObject $hostID

    The send-fogimage function was a good one to look at for an example, but pushing an image has more fields for the task than other tasks, some tasks only need the type id and what host to run it on. This one might even work without some of these variables.

    Hope that helps

    posted in General
  • Active Directory Fields Randomly Clearing

    Fog version:
    Running on centOS 7

    I have a number of hosts where the active directory information is randomly going poof.
    The host gets imaged, it joins the domain with a post download script, and all is well. Then some time later I go check on things to find the information has gone away and no one has edited it.

    I think it might have something to do with the fog service and adding pending macs, but I’m not sure. I have globally disabled adding new hosts via the fog client to see if that had any affect, but there was no change.

    I’m unsure where to look at the moment to troubleshoot this further.

    posted in FOG Problems