• Recent
    • Unsolved
    • Tags
    • Popular
    • Users
    • Groups
    • Search
    • Register
    • Login
    1. Home
    2. jmeyer
    3. Posts
    J
    • Profile
    • Following 0
    • Followers 1
    • Topics 58
    • Posts 297
    • Groups 0

    Posts

    Recent Best Controversial
    • Fog 1.6 - Kernel Panic

      Hello,
      I have update to 1.6 and i have this during install :

      * Setting up and starting TFTP Server.........................xinetd.service is not a native service, redirecting to systemd-sysv-install
      Executing /lib/systemd/systemd-sysv-install is-enabled xinetd
      tftpd-hpa.service is not a native service, redirecting to systemd-sysv-install
      Executing /lib/systemd/systemd-sysv-install is-enabled tftpd-hpa
      Too few arguments.
      Too few arguments.
      OK
      

      And during deploy :

      IMG_20190624_091008 (002).jpg

      I have download manually .xz files in cas they were corrupt on my side without success.

      root@fog0210003p:~/fogproject/bin# ls /var/www/fog/service/ipxe/ -l
      total 54692
      -rw-r--r-- 1 fogproject www-data     1943 juin  21 17:13 advanced.php
      -rw-r--r-- 1 fogproject www-data    16272 juin  21 17:13 bgdark.png
      -rw-r--r-- 1 fogproject www-data    21280 juin  21 17:13 bg.png
      -rw-r--r-- 1 fogproject www-data     1134 juin  21 17:13 boot.php
      -rw-r--r-- 1 fogproject www-data  8389280 juin  21 17:14 bzImage
      -rw-r--r-- 1 fogproject www-data  7808448 juin  21 17:14 bzImage32
      -rw-r--r-- 1 fogproject www-data       76 juin  21 17:14 bzImage32.sha256
      -rw-r--r-- 1 fogproject www-data       74 juin  21 17:14 bzImage.sha256
      -rw-r--r-- 1 fogproject www-data   234697 juin  21 17:13 grub.exe
      -rw-r--r-- 1 fogproject www-data      592 juin  21 17:13 index.php
      -rw-r--r-- 1 fogproject www-data 18863676 juin  21 17:14 init_32.xz
      -rw-r--r-- 1 fogproject www-data 19691232 juin  21 17:14 init.xz
      -rw-r--r-- 1 fogproject www-data    25340 juin  21 17:13 memdisk
      -rw-r--r-- 1 fogproject www-data  1839104 juin  21 17:13 memtest.bin
      -rw-r--r-- 1 fogproject www-data    29701 juin  21 17:13 refind.conf
      -rw-r--r-- 1 fogproject www-data   262592 juin  21 17:13 refind.efi
      -rw-r--r-- 1 fogproject www-data   201600 juin  21 17:13 refind_ia32.efi
      -rw-r--r-- 1 fogproject www-data   208776 juin  21 17:13 refind_x64.efi
      

      Bios update doesn’t fix the problem but remove the “Firmware Bug” line.

      Thank you for your help.

      I also see this in apache error log :

      [Mon Jun 24 09:31:59.632454 2019] [proxy_fcgi:error] [pid 2051] [client 10.21.1.226:51916] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Class 'ServiceModule' not found in /var/www/html/fog/service/servicemodule-active.php:25\nStack trace:\n#0 {main}\n  thrown in /var/www/html/fog/service/servicemodule-active.php on line 25\n'
      
      posted in Bug Reports
      J
      jmeyer
    • RE: IRC (Internet Relay Chat)

      You can use this if you don’t have the IRC client : https://web.libera.chat/#fog

      posted in Announcements
      J
      jmeyer
    • RE: Error deploying old image with partimage

      @sebastian-roth I don’t think to go in the wrong direction about the 63s.
      Here is what I have from command line on working computer :

      DISKPART> detail partition
      
      Partition 1
      Type   : 07
      Masqué : Non
      Active : Oui
      Décalage en octets : 32256
      
        N° volume   Ltr  Nom          Fs     Type        Taille   Statut     Info
        ----------  ---  -----------  -----  ----------  -------  ---------  --------
      * Volume 1     C                NTFS   Partition    232 G   Sain       Système
      

      How I can get same result from debug task ?
      I tried making the partition with parted (mkpart primary 63s 100%) but without success on booting computer.

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      I tried setting 63 as first sector using command “fdisk -c=dos /dev/sda” in debug but it’s not working at the end. I must have missed something.

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      @sebastian-roth HDD size is one problem link to hardware but I think OS boot is more about first sector of the partition.
      I remember that my old Windows 7 image were build as windows XP and doesn’t start at 2048 but 63.
      Thomas had fixed this before but I think he has probably reverted changes.

      How can i check this ?

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      @sebastian-roth It deploy fine on the 300GB VM drive or a 1 TB drive.
      I have a black screen with a blinking underscore on the VM.
      On a computer, It’s write “A disk read error occured”.

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      @tom-elliott It’s a new HDD. I have tried on a VM with a 300GB HDD and I think image is corrupt because it doesn’t boot after deploy.

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      @sebastian-roth It’s an old image so i am not sure but I think it is one.

      posted in FOG Problems
      J
      jmeyer
    • RE: Error deploying old image with partimage

      I have tried to run partimage in debug and it says that partition is too small to be restored.
      Original size is : 250059317760 and destination size is 250058301440.

      Is there a way to bypass this ?

      posted in FOG Problems
      J
      jmeyer
    • Error deploying old image with partimage

      I am running 1.5.0 RC 11 and since few update, I have this error.

      0_1516955488912_IMG.jpg

      Here are the files in the directory of the image.

      0_1516955519413_704177fa-af2d-4357-a17a-472a8b9c745c-image.png

      posted in FOG Problems
      J
      jmeyer
    • RE: Working Tree

      @Tom-Elliott I have make a look at GUI this morning and I didn’t see anything blocking me. I would like to say that it looks functional for an average use.

      • The view in “Hosts and Users Login” with 50 users in a column is a bit hard to read. 😛
      • “User tracking - Search” give blank page.
      posted in Announcements
      J
      jmeyer
    • RE: Working Tree

      As I work under VMWare, i’ll make a snapshot of my server and run the update.
      I missed bothering Thomas for bugs. 😉

      posted in Announcements
      J
      jmeyer
    • RE: FOG 1.4.0 Officially Released

      Great work !! :clap_tone1:

      posted in Announcements
      J
      jmeyer
    • RE: Reg Query with 0.11.11 client

      Tested using VBS.
      Result is the same and even

      objShell.ExpandEnvironmentStrings( "%COMPUTERNAME%" )
      

      return nothing.

      posted in FOG Problems
      J
      jmeyer
    • RE: Reg Query with 0.11.11 client

      I kind of make errors using “if defined ValueName ()” command.
      To confirm that “reg query” is the problem and that i don’t have problem of rights to create a directory, I have tested again with these two lines in my script.
      ( because I just realised that topic was a bit focusing on the wrong thing)

      if defined ValueName (echo %COMPUTERNAME%;%ValueValue% >> \\console\wsusclients$\logs.csv)
      echo %COMPUTERNAME%;%ValueValue% >> \\console\wsusclients$\logs.csv
      

      I have only one line in the logs.csv that is

      console;
      

      It means ValueName has no value.

      posted in FOG Problems
      J
      jmeyer
    • RE: Reg Query with 0.11.11 client

      @Joe-Schmitt That’s what I did. Hidden share with full rights for everybody.
      0_1490100750932_upload-8e7a1ce9-c6c8-4ae7-a79d-814c2cc89026

      0_1490100594460_upload-e0a2ee84-7e11-4ed0-9d89-9ad6bac85ecb

      posted in FOG Problems
      J
      jmeyer
    • RE: Max task for single snapin

      @Tom-Elliott

      Your command has changed something.
      Now, it runs “single snapin” only on the host that have it added (it means only 1).
      Is this normal ? lol

      edit : Found out, with Thomas, that I have to associate this snapin to each host to create a working task for every host using group single snapin task.

      posted in FOG Problems
      J
      jmeyer
    • RE: Reg Query with 0.11.11 client

      Yes it is. Here is the orginal code :

      @echo OFF
      
      setlocal ENABLEEXTENSIONS
      set KEY_NAME=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
      set VALUE_NAME=SusClientId
      
      FOR /F "tokens=1-3" %%A IN ('REG QUERY %KEY_NAME% /v %VALUE_NAME% 2^>nul') DO (
          set ValueName=%%A
          set ValueType=%%B
          set ValueValue=%%C
      )
      
      if defined ValueName (
      	echo %COMPUTERNAME%;%ValueValue% >> \\console\wsusclients$\logs.csv
      )
      
      posted in FOG Problems
      J
      jmeyer
    • RE: Reg Query with 0.11.11 client
      ------------------------------------------------------------------------------
      ---------------------------------SnapinClient---------------------------------
      ------------------------------------------------------------------------------
       20/03/2017 16:38 Client-Info Client Version: 0.11.11
       20/03/2017 16:38 Client-Info Client OS:      Windows
       20/03/2017 16:38 Client-Info Server Version: 1.3.5
       20/03/2017 16:38 Middleware::Response Success
       20/03/2017 16:38 SnapinClient Snapin Found:
       20/03/2017 16:38 SnapinClient     ID: 272
       20/03/2017 16:38 SnapinClient     Name: WSUS ID
       20/03/2017 16:38 SnapinClient     Created: 2017-03-20 15:38:00
       20/03/2017 16:38 SnapinClient     Action: 
       20/03/2017 16:38 SnapinClient     Pack: False
       20/03/2017 16:38 SnapinClient     Hide: False
       20/03/2017 16:38 SnapinClient     Server: 
       20/03/2017 16:38 SnapinClient     TimeOut: 0
       20/03/2017 16:38 SnapinClient     RunWith: cmd.exe
       20/03/2017 16:38 SnapinClient     RunWithArgs: /c
       20/03/2017 16:38 SnapinClient     Args: 
       20/03/2017 16:38 SnapinClient     File: SusClientId.cmd
       20/03/2017 16:38 Middleware::Communication Download: http://fogserver/fog/service/snapins.file.php?mac=4C:CC:6A:32:E5:4B||00:00:00:00:00:00:00:E0&taskid=272
       20/03/2017 16:38 SnapinClient C:\Program Files (x86)\FOG\tmp\SusClientId.cmd
       20/03/2017 16:38 Bus {
        "self": true,
        "channel": "Notification",
        "data": "{\r\n  \"title\": \"Installation de WSUS ID\",\r\n  \"message\": \"Ne pas éteindre l'ordinateur tant que la tâche n'est pas terminée\"\r\n}"
      }
       20/03/2017 16:38 Bus Emmiting message on channel: Notification
       20/03/2017 16:38 SnapinClient Starting snapin...
       20/03/2017 16:38 SnapinClient Snapin finished
       20/03/2017 16:38 SnapinClient Return Code: 0
       20/03/2017 16:38 Bus {
        "self": true,
        "channel": "Notification",
        "data": "{\r\n  \"title\": \"WSUS ID installé\",\r\n  \"message\": \"L’installation est terminée, prêt pour l'utilisation\"\r\n}"
      }
       20/03/2017 16:38 Bus Emmiting message on channel: Notification
       20/03/2017 16:38 Middleware::Communication URL: http://fogserver/fog/service/snapins.checkin.php?taskid=272&exitcode=0&mac=4C:CC:6A:32:E5:4B||00:00:00:00:00:00:00:E0&newService&json
      ------------------------------------------------------------------------------
      
      posted in FOG Problems
      J
      jmeyer
    • Reg Query with 0.11.11 client
      Server
      • FOG Version: 1.3.5
      • OS: Ubuntu
      Client
      • Service Version: 0.11.11
      • OS: Windows 10 pro 64 bits
      Description

      I run a script that write on a network share and use reg query.
      It was working fine on 1.3.4 but since i have updated to 1.3.5, some commands doesn’t look to work.
      I can write in local (such as c:) but not using \aComputerName\Myshare even using a “net use”.
      Reg query doesn’t return anything neither.

      These are the test I have done writing localy

      echo 1. blablabla >> C:\logs.txt
      REG QUERY %KEY_NAME% /v %VALUE_NAME% >> C:\logs.txt
      echo 3. %KEY_NAME% >> C:\logs.txt
      echo 4. %VALUE_NAME% >> C:\logs.txt
      echo 5. titi;toto;tata >> C:\logs.txt
      echo 6. %COMPUTERNAME%;%ValueValue% >> C:\logs.txt
      

      Here are the results :

      1. blablabla 
      3. HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate 
      4. SusClientId 
      5. titi;toto;tata 
      6. console; 
      
      posted in FOG Problems
      J
      jmeyer
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 14
    • 15
    • 6 / 15