Surface Pro 4


  • Testers

    Hi Everyone,
    I am unable to get a Surface pro 4 to quick image. I have the UEFI co-existence set up on my DHCP server. I am running 1.3.5. I am using a Microsoft model 1663 usb to ethernet dongle to connect. I have used a powered USB hub as well to no avail. Please see the below picture. I am able to get to the fog menu but it fails at this point.
    0_1491844992340_unnamed.jpg

    Note: I have successfully imaged surfaces in the past with the same setup. Kernel is latest

    Thanks


  • Testers

    @dylan123 As stated earlier, I got an instant “Failed to get IP via DHCP” error when I had just the dongle plugged directly in. I also am already using the “has_usb_nic=1” argument. Lastly. I have both the dongle MAC and the USB hub MAC listed in the host.


  • Moderator

    @dylan123 said in Surface Pro 4:

    the surface keyboard worked fine plugged in so I didn’t really have any need for the usb hub.

    The keyboard working for the surface 3 is a new thing in Linux, a year ago I don’t think the kernel supported it. A lot of people just don’t know it is working now.



  • @fry_p So if I’m understanding correctly, you’ve got your Surface with a USB hub directly connected to that. From that you’ve plugged in your surface adapter to one of those ports? Kind of makes sense with it struggling given it’s trying to get the IP from the other adapter.

    I think to get this working together you’d want turn your surface on with the USB hub connected. CMD > getmac to figure out the mac address for both the HUB ethernet and the surface adapter. Then you can open up the fog dashboard, create a new host, manually add both mac addresses (making the surface adapter the primary one). Then under the FOG_KERNEL_ARGS section, add has_usb_nic=1. I imagine the next time you try to image it with all of that connected it should work.

    With all of that said, do you really need to use the USB hub? Can you not just plug the surface usb > Ethernet adapter in directly? I haven’t done a full test with my 4 yet, but I know with the 3, the surface keyboard worked fine plugged in so I didn’t really have any need for the usb hub.


  • Testers

    @dylan123 Brilliant suggestion, I didn’t think of that. Unfortunately, with the dock disconnected, we have the same result. I have also tried using the nic on the dock. I have tried a powered usb hub as well. I get the “Failed to get an IP via DHCP” message immediately if I have the usb nic directly connected. In the hub, it waits 35 seconds before the message pops up.

    EDIT: I think I figured it out. I failed to realize that my powered USB hub has its own nic. I gather that it is switching the interface to that once it gets to the screen I am having trouble with. My first test, I let it pxe boot and when it got to the “Sleeping for 5 seconds” part, I quickly swapped the ethernet from the microsoft dongle to the USB hub port. It imaged perfectly. My second test is to hook up network to both the USB hub and the dongle going into the USB hub, and I had no trouble. I guess it is “switching” from the microsoft dongle MAC to the USB hub MAC when it hits this stage. I will try to get a powered usb hub (tried non powered to no avail) sans the nic. I am just curious why the stupid dongle by itself can’t pull an ip at that stage.



  • Out of interest Fry, looking at the image you’ve attached in the OP, is your surface still attached to the docking station as the charger looks like the fat one for the docking station rather then just the power lead which is much thinner? Just curious as to whether having that disconnected makes any difference as it might be trying to read the docking station USB interfaces instead o the one directly connected to the surface?


  • Moderator

    @fry_p Here are the better threads on the Surface Pro topic: https://wiki.fogproject.org/wiki/index.php?title=Surface_Pro


  • Testers

    @Tom-Elliott I followed the exact steps in the highlighted in the solution post on this thread to no avail: https://forums.fogproject.org/topic/9704/surface-3-unable-to-obtain-dhcp/22

    It almost appears that it is looking at the wrong interface. Is there a way to specify the interface in fog? It is looking at USB0 but when I unplug the dongle, it states USB2-port1 is the one being pulled.

    EDIT: Just noticed i triple posted, sorry. I am just eager to get this working. It is the superintendent’s surface that needs an image, go figure.


  • Testers

    @Tom-Elliott Just got to 1.4.0 RC4, still no luck. I tested the USB nic on an already imaged surface for plain connectivity and it worked for that. I tried to image a Pro 3 with the dongle and the same issue. Please let me know what info you need from me.


  • Testers

    @Tom-Elliott oops i mean 4.10.9


  • Senior Developer

    @fry_p Roger, thank you.


  • Testers

    @Tom-Elliott Sorry the kernel is 4.10.1. In my DHCP policy, the 7156 is the file it points to. I can move to RC and try. I have an different upload running so I’ll try the RC in a bit.


  • Senior Developer

    What boot file are you using? Are you using ipxe7156.efi? This is the only file, that I’m aware of, that consistently works with these Surface machines. As far as network not working, I don’t know about that. Maybe, if you can, try another usb port? Also would you mind telling the VERSION of the kernel? “The latest” is in regards to what’s currently available? I just pushed up 4.10.9 so I’m “assuming” this is the version you’re referring to. I might also ask if you can try the RC versions of FOG. The fact that “Failed to get an IP via DHCP! Tried on interface(s):” shows that the system isn’t detecting a single nic to use. It also appears to show that there is NO nic to use. You pair that with the error message (Cannot enable. Maybe the USB cable is bad?) (This is not my message btw), seems to point to the device being unrecognized.


Log in to reply
 

405
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.