After Update to RC-12 extremly slow



  • Server
    • FOG Version: 1.3.5-RC-12
    • OS: Debian 8
    Description

    I just updated to RC-12, but FOG is now extremly slow, the dashboard for example takes several seconds and there is now data displayed (queu and storage). After a reboot it’s quick again but only for a few seconds. Apache logs doesn’t show me anything…


  • Moderator

    @Tom-Elliott So will you start including those? I don’t understand.


  • Senior Developer

    @Polii123 Sorry, it was suggested of me to use “binaries” during RC’s as during our resize stuff it was possible for 10 different people to have 10 different inits (making troubleshooting a pain).

    As I typically don’t update the client files in these binaries until a “stable” release, the binaries.zip file didn’t have the 0.11.10 client version.



  • This is repeating over and over. I tried to uninstall the client manually and installed it again but then this happens:

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     09.03.2017 17:43 Client-Info Version: 0.11.9
     09.03.2017 17:43 Client-Info OS:      Windows
     09.03.2017 17:43 Middleware::Authentication Waiting for authentication timeout to pass
     09.03.2017 17:43 Middleware::Communication Download: http://172.30.40.25/fog/management/other/ssl/srvpublic.crt
     09.03.2017 17:43 Middleware::Authentication ERROR: Could not authenticate
     09.03.2017 17:43 Middleware::Authentication ERROR: Der Wert darf nicht NULL sein.
    Parametername: authority
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     09.03.2017 17:43 Client-Info Version: 0.11.9
     09.03.2017 17:43 Client-Info OS:      Windows
     09.03.2017 17:43 Middleware::Authentication Waiting for authentication timeout to pass
     09.03.2017 17:44 Controller Stop
     09.03.2017 17:44 Service Stop requested
     09.03.2017 17:44 Middleware::Authentication ERROR: Could not authenticate
     09.03.2017 17:44 Middleware::Authentication ERROR: Der Thread wurde abgebrochen.
     09.03.2017 17:44 Bus {
      "self": true,
      "channel": "Status",
      "data": "{\r\n  \"action\": \"unload\"\r\n}"
    }
     09.03.2017 17:44 Bus Emmiting message on channel: Status
    
    
    

    Had to split in to posts because i couldn’t get to codes in one post.

    Looks like I’m not the only one.:
    https://forums.fogproject.org/topic/9685/fog-agent-0-11-9-response-module-disabled



  • I guess i found the problem, it looks like the client updater has some problems.

    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     09.03.2017 17:43 Client-Info Version: 0.11.9
     09.03.2017 17:43 Client-Info OS:      Windows
     09.03.2017 17:43 Middleware::Authentication Waiting for authentication timeout to pass
     09.03.2017 17:43 Middleware::Communication Download: http://172.30.40.25/fog/management/other/ssl/srvpublic.crt
     09.03.2017 17:43 Data::RSA FOG Server CA cert found
     09.03.2017 17:43 Middleware::Authentication Cert OK
     09.03.2017 17:43 Middleware::Communication POST URL: http://172.30.40.25/fog/management/index.php?sub=requestClientInfo&authorize&newService
     09.03.2017 17:43 Middleware::Response Success
     09.03.2017 17:43 Middleware::Authentication Authenticated
    
    
     09.03.2017 17:43 Bus Registering ParseBus in channel Power
     09.03.2017 17:43 Middleware::Communication URL: http://172.30.40.25/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     09.03.2017 17:43 Middleware::Response Success
     09.03.2017 17:43 Middleware::Communication URL: http://172.30.40.25/fog/management/index.php?sub=requestClientInfo&mac=4C:CC:6A:33:FC:FD||00:00:00:00:00:00:00:E0&newService&json
     09.03.2017 17:43 Middleware::Response Success
     09.03.2017 17:43 Middleware::Communication URL: http://172.30.40.25/fog/service/getversion.php?clientver&newService&json
     09.03.2017 17:43 Middleware::Communication URL: http://172.30.40.25/fog/service/getversion.php?newService&json
    
     09.03.2017 17:43 Service Creating user agent cache
     09.03.2017 17:43 Middleware::Response Invalid time
     09.03.2017 17:43 Middleware::Response No Printers
     09.03.2017 17:43 Middleware::Response Module is disabled globally on the FOG server
     09.03.2017 17:43 Service Initializing modules
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     09.03.2017 17:43 Client-Info Client Version: 0.11.9
     09.03.2017 17:43 Client-Info Client OS:      Windows
     09.03.2017 17:43 Client-Info Server Version: 1.3.5-RC-12
     09.03.2017 17:43 Middleware::Response Success
     09.03.2017 17:43 Middleware::Communication Download: http://172.30.40.25/fog/client/SmartInstaller.exe
     09.03.2017 17:43 Data::RSA FOG Project cert found
     09.03.2017 17:43 ClientUpdater Update file is authentic
    -----------------------------------------------------------```

  • Developer

    @Polii123 after you reset the encryption data, it takes a while for the clients to all check in and get up to date.



  • Just reseted the encription data, and restarted apache. But this didn’t help. I even tried re-running the installer…

    Edit:

    Seems to be good now… Seems something was happening in the background :s Anways, glad it’s working now.


  • Senior Developer

    @Polii123 I can’t tell.

    You may think about resetting host encryption data though? I’d check on of your clients and see if they’re complaining about “Authentication Timeout to pass” or “Invalid Security Token”



  • p is an unknown comand in top…

    The only thing I see is a bunch of apache2 processes, is this normal?

     888 mysql     20   0 1366160 115108  10984 S   9.7  2.8   4:50.99 mysqld
    16798 www-data  20   0  325276  21932  14208 R   9.7  0.5   0:05.70 apache2
    17956 www-data  20   0  326832  25308  16056 R   9.7  0.6   0:00.83 apache2
    17958 www-data  20   0  324448  20492  12320 R   9.7  0.5   0:00.60 apache2
    16403 www-data  20   0  363960  62940  16528 R   6.5  1.6   0:12.68 apache2
    16419 www-data  20   0  326060  24464  16132 R   6.5  0.6   0:07.49 apache2
    16745 www-data  20   0  326828  25248  16068 R   6.5  0.6   0:06.28 apache2
    17063 www-data  20   0  326252  23708  13540 R   6.5  0.6   0:03.00 apache2
    17106 www-data  20   0  327728  26192  16120 R   6.5  0.6   0:03.46 apache2
    17124 www-data  20   0  327472  26172  16056 R   6.5  0.6   0:03.51 apache2
    17817 www-data  20   0  325228  22544  13348 R   6.5  0.6   0:01.49 apache2
    17873 www-data  20   0  325900  23536  13476 R   6.5  0.6   0:01.36 apache2
    17930 www-data  20   0  323948  21260  13476 R   6.5  0.5   0:00.57 apache2
    17931 www-data  20   0  327728  24148  14016 R   6.5  0.6   0:00.84 apache2
    17941 www-data  20   0  324460  21564  13336 R   6.5  0.5   0:00.72 apache2
    17947 www-data  20   0  326828  25300  16056 R   6.5  0.6   0:01.04 apache2
    17951 www-data  20   0  323952  21236  13400 R   6.5  0.5   0:00.66 apache2
    17953 www-data  20   0  326288  22328  13780 R   6.5  0.6   0:00.67 apache2
    17954 www-data  20   0  325132  22816  13464 R   6.5  0.6   0:00.80 apache2
    10491 root      20   0   82740   6028   5148 S   3.2  0.1   0:01.85 sshd
    16398 www-data  20   0  327228  26484  16776 R   3.2  0.7   0:10.37 apache2
    16411 www-data  20   0  326060  24676  16344 R   3.2  0.6   0:08.76 apache2
    16788 www-data  20   0  325272  22064  14144 R   3.2  0.5   0:04.83 apache2
    16800 www-data  20   0  382376  80240  15856 R   3.2  2.0   0:10.24 apache2
    16925 www-data  20   0  323952  21280  13540 R   3.2  0.5   0:04.71 apache2
    16936 www-data  20   0  326060  24452  16120 R   3.2  0.6   0:04.55 apache2
    16939 www-data  20   0  325900  23596  13528 R   3.2  0.6   0:04.93 apache2
    17071 www-data  20   0  325900  23528  13412 R   3.2  0.6   0:03.37 apache2
    17111 www-data  20   0       0      0      0 Z   3.2  0.0   0:03.27 apache2
    17474 www-data  20   0  326036  22316  14016 R   3.2  0.6   0:02.34 apache2
    17475 www-data  20   0  325280  24020  16092 S   3.2  0.6   0:02.51 apache2
    17479 www-data  20   0  326260  23576  13412 R   3.2  0.6   0:02.67 apache2
    17484 www-data  20   0  325228  22612  13412 R   3.2  0.6   0:02.45 apache2
    17507 www-data  20   0  325300  23996  16056 R   3.2  0.6   0:02.33 apache2
    17933 www-data  20   0  327736  23756  13612 R   3.2  0.6   0:00.72 apache2
    

  • Senior Developer

    @Polii123 If you run top -d 0.3

    When in top type the letter p

    It will sort items by highest CPU usage. 0.3 is pretty fast but should help you see what’s using the processes on the system. If you can grab a few seconds of video and post it, or maybe it will help lead you to whatever the issue is?



  • Replication isn’t possible, I only have one node.

    CPU load states 68.6 us, 27.2 sy, i guess that’s high? There should be enough disk space aswell.

    I jumped from 1.3.4 to 1.3.5 RC-12, but this shouldn’t be a problem right?


  • Senior Developer

    Beyond that, the reasoning RC-11 was released (beyond image resizing issues) was to address a load issue. This was not changed for RC-12, so I’m not thinking this is a BUG in the sense that the only differences between 11 and 12 were related to imaging. (Resizing, and getting multicast-sessions to work).


  • Senior Developer

    I can only think your images and/or snapins are trying to replicate right now.

    Just a guess. Maybe see if those logs are showing anything?

    Is your CPU load high? Maybe disk space really low? Maybe RAM is being used quickly?


Log in to reply
 

424
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.