All fog services turning off on hosts after reimage.



  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu 14.04LTS
    Client
    • Service Version: 0.11.9
    • OS: Windows 10 Enterprise
    Description

    I have just reimaged 2 machines, and both had all services turned on prior to being imaged, however after the Windows image was pushed all of the services under “Service Settings” on the FOG Web GUI were turned off which then causes the client not to be renamed or to run snapins. However if the services are re-enabled after the imaging process is done, the client will run snapins prior to changing its hostname. which then causes my powershell script to join computers to domain with a name I don’t intend for them to have.



  • Hi,

    something additional, today i registered a host, enabled domain join and a snapin like i always do. deployed the image and was wondering why the host hasn’t joined the domain. After checking the hosts settings i could see that joining domain wasn’t saved for this host. enabled it again and the host joined the domain and rebooted.

    I don’t know if this is related but i have the feeling it could.

    Regards X23



  • @george1421 Sorry, I mixed up terminology there.

    The Fog-Client-Service runs just fine (i use setupcomplete to enable it and then start it, and yes it is set to delayed start, but that usually works out fine somehow.

    I’m talking about the service settings in the fog webgui.



  • Hi,

    i also have seen this behaviour, i cannot say exactly with or since which version this happened.
    But i can remember that i deployed a client and i was wondering that the task wasn’t finished as expected.

    After head scratching i could see that all the services where not enabled (normally they are active by default).

    Regards X23


  • Moderator

    @pijltje said in All fog services turning off on hosts after reimage.:

    In my case de services is running oke on the client.
    The issue remain on the fog server, all the client settings are checked before imagine a computer and after imagine the computer (or again) all the client setting are unchecked. in the fog GUI "Client Settings"
    If manually checked again after imaging, then the client will apply the client settings and reboot.
    and everything is working oke.

    @Developers This one is a bit strange, image deployment resets Host Management-><host>->Service Settings in FOG 1.5.0. Is this a new feature ;-)



  • @george1421
    In my case de services is running oke on the client.
    The issue remain on the fog server, all the client settings are checked before imagine a computer and after imagine the computer (or again) all the client setting are unchecked. in the fog GUI "Client Settings"
    If manually checked again after imaging, then the client will apply the client settings and reboot.
    and everything is working oke.

    Just noticed the the current power management settings are also gone after re-imaging


  • Moderator

    @taspharel Just for clarity (since the OP is talking about a down level version). After imaging, in the setupcomplete.cmd file, you use the sc command to enable the fog client service, then you manually start the service. After a reboot the service is not restarting? Where exactly is it failing? I do remember reading a discussion about setting the service to delayed start instead of auto. I’m not sure that applies here. But the developers will need to understand exactly where its failing.



  • It happens to me as well, but so far I would have assumed that I just forgot to activate the service settings for the machines where it happens, but it does happen quite often.

    FOG latest RC
    OS Centos 7
    Images being installed are Win10 - 1709



  • Hi,

    I am expiring also the same issue, and was wondering if any one has found a answer for this issue

    Server
    Fog 1.5.0.16
    OS Centos 7

    Client
    Service Version 0.11.15
    OS Windows 10 1709 Education



  • Did you check fog.log?



  • Has anyone experienced something similar to this? I just upgraded to 1.3.5-RC1 and the issue is still there



  • @Raymond-Bell Yes they are all enabled by default, and they are enabled prior to pushing the image to the machines, however they all get unchecked specifically for the machines I imaged.


  • Testers

    @davidedpg10 Have you got all services turned on global? Are the all checked under FOG Configuration,
    FOG System Settings


 

385
Online

41.4k
Users

11.8k
Topics

112.1k
Posts