PDF Report Blank



  • Server
    • FOG Version: 1.3.0 RC33
    • OS: UBUNTU 16.04
    Client
    • Service Version:
    • OS:
    Description

    When using report management i can export pdf document, but it always blank.
    Any idea why?

    Thank You
    Albertus



  • @Tom-Elliott

    Problem was fixed in RC-34/35

    Thank You


  • Moderator

    @Quazz said in PDF Report Blank:

    Curious how this problem seems to limit itself to Ubuntu (so far as we know), though.

    My home-production server I tested on is running CentOS 7.


  • Senior Developer

    In the latest, the banner logo is now a part of the header of the HTML documents too, YAY!


  • Senior Developer

    @Quazz I was able to replicate the problem.

    Should be fixed in RC-34.


  • Moderator

    @x23piracy Probably want to run apt-get auto-remove to clean that stuff up.

    Curious how this problem seems to limit itself to Ubuntu (so far as we know), though.

    edit: changed to apt-get for ubuntu 14



  • @Tom-Elliott said in PDF Report Blank:

    @x23piracy Don’t forget, you might need to install htmldoc (if it’s not already installed).

    root@fog:~# apt-get install htmldoc
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    htmldoc ist schon die neueste Version.
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
      dbconfig-common javascript-common libjs-codemirror libjs-jquery
      libjs-jquery-cookie libjs-jquery-event-drag libjs-jquery-metadata
      libjs-jquery-mousewheel libjs-jquery-tablesorter libjs-jquery-ui
      libjs-underscore libonig2 libqdbm14
    Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.```

  • Moderator

    Found this in my error log, which is pretty obvious:

    sh: htmldoc: command not found
    sh: htmldoc: command not found
    

  • Moderator

    @Wayne-Workman Only thing I can think of that might be different (aside from RC version) is that I at one point installed the yumgroup for development tools.


  • Moderator

    @Quazz Nah, I tested on my home fog server. It has about 6 machines in inventory.

    I got a new job that starts a little later in the day, so I’m able to prowl the forums just in the mornings and after work for now.


  • Moderator

    @Wayne-Workman They all work fine on my end. Not sure what else I can say about it, maybe your inventory is far larger causing it to fail?

    Also, I’m on RC33

    Do you have the same apache errors as x23piracy?


  • Moderator

    @Quazz I’m running CentOS 7, RC-30 and I have the same blank report described here.

    Report Management -> Inventory -> PDF

    Gives me a file called InventoryReport.pdf that is 0 bytes in size.

    Moved to bugs.


  • Senior Developer

    @x23piracy Don’t forget, you might need to install htmldoc (if it’s not already installed).



  • Can someone else under ubuntu test the pdf export feature too please?


  • Moderator

    @x23piracy It’s possible, I’m using Centos 7.



  • @Quazz Full Inventory Report is bringing me a broken pdf, imaging log produces a working but empty pdf. no entrys in apache error log.

    Is it maybe OS related? I am under Ubuntu 14 the op is under 16 what do you use?

    i made a server reboot and i can see this in error logs before trying to export to pdf, when i try to make a export again file is still broken and no additional log lines in error log.

    [Mon Dec 12 13:36:24.896317 2016] [php7:warn] [pid 20706] [client 172.19.102.88:62688] PHP Warning:  PDOStatement::execute(): MySQL server has gone away in /var/www/fog/lib/db/pdodb.class.php on line 551
    [Mon Dec 12 13:36:24.896393 2016] [php7:warn] [pid 20706] [client 172.19.102.88:62688] PHP Warning:  PDOStatement::execute(): Error reading result set's header in /var/www/fog/lib/db/pdodb.class.php on line 551
    [Mon Dec 12 13:36:28.477282 2016] [mpm_prefork:notice] [pid 32405] AH00169: caught SIGTERM, shutting down
    [Mon Dec 12 13:37:03.960928 2016] [mpm_prefork:notice] [pid 1392] AH00163: Apache/2.4.23 (Ubuntu) OpenSSL/1.0.2j configured -- resuming normal operations
    

    Regards X23


  • Moderator

    PDF export is working for me (tested with imaging log)

    Which reports are you trying to export to PDF and is there anything in the Apache error logs?

    EDIT: I personally did get the following apache error, but it did not prevent successful PDF export

    [Mon Dec 12 10:43:14.903261 2016] [:error] [pid 13411] [client 192.168.1.152:56164] PHP Warning: array_pop() expects parameter 1 to be array, null given in /var/www/html/fog/lib/pages/reportmanagementpage.class.php on line 341, referer: http://192.168.1.154/fog/management/index.php?node=report&sub=imaginglog
    


  • Good Day

    Thank You.



  • @Tom-Elliott confirmed, seems to be a bug :) For me the pdf is broken not empty (E/A error)

    alt text

    Excel export is working fine.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.