Dual boot windows 7 & opensuse boot problem



  • I recently using fog as cloning software in my company. Everything work fine, until someday i need to clone pc with widows 7 & opensuse.
    I’ve tried many ways, from tutorial from wiki that use os type linux and multpartition single disk, but that not seems work when i finished to clone, windows 7 bootloop and opensuse blackscreen with text GRUB GRUB.

    Then i tried with my way, choose os type windows 7 and mltipartition single disk. Widows 7 work fine, but opensuse blackscreen with text Initramfs unpacking failed.

    Anyone have tried cloning dual boot like me before, or have the solution.
    Thankyou



  • @Sebastian-Roth
    Yes, My image is not resizable…
    I will try to reproduce my steps…
    1 - Erase disk data/delete partitions
    2 - Install Windows, reserving space for linux or shrink windows later (in disk management tool, or gparted if needed).
    3 - Install Linux, install grub on mbr or partition.
    4 - Configure grub if needed ( i had to make some minor changes only in Debian8/Windows10 because grub was listing windows 10 as 7)

    My preference to use grub is because i can make changes in boot order, one time boot order and so on… easily using ansible or other management tool. I don’t know how can i achieve the same in Windows side.


  • Developer

    @ricky-ext FOG 1.2.0 is years old. I don’t remember exactly but possibly there was an issue with multicast and SWAP. I don’t know. We won’t fix this anyway. If you care about multicast (and I totally understand that you do!) then you need to update to the latest release candidate or wait till 1.3.0 will be released.



  • @Sebastian-Roth Thank you for your advice, okay i’ll follow your setup. Thank you for your help guys !

    But, i have a new problem here,
    When deploy dual boot image, using Unicast no problem, everything work perfect.
    And when i deploy it with Multicast, there is a problem. I think when we used multicast mode, that cannot deploy SWAP partition. Or this is only happened to me?

    After this i’ll follow your setup bro @Sebastian-Roth


  • Developer

    @Thiago There is no right or wrong as long as it is working for you guys. But yours definitely looks a bit cleaner to me. Although you might run into trouble with this hidden NTFS partition (sda1, type=27) if you want to use resizable image type. Not saying that you will, but possibly could…

    Please tell us a bit more about your steps on installing the two OSes. I guess you installed Windows first and then linux. What about the bootloader. Which one are you using and how did you install it? Skipped GRUB install on linux install and added it into the windows loader by hand? Or did you let linux take care of the bootloader stuff when installing and everything just went fine?



  • @ricky.ext
    this is from one of my images:

    label: dos
    label-id: 0x40c79279
    device: /dev/sda
    unit: sectors
    
    /dev/sda1 : start=        2048, size=     2097152, type=27
    /dev/sda2 : start=     2099200, size=   222398464, type=7
    /dev/sda3 : start=   224497664, size=     1953792, type=82
    /dev/sda4 : start=   226451456, size=    86128640, type=83, bootable
    

    I don’t know if this is correct, but works for me.


  • Developer

    @ricky-ext Sorry to say this but I still find your partition layout a bit of a mess - but well that’s just my opinion. Your very first partition (sda1) is an extended one (or actually pointing to the extended partitions - sda5 and sda6 as linux calles those). As you see sda1 starts at sector 2048 and sda5 at 4096. Physically those extended partitions are not number 5 and 6 but 1st and 2nd! I am sure windows is showing you the extended partition(s) first in the disk manager tool.

    As you proofed it’s definitely possible to install dual boot like this. But I’d never recommend having the extended partitions first because it can be confusing and could lead to human failures.

    Next is the partition type of sda4. It’s FAT16 (id 6). How were you able to set this partition type. Did you really format this partition with FAT16? I doubt it. FAT16 is not made for such “big” disks/partitons and shouldn’t be used nowadays!

    If it is working for you, you might just stay with it…



  • @Sebastian-Roth I think my previous setup wrong, so i creating from scratch my system. And i using vmware for my experiment.

    When i run sudo sfdisk -d /dev/sda the output:
    alt text

    Here my “mbr_images.tar.gz” after follow your step -> https://drive.google.com/file/d/0B4knU-eG9r1nVjlncEo3d2ZvUGc/view?usp=sharing

    And this how i setup my latest system:

    1. I install opensuse 11.4. Set a half of my hdd to extended, then i add “/” partition using ext3 and add “swap” partition. Ok, opensuse work perfectly.
    2. Install windows 7. Make remaining unlocated partition for my windows. I just set 1 partition “C” only. Done, windows 7 work perfectly. But Bootloader didn’t show, by default my setup boot into windows 7.
    3. Because my setup need dual boot os, so i need boot loader. Then i found easiest way that using EasyBCD. After success intall easyBCD to my windows, then i add new entry, on tab Linux/BSD and choose type bootloader GRUB(Legacy), and i let “Use EasyBCD’s copy of GRUB”, then i save my config in easyBCD. Done, dual boot work nice and perfect, windows 7 and opensuse.
    4. I think my setup will work, so i creating image from that. With fog 1.2.0, i create new image with settings OS “Linux(50)” and image type “Multiple partition image - single disk”, this settings based on fog wiki. Finally, my system finished creating image of dual boot os.
    5. I ready for deploying my image to client, and finally the deployment finished. First i choose boot from windows 7, and system success boot and work perfectly. Second i choose boot from opensuse, OMG opensuse work perfectly too, i think my experiment success bro.

    How about my setup? Is that right or no? Thanks before bro.
    And @Thiago, how about my setup bro?



  • @Wayne-Workman
    :) each lab with its configuration and its specific purpose.

    @ricky-ext
    the same layout here, 2 partitions for each system.(windows boot, windows system, swap, /)
    i’m using grub to manage all.


  • Developer

    @ricky-ext We definitely need to know the exact partition layout. Boot opensuse and run sudo sfdisk -d /dev/sda and post the exact output here. If you installed windows and linux in UEFI mode then you might need to run gdisk -l /dev/sda

    Then as well I might be able to figure out your bootloader setup if you could run the following commands and upload the generated binaries here in the forum as well: dd if=/dev/sda of=/tmp/sda.mbr bs=512 count=2048 and this one dd if=/dev/sda1 of=/tmp/sda1.mbr bs=512 count=2048 plus the same command but put your linux root (/) partition instead of sda1.
    Then pack all those files into one compress tarball (tar cvzf /tmp/mbr_images.tar.gz /tmp/sda*) and upload the resulting file called “mbr_images.tar.gz” here in the forum.


  • Moderator

    @Thiago said in Dual boot windows 7 & opensuse boot problem:

    All of our computers are dual boot system.
    Some of them are Windows Vista/Debian, some Windows 10/Debian, Windows 10/Mint, Windows Vista/CentOS, Windows10/CentOS and so on.
    Fog works correctly in all the cases.
    How is your partition layout for opensuse (fs types)?
    What is your fog version?

    I think you should elaborate on YOUR setup lol!



  • @Thiago partition layout my opensuse using swap and /. But i install bootloader (using easyBCD) in windows 7 partition.
    My fog version is newest one 1.2.0
    How about your config for dual boot bro? so i can cloning easily



  • @Sebastian-Roth wow maybe my system not configured well. First i creating partition for os windows 7 and linux (suse), then i installing windows first then linux. And then i installed the boot loader in partition windows. That’s my config.
    How about your setup bro that would work?



  • This post is deleted!

  • Developer

    @ricky-ext I have successfully cloned dual boot system (Win 7 + Ubuntu). But it all depends on partition layout (sfdisk -d /dev/sda on that client) and boot loader used. We need more information to be able to help you with this. Please tell us how you installed windows and linux on that PC - which one was first - which one installed the boot loader last - which partition did you choose to install the bootloader (if so)???



  • All of our computers are dual boot system.
    Some of them are Windows Vista/Debian, some Windows 10/Debian, Windows 10/Mint, Windows Vista/CentOS, Windows10/CentOS and so on.
    Fog works correctly in all the cases.
    How is your partition layout for opensuse (fs types)?
    What is your fog version?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.