FOG client : printer from master appears on all client



  • Server
    • Version: 1.3-RC8
    • OS: Debian 8.5
    Client
    • Version: 0.11.5
    • OS: Win 10
    Description

    HI @Joe-Schmitt ;)
    I’ve prepared a win10 image on computer which has printer associate in fog (hostname res101 with printer S101laser1 associate).
    After capture image, if I deployed it on computers without any printer management (printer manager disable in “service settings” and “No Printer Management” in “Printers”), the initial printer continue to appears on all new hosts (and twice ^^)
    0_1472048668826_Capture.JPG

    And if I delete them, they came back soon :(

    Thanks,
    Matthieu



  • @Tom-Elliott I think you can close, I had to clean registry on these computers but when my image is clean deployment is ok.


  • Senior Developer

    @Matthieu-Jacquart Just guessing this still happens? (Trying to keep unsolved bugs to the first page so we don’t “lose” them).



  • @Tom-Elliott Yes problem persist, so I clean registry manually to delete those printers, and after it seems ok…
    But it’s not convenient at all !

    @Wayne-Workman Problem is I only use network shared printer (no ip printers)



  • In here, there’s a powershell script that you can use as a snapin that deletes all IP printers and IP ports. I’d only advise this if all your IP printers are managed by FOG already, as the FOG client would just re-add them back after this runs.
    https://forums.fogproject.org/topic/8406/fog-client-printer-not-displaying


  • Senior Developer

    bump, I’m still guessing this issue is still happening?



  • @Matthieu-Jacquart You could write a batch file that deletes that 2nd key, and deploy it with snapins.



  • @Tom-Elliott Ok I found problem, printer s101laser1 was stored in registry HKCU/printers and HKU/printers, so it appeared twice…
    If i removed these registry key it’s all good, now the problem is : if an image is built on host with network printer associate, this printer stay in registry, and I have to delete it manually on each computer…


  • Senior Developer

    @Matthieu-Jacquart is this really due to the fog client? If you disable the client and remove these printers and the host does the printers still appear?



  • @Wayne-Workman Some tests :

    • I enable printer manager service on these hosts and set it to Fog management printer, with no printer, but even after client reboot S101Laser1 always appears twice…
    • I deployed image on another host with no printer, but these 2 printers always appears, so if I upload image theses printers will stay in image…

    Maybe registry entry to modify/delete for these printers ?



  • @Matthieu-Jacquart For now, download the image to a computer, un-associate all fog printers and let the fog client delete them (do not do it manually). Then re-upload to a new image with a new name (so you don’t overwrite you’re old one).

    Then try to deploy this new image, see if you still have the issue.

    Also, re-pinging @Joe-Schmitt about what to do with all the other existing deployments.

    Also, this line from your log:

    24/08/2016 16:34 Middleware::Response Module is disabled on the host
    

    That would tell me that printer management is disabled on that computer. I would check that out. Set it to “FOG Managed Printers” and see if it’s fixed.



  • @Joe-Schmitt Any news about this ?
    I’ve got another image with same problem, 3 times same network printer, and if I delete them it appears few seconds later…



  • Pinging @Joe-Schmitt about this one.



  • I’ve got this after deployment

    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     23/08/2016 13:18 Client-Info Client Version: 0.11.5
     23/08/2016 13:18 Client-Info Client OS:      Windows
     23/08/2016 13:18 Client-Info Server Version: 1.3.0-RC-8
     23/08/2016 13:18 Middleware::Response Success
     23/08/2016 13:18 PrinterManager Getting installed printers
     23/08/2016 13:18 PrinterManager Adding printers
     23/08/2016 13:18 PrinterManager \\impression\s101laser1 has already been configured
    ------------------------------------------------------------------------------
    

    And 1 hour later

    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     24/08/2016 16:34 Client-Info Client Version: 0.11.5
     24/08/2016 16:34 Client-Info Client OS:      Windows
     24/08/2016 16:34 Client-Info Server Version: 1.3.0-RC-8
     24/08/2016 16:34 Middleware::Response Module is disabled on the host
     24/08/2016 16:34 PrinterManager Getting installed printers
    ------------------------------------------------------------------------------
    

    Printers don’t delete automatically and even if I delete them, reboot, then they’re come back !



  • We need the fog log from the computer.


 

408
Online

41.8k
Users

12.3k
Topics

115.9k
Posts