Do we have any solution without WOL scheduled..?



  • Why we can’t scheduled the task without WOL deploy or capture…?

    it helps if we scheduled the task (deploy or capture), PXE boot have to wait upto specified time period during boot itself (Like disk wipe waiting period)

    Thanks in advance


  • Moderator

    @Satheesh I don’t agree with what you want changed.

    Currently, - if a computer is off, a scheduled task will wake it up and perform the task.

    If it is on - and you’re using the FOG Client - the fog client will ask the user to allow maintenance, or to delay 10 minutes (currently). The client at the end of the delay will reboot the computer, and the computer performs the task.

    I don’t see how this isn’t good enough. You are asking for the computer to purposely hang during the boot process for - how long? That’s not acceptable. And why can’t WOL be turned on? You’re asking the developers to do a very major change because you don’t want to turn on WOL. We’re in Release Candidate mode - and this is way far out there - and not only is it way far out there, I just wouldn’t ever use a scheduled image task anymore because I don’t want my organization’s computers just hanging on boot. It’s unacceptable.

    My advice to you, turn on WOL like the rest of us did.



  • Thank God now you have understand my point… for this only I need a solution form your TEAM…

    Adding or integrating the below requirement on FOG

    Scheduled Delayed Deployment task is created and it will start in next few min / few Hours (date and Time) (press Esc to Normal boot)

    Now people can pressing Esc and use their computers normally in the mean time.


  • Moderator

    @Satheesh Well, it doesn’t really work like that. It will only attempt to start its task at the designated time. It won’t block you from accessing the menu until that point in time, so people can use their computers normally in the mean time.



  • @Quazz …I am using FOG 1.3.0 RC8…latest update

    Schedule delayed deployment and try boot up your system before designated time hits…


  • Moderator

    @Satheesh What version are you on? I ran a quick test and delayed deployment works fine for me.

    As soon as the designated time hits, I boot it up and it starts to do its assigned task.



  • @Quazz FOG server system time and WEB portal time & client system all are same with IST +5.30


  • Moderator

    @Satheesh There are numerous things that could cause delayed deployment to not work, one of them being your server timezone being incorrect somewhere. There’s a FOG setting for timezone you could check and of course on your system itself.



  • @Quazz Instant deployment is working perfect…

    Do we have solution for Scheduled Delayed Deployment by Uncheck of “Wake On LAN”…?


  • Moderator

    @Satheesh You don’t have to uncheck WOL if it’s not enabled on the machine. Try instant deployment instead, should work.



  • @Sebastian-Roth …I have written my queries in normal Indian English only.

    This is my planning
    I need to Deploy the image to desktop without enabling WOL.

    What I have done…
    I just went to Host Management -->select “Host”—> select “basic taks” ----Click “Deploy”, Uncheck “Wake On LAN” — Click schedule delayed deployment.

    Now “Host task” on FOG created…

    Now I will switch on my client host and leave it…

    Clinet host taken the IP from DHCP booted via TFTP…

    0_1472197418028_upload-e6fee390-9bc9-451c-88d3-8de3650340d0

    Now the system not waiting for Scheduled Delayed Deployment. It’s continuous to boot with main menu.

    Here is the problem.…If I create Scheduled Delayed Deployment task it not suppose to show this Booting menu. instead of that it have to say "your task will start in next few min / few Hours (date and Time)


  • Developer

    @Satheesh I think we all misunderstand your question. I read through this a couple of times not but still don’t understand what you really mean. What’s your native language. Maybe you could write in your language and we try to use google translate to figure out what exactly you mean. Please give it a try.



  • @Wayne-Workman …Please understand my question.

    I am planning to deploy/capture the image for one desktop without WOL enable.

    What I am doing…

    I just schedule the task in FOG…and then I will switch on my system and leave it…

    During PXE boot the system have to wait for sheduled task …it not suppose to boot with iPXE boot menu


  • Moderator

    @Satheesh That means your boot order goes to network first. It’s not WOL causing that. You just need to change your boot order.

    If you can’t do that easily, you can just hide the boot menu, it’s a setting in FOG Configuration -> iPXE boot menu.



  • Yes, I did but not stopping …it continuous to boot to PXE menu option


  • Moderator

    Just unselect the WOL option?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.