FOG FTP Permission Issue



  • So after upgrading to RC-8, I noticed that my settings must have changed to allow the server to save images from one of the NAS nodes to itself during imaging… I get an error saying:

    Could not mount images folder (/bin/fog.download)
          Args Passed:
             Reason: mount: mounting 172.16.200.173:/mnt/bhs/images/ on /images failed: Permission denied
    

    I have gone through the following wiki and have had little success here…

    https://wiki.fogproject.org/wiki/index.php?title=Images_Directory_Permissions

    I checked everything to make certain that the permissions were right on both ends. The problem lies when I try to put a file from the storage node to the server. My file permissions are set to 777 on the entire images directory on the server side. My passwords and usernames match on the fog server and on the NAS storage node. I checked to make sure these settings were correct in the fog web interface as well and they are. I also made sure fog was an owner and a member of the root group on that directory on the server.

    Any suggestions would be helpful. I have been able to image other images throughout the day. I just have one that is giving me a fit… I’ll be around after 1PM MST today if anyone wants to remote in if need be.

    I know this has to be something simple and it’s driving me crazy! LOL

    Thanks!

    Cheers,

    Joe



  • @Wayne-Workman Ok. I’ll try that. I disabled that node for right now to get my immediate imaging tasks done. I’ll try that though later this afternoon if I get time. Thanks!!

    I think I went through this before but I can’t seem to find my previous posts about it. Ugh…

    Thanks!!

    Cheers!



  • @Joe-Gill Do a debug capture, and manually mount the remote NFS share yourself. See what happens. Instructions on this are in the wiki:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_NFS



  • @Quazz
    @Developers

    I have tried updating our FreeNAS server exports file to:

    [root@freenas ~]# cat /etc/exports                                              
    /mnt/bhs/data/images -alldirs -mapall=Free:Free -network 172.16.1.0/24          
    -mask 255.255.0.0  
    

    I still get the same response in FOG… Mounting image fails.

    I can FTP from my servers /images directory into the FreeNAS server and transfer a file to and from the /mnt/bhs/data/images directory. I didn’t start seeing this problem until recent releases of FOG. I’m kind of at a loss here. I’ll be here until 5:30 MST if anyone would like to remote in. Any ideas are greatly appreciated!

    Cheers,

    Joe


  • Moderator

    @Joe-Gill I have a NAS4FREE server that I used as a node in the past. I just used the GUI to config it, but here’s the exports file for it anyway

    /mnt/INSTALLERS -alldirs -mapall=root -network 192.168.1.0 -mask 255.255.255.0
    

    But more importantly, I notice your Storage Node page has browser autofill on it, so likely your password is being overwritten with the GUI login.



  • I was out of town last week. I’ll look at it again this week. I believe that it’s still an issue though. If I get a chance today I’ll look at it and update this post. Thanks!

    Cheers,

    Joe



  • @Joe-Gill What is the status on this issue? Do you still need/want help?



  • @Wayne-Workman Sorry Wayne, I was offline. I left my machine on at the office. I’ll be busy this morning but may be around later this afternoon to work on this. Thanks again!



  • @Joe-Gill I tried messaging you earlier today (top right- talk bubble). I’d like to help, to figure out what’s going on.



  • @Wayne-Workman I had originally posted the /etc/exports file from the server… It did NOT have the correct settings. This from the freeNAS storage node appears to be correct… I tried adding

    /mnt/bhs/data/images -maproot=fog:fog
    

    and that did not work…

    Exports file from freeNAS node…

    /mnt/bhs/data/images/dev -maproot=Free:Free
    /mnt/bhs/data/images -alldirs -maproot=Free:Free -network 172.16.1.17/24

    0_1471299441548_freenas node.png



  • @Joe-Gill said in FOG FTP Permission Issue:

    It doesn’t seem to affect most of our images. Thanks!

    for the node that has the image that has the problem, can you confirm this alternate path is correct? Also, the exports file is case sensitive, so is the image path setting (in the Web UI) for this storage node.



  • @Wayne-Workman I added these arguments on the NFS node and rebooted. I still get the same message. I’ll be out of the office until Monday. I’ll look at it then. It doesn’t seem to affect most of our images. Thanks!



  • @Joe-Gill The arguments should be left the same, just edit the paths. This only needs done on the nodes that has this alternative images directory.



  • @Wayne-Workman

    Also, are their any specific arguments that I should include for that directory? I noticed both of the entries in my /etc/exports have different arguments…

    Thanks!



  • @Wayne-Workman will this change anything for my other storage nodes? I know this directory is unique to that node.

    Thanks!!



  • @Joe-Gill That’s your problem. Your image task is trying to mount to the server’s /mnt/bhs/images/ directory, but exports only has /images exported. You will need to correct the /etc/exports file to have the correct paths. Reboot your server after changes to this file (there are ways without rebooting but I’m keeping it simple).

    AND

    Edit the /opt/fog/.fogsettings file to include the correct image path so this doesn’t happen again.



  • @Wayne-Workman

    root@Fog:/opt/fog# cat /etc/exports
    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    


  • I don’t think it’s permissions. I think it’s your exports file or firewall.

    What’s this give? cat /etc/exports


 

572
Online

41.9k
Users

12.5k
Topics

117.6k
Posts