FOG Services Crashes - subsequently doesn't join domain



  • Not sure if this is a FOG error or windows error…

    Fog version 8155 SVN 5705 running client version 0.11.2

    We noticed that our clients weren’t rebooting automatically when the fog service/client is supposed to join them to the domain. I would check the services and found that the fog service was stopped.

    Fog log looks good like its going to to join domain and reboot but the service just crashes instead of a reboot. I have even tried to set the service recovery to restart the service every time but no avail.

    Checking the windows event log I see Event ID 7000:: The FOGService service failed to to start due to the following error: The service did not respond the the start or control request in a timely fashion.
    I am running Windows10 - EDU 64bit


  • Moderator

    @MRCUR said in FOG Services Crashes - subsequently doesn't join domain:

    @Joe-Schmitt Do you have the new client that I can test Joe?

    This issue was fixed in 0.11.3.

    Current Client version is 0.11.4, and 0.11.5 will probably be released sometime in the following week (August 2016).


  • Testers

    @Joe-Schmitt Do you have the new client that I can test Joe?


  • Testers

    @gwhitfield I don’t believe the service starts until after a reboot following installation. At least that’s what I was seeing today while testing a reinstall for Joe.



  • @Joe-Schmitt Having same issue on trunk 8415 version client 11.2, happening on Win10 CBB, Win 7 and VMWare machines. Is client 11.3 available that I could try it out? I also have it setupcomplete.cmd but had to add startup task running a bat file containing only “net start FOGService” that delays 90 seconds. This does seem to work if it’s of any help. Just seems to be a timing thing.

    edit: Noticed service isn’t running immediately after installation either, this being on a WIN 10 CBB VM (1511). haven’t tried on physical hardware just yet.


  • Senior Developer

    @MRCUR I have isolated the issue: it is with select machine’s/configuration’s JIT (just in time) compiler. My v0.11.3 nighties patch this issue. PM me when you have a chance and we can make sure the patch works for your machine.


  • Testers

    @Joe-Schmitt I’ve been updating images today and each time have tested after upload to see if domain join would work. Of the three models I’ve been using, two work fine, one does not. The one that does not is the only model with a slow 5400RPM drive (the others have SSD’s). A few months ago these same issues occurred where the client service would crash or fail to start on “slow” computers. The workaround at the time was to add an explicit “net start FOGService” line in the setupcomplete.cmd file. That doesn’t appear to be fixing it anymore with the latest client versions.


  • Testers

    @Joe-Schmitt File exists with a timestamp of 6/26/16 7:25PM. Signed with FOG Project signature.


  • Testers

    @Joe-Schmitt I’ll check the client I was using to test in the morning and let you know.


  • Senior Developer

    @MRCUR That log indicates that either the modules are failing to load or the main service thread is dying prematurely. Can you confirm that the Modules.dll file is present in the fog client program directory. Also right click it, go to properties, and ensure that it shows that it was signed by us under Digital Signature.


  • Testers

    I’m seeing the same issue as @Arsenal101, @Joe-Schmitt. Log entry is below. Computer is Win 10 Ent x64 with client 0.11.2 that was auto updated. This is a sysprep image with the appropriate service commands as in the Wiki.

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     6/30/2016 2:30 PM Client-Info Client Version: 0.11.2
     6/30/2016 2:30 PM Client-Info Client OS:      Windows
     6/30/2016 2:30 PM Client-Info Server Version: 
     6/30/2016 2:30 PM Middleware::Response Success
     6/30/2016 2:30 PM HostnameChanger Checking Hostname
     6/30/2016 2:30 PM HostnameChanger Removing host from active directory
     6/30/2016 2:30 PM HostnameChanger The machine is not currently joined to a domain, code =  2692
     6/30/2016 2:30 PM HostnameChanger Renaming host to PO400-WIN10
     6/30/2016 2:30 PM Power Creating shutdown request
     6/30/2016 2:30 PM Power Parameters: /r /c "FOG needs to rename your computer" /t 0
     6/30/2016 2:30 PM Bus {
      "self": true,
      "channel": "Power",
      "data": "{\r\n  \"action\": \"shuttingdown\"\r\n}"
    }
     6/30/2016 2:30 PM Bus Emmiting message on channel: Power
    ------------------------------------------------------------------------------
    
     6/30/2016 2:33 PM Main Overriding exception handling
     6/30/2016 2:33 PM Main Bootstrapping Zazzles
     6/30/2016 2:33 PM Controller Initialize
     6/30/2016 2:33 PM Entry Creating obj
    

  • Senior Developer



  • @Joe-Schmitt The fog log was on a machine I was imaging at the time, I dont have that machine right now so for the sake of time i’ll upload it in a next post.

    Fresh install (on the reference image) was then bundled up with sysprep and deployed along with the image. I did not see any directions about disabling it when sysprepping. We never had an issue before so I honestly didn’t think to look. I am guessing that’s why everyone is talking about their setupcomplete.cmd files re-enabling it on the first boot. I’ll give that a try.


  • Senior Developer

    Please upload the fog.log. I also need to know if this was a fresh 0.11.2 install ot an auto update. In addition, did you install the client manually on this machine or was it imaged on or deployed with GPO. If imaged on, did you use sysprep. If you used sysprep did you follow the wiki instructions to disable the client while sysprep is running?



  • Also : EventID 7009: A Timeout was reached (30000 milliseconds) while waiting for the FOGservice service to connect


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.