SOLVED FOG 8020 - All Service/Client Modules Disabled and un-enableable on new hosts

  • Testers

    I just created a new host and imaged it. All was well with the world.
    Then I noticed in the fog.log that for every action, the response is “Module is disabled on host”

    So I go take a look at the host and sure enough they are all disabled, but not just disabled, greyed out…

    I’m confused, so I look at another host. I find that the boxes are checked but greyed out. Even though they’re greyed out the host is working properly.

    So I tried to manually disable and enable one of the options in fog setting. It does nothing.
    I tried the select/deselect all button and then updating, nothing.
    So I went to the service settings menu in the gui. It’s a little buggy at the moment. The links seem to work intermittently, and occasionally you get 2 screens, i.e.

    I’m guessing this has to do with the new power management settings, a feature that I am rather excited about.
    This of course happened right when I got 10 new computers 😃

    I suppose I can also add that I added this new host manually in the gui, not via the pxe boot. I did it that way because it’s a intel compute stick with wifi only and I’m using one usb to ethernet adapter to image them all. So I don’t want to register the usb ethernet as the primary mac address for any of them. So this may only be a gui add host issue is my point.

  • This post is deleted!
  • Testers

    @Tom-Elliott Oh that makes sense, so not quite so easy to change. I thought it was just a typo, but that makes more sense that it just pulls the description from elsewhere.

  • @Arrowhead-IT It’s not a dynamic description. It’s a global description.

  • Testers

    Updated to 8022, issue is fixed 😃

    However, I just saw something else related that should probably be changed.

    The wording on all the service configuration options in the global service configuration menu says “…module on this specific host” Shouldn’t that be worded to say that it will enable the option on all hosts or something like that?

  • Testers

    @Wayne-Workman said in FOG 8020 - All Service/Client Modules Disabled and un-enableable on new hosts:

    Definitely a bug. maybe it still works via groups?

    Just tried the group idea, they’re all blank and greyed out there too.

  • Definitely a bug. maybe it still works via groups?

    Last ditch effort would be just set them in the DB manually until the bug is fixed.