DNS Name Goes to Old FOG Installation



  • Hi all,

    I recently upgraded to trunk (as of last week) and I’ve since had a problem when trying to log into fog/management. The problem is, whenever I type in the DNS name - i.e. FOG-Server/fog/management, I’m taken through to a log-in page with 1.2.0 showing in the cloud picture on the left. However, when I type in the IP address: x.x.x.x/fog/management, I get taken through to a log-in page showing the correct version of FOG in the cloud picture.
    I’ve tried flushing the DNS on both the server and my PC to no avail. I’ve also checked the DNS records on the server running DNS and that points to the correct IP address. Has anyone else experienced this issue before? Or does anyone know how I would be able to resolve it?

    Any help with this would be greatly appreciated as always :)



  • @Wayne-Workman That’s solved it! Thanks a lot for your help :)


  • Moderator

    @ITSolutions said in DNS Name Goes to Old FOG Installation:

    Ubuntu moved the default location for web pages in 14.04 from /var/www to /var/www/html. FOG is designed to do a symlink back to /var/www, but maybe something broke in that.

    I think that statement there is what’s going on.

    So, if you use the host name, you are taken to 1.2.0 interface, but if you use the IP you are taken to fog trunk interface.

    This means that the web files for 1.2.0 obviously still exist, and the trunk files are there too.

    If it were me, I’d delete everything in /var/www EXCEPT for the html directory, and I would delete everything INSIDE of /var/www/html and re-run the installer. That should fix it.

    So for instance if you saw some-folder inside /var/www you’d do rm -rf /var/www/some-folder That’s a recursive delete command. same goes for everything in the other.

    You can list the contents of the directory, including hidden files, with ls -la



  • @ITSolutions I upgraded the server from 1.2. I can confirm I’m now running build 7971. However, I’m still experiencing the same issue.


  • Testers

    @RobTitian16 said in DNS Name Goes to Old FOG Installation:

    @ITSolutions Sorry, it’s an old version that was released last week that I’m currently using. I’ll update to the latest and let you know how I get on.
    Did you upgrade the server from 1.2 or did you build a new server and is it the same IP?



  • @ITSolutions Sorry, it’s an old version that was released last week that I’m currently using. I’ll update to the latest and let you know how I get on.


  • Testers

    @RobTitian16 Is this a new install of FOG trunk or an upgrade, I guess I am a little confused re-reading your OP.


  • Testers

    What version of trunk do you have? If it is below 7971 can you try updating? This version was just released.



  • @ITSolutions I can confirm both folders are there and there is a symlink between the two.


  • Testers

    @RobTitian16 said in DNS Name Goes to Old FOG Installation:

    @ITSolutions Ubuntu 14.04… Perhaps it’s time to upgrade?

    No definitely don’t upgrade Ubuntu broke a lot of things in 16.04, so 14.04 is a better choice for now. Ubuntu moved the default location for web pages in 14.04 from /var/www to /var/www/html. FOG is designed to do a symlink back to /var/www, but maybe something broke in that. Can you check to see if there is a /var/www/fog folder and a symlink /var/www/html/fog?



  • @ITSolutions Ubuntu 14.04… Perhaps it’s time to upgrade?


  • Testers

    @RobTitian16 Something that I forgot to ask is what OS is FOG running on?



  • @ITSolutions I’ve tried with IE and Edge. I’ll have to download Firefox if you think it’s worth trying on there as well. I still get the same issue. It’s as if 10.1.0.102 goes directly to the right log-in page, whilst the fog-server/fog/management/ goes to an old database or something… like a remnant of the upgrade.

    Another thing to note (which is also a bit of an issue but I’m not too bothered about it) is that I edited the Apache settings before upgrading to trunk so that fog-server/ would go directly to the fog-server/fog/management/ page. Since updating to trunk, that’s stopped working.


  • Testers

    @RobTitian16 said in DNS Name Goes to Old FOG Installation:

    Windows 10 Pro with Google Chrome. I’ve already attempted to clear my browser history, cookies, etc. to no avail.
    The server is Windows 2008 R2.
    I do get the correct IP when I ping Fog-server.

    Another thing to note is that when I go to the ‘wrong’ login page, I can’t login using any of my credentials. It keeps saying username/password is incorrect.

    Can you try with IE or Firefox? I have had issues with Chrome using some hidden DNS stuff or something. Not sure how chrome handles DNS, but I had a case that in a school I worked at DNS was having an issue and user couldn’t get to a testing site, but in chrome they had no issue.



  • @ITSolutions Windows 10 Pro with Google Chrome. I’ve already attempted to clear my browser history, cookies, etc. to no avail.
    The server is Windows 2008 R2.
    I do get the correct IP when I ping Fog-server.

    Another thing to note is that when I go to the ‘wrong’ login page, I can’t login using any of my credentials. It keeps saying username/password is incorrect.



  • @Wolfbane8653 Yes - Fog-Server points to 10.1.0.102.



  • This post is deleted!

  • Developer

    Did you create an A Record pointer on your DNS Server to point FOG-SERVER to IP xxx.xxx.xxx.xxx.?


  • Testers

    What OS are you going to the login page from and what browser? What kind of server are you using for DNS? If you ping fog-server does it return the correct IP?

    This isn’t a FOG problem, it is definitely a DNS issue.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.