Snap-in MSI with multiple files



  • OK, so after listening to the Q&A video for the second go around, looking for details I may missed I came across the part where Michael was talking about the Smart Notebook software used in all his schools on teacher computers. As we use this software as well I thought of a way he could use the snap-ins to do the single installs her does that the images don’t cover.

    First off I assume he uses the Smart Install Manager to create an MST to automate the MSI install. (we do) However, this means that the MSI and MST needs to be in the same directory.

    Looking at the Snap-in pane, I choose the MSI template. and it fills in most of the information needed. Here is the kicker though. When going to add the file, it seems snapins only allow for one file upload per snapin. However, the MSI and MST needs to be uploaded, and then part of the argument needs to call that MST so the MSI installs with the custom settings.

    I know I am on the right track. (for me as well as hopefully, Michael)

    So I am thinking there are three ways to accomplish this…

    1. use the snapin if it is capable of such an install (multiple file upload)
    2. snapin script to copy the files to the local machine, then run the MSI, and call the MST
    3. have the files on a network share, then use a snapin to script run the MSI from the network share. and calling the MST

    the command to run the installer is this:

    msiexec /i “[Path]\SMARTEducationSoftware.msi” TRANSFORMS="[MST file]"

    Anyone have other ideas, or am I covering it in here? Would also like to know about the multiple file upload for snapins.

    Thanks.


  • Moderator

    Personally, I install smart notebook on every image. Then I leave a copy of the installer on the C:\ drive for actual smartboards. We just run the installer and choose “Smartboard Drivers” so it works with the smartboard.


  • Testers

    @adukes40 I haven’t watched the Q&A yet, but when I saw Smart Notebook in the post, I wanted to share the way I incorporate it into an image. I haven’t experimented with doing a snapin (though since updates for Smart Notebook are regular it would make sense), rather, I install it within an image. Once I deploy this Smart Notebook image, it tells me the license is expired, but with a couple of clicks (manage license>repair license online automatically) it’s good. I guess if you have many different images that need Smart Notebook, the snapin method would be best, but on a universal image (we have a generic smartboard image), I feel like it may be simpler to use my method and update it then re-upload as needed for new versions. We do it that way periodically for not only Smart updates, but other applications and windows updates. I can post screens on Tuesday of the simple license repair for Smart Notebook embedded images if anybody is interested.

    I digress, this may have already been discussed and this thread is about a more in general snapin question, so I apologize for getting off topic.


  • Moderator

    I added the samba stuff to the wiki here, made some fog-specific changes so it’s “ours” and “belonging” and all that good stuff. :-)
    https://wiki.fogproject.org/wiki/index.php?title=Password_Protected_Samba_Share


  • Moderator

    @Mentaloid The key to the left of the 1 key seems to be doing it. I don’t know what to say about it. It’s a NodeBB issue for sure. Seems we need better escaping.



  • @Wayne-Workman

    Tilde? like ~ chars? or the backticks like `?

    My experiment seem to show using things like
    param (
    [string]$url = “.”
    [string]$exec = “”
    )
    is messed up as well (Wayne, not the missing line and square brackets if you edit directly)


  • Moderator

    @Mentaloid I tried messing with it for a while, it’s the tilde characters messing it up. :-\

    You can create a .txt file and upload that if you want.

    @Developers this would be a good example of a “forums issues”.



  • @Wayne-Workman
    There’s a ton of missing code in the first code block, and strings seem to be substituted in several places. If I edit the post, it all seems right in the preview, but the actual post is messed up.

    it seems it’s not restricted to code blocks either - I just tried quoting here. I’ll send you a file if I can as an example of what’s messed up?


  • Moderator

    @Mentaloid I can see the deleted post. It looks fine to me. What’s wrong, exactly?



  • Well - I did have some stuff to add to this, but whatever forum software this is doesn’t seem to like code blocks with powershell with param or typecasting in it :(



  • This post is deleted!

  • Moderator

    I could cover how to make a samba share…

    on CentOS 7 and Fedora, the process is identical, just depending on how much security you want.

    yum install samba samba-client -y (or dnf for fedora 22 and newer).

    Start samba:
    systemctl start smb (status and restart also available).

    Make your share:
    mkdir /smallshare

    make a user for it:

    useradd smalluser
    passwd smalluser

    Set samba password for the user “small user”:

    smbpasswd -a smalluser

    Set permissions on the local directory:
    chown smalluser:smalluser /smallshare
    chmod 770 /smallshare

    Setup the samba configuration script:
    vi /etc/samba/smb.conf

    Things above [smallshare] are global and apply to all shares. Then below each bracket name, is settings specific to the share.

    security = user
    passdb backend = tdbsam
    unix charset = utf-8
    dos charset = cp932
    
    [smallshare]
    path = /smallshare
    read only = no
    create mode = 0777
    directory mode = 0777
    writable = yes
    valid users = smalluser
    

    Then restart samba:
    systemctl restart smb

    And you’re done.

    Of course you can get a lot more advanced, but this is just a basic password protected share.

    #wiki worthy


Log in to reply
 

531
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.