FOG 0.32 problems with HP 840 G3



  • Hi,

    We have a 0.32 FOG setup on Ubuntu 12.04.4 LTS, which has worked fine up until we got this HP 840 G3.
    Upgrading the FOG server to latest version isn’t really possible right now.

    The ethernet adapter the laptop uses is:
    Intel® Ethernet Connection I219-V 10/100/1000 Ethernet

    The issue I’m having is with registering a new host, i get the error “ioctl 0x304 failed: Inappropriate ioctl for device” before I’m able to type in a computer name.
    If i add the machine manually and start a Deploy task, it gets stuck at “Checking queue”

    I have disabled secure boot and enable legacy boot in the BIOS. The laptop also has the latest BIOS version.

    I have tried to compile a custom kernel (using this guide https://wiki.fogproject.org/wiki/index.php/Build_TomElliott_Kernel) with 4.5.1 kernel, even copy the bzImage from a server running the latest FOG version with out any change.

    Seems the issue is similar to this, just on a new version of FOG: https://forums.fogproject.org/topic/6747/unable-to-register-and-inventory-new-dell-pcs

    Any help would be appreciated!


  • Developer

    @Sam-Wennerlund for what it’s worth, i’m running the latest trunk on Ubuntu 12.04.5 LTS. it works fine.



  • After a bit more testing it turns out i could’t image older laptops either, but desktops work.
    So i put the old kernel back that i started with. Same issue.

    Rebooted the FOG server, and it works.

    Seems i should listen to my own advice more often, if all else fails reboot!

    Upgrading to latest version will probably take place when we start with Windows 10, hopefully not to long in the future! :)


  • Moderator

    @Sam-Wennerlund said in FOG 0.32 problems with HP 840 G3:

    Part of the reason we can’t upgrade that server now it will be a big process, we have around 1300 computers and 6 Storage Nodes connected to it now.

    Upgrading fog is not a hassle. The challenge comes into play when you have an old Linux OS that can’t run FOG Trunk. However, that’s not to say you shouldn’t upgrade. FOG is FOSS software, so is Linux.



  • it was already in a mini-switch, tried directly to the network with same errors.

    Forgot to mention i tried a Debug Deploy task, found this: alt text

    if i do a “ifup eth0” i get:
    ifup: ignoring unknown interface eth0


  • Developer

    @Sam-Wennerlund Just a wild idea. Can you try connecting the client with an intermediate mini switch instead of connecting it straight to your network - still using the newer kernel for sure…



  • Unfortunately it’s the same errors with the newest kernel.

    Part of the reason we can’t upgrade that server now it will be a big process, we have around 1300 computers and 6 Storage Nodes connected to it now.


  • Senior Developer

    Of course I want to simply say (Upgrade). Why? 0.32 was not intended for newer hardware. It worked, sometimes, and kernels were a big part of it. Because this isn’t working for you, I suspect (as you do) that it is the kernel and that kernel simply doesn’t have the Network drivers.

    You can try manually installing a newer kernel.

    For 0.32 I think a command such as:

    sudo mv /tftpboot/kernel/bzImage /tftpboot/kernel/bzImage_Original
    sudo wget --no-check-certificate https://fogproject.org/kernels/bzImage32 -O /tftpboot/kernel/bzImage
    

    Would work.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.