Client boots through FOG menu and into windows



  • Working on setting up a standalone network FOG server, running ubuntu 12.04 with FOG 0.32 freshly installed.
    Server side, everything seems fine. Client side on PXE boot, it reaches and establishes connection, shows the FOG menu for about a second and goes directly to windows after it flashes the FOG menu. What can I do to stop the client from skipping the the FOG menu?


  • Moderator

    @Sebastian-Roth Totally different GUI for setting up the partitions - and may have a little bit different experience with installing since it’s as minimal as you can get.

    We can have two though, one for server and one for workstation - since installing and partitioning looks totally different from each other.

    I’ve got a video on partitioning Ubuntu 16 server but I just haven’t gotten around editing it yet.


  • Developer

    @Wayne-Workman Oooops. I saw that you had created the Ubuntu_16.04 article but deleted it again. So I thought I’d just start again. Why Ubuntu_16.04_Server??


  • Moderator


  • Developer

    Just for you guys to know. Turns out that 16.04 definitely is breaking a lot of things. Not only FOG itself but kind of related (namely MySQL!!). I don’t recommend going for Ubuntu Xenial 16.04 yet. I am trying to see if and how we can get around this… Keep watching the forums and this article in the wiki: https://wiki.fogproject.org/wiki/index.php?title=Ubuntu_16.04


  • Testers

    @CDown Everyone has their opinion on the best version. I recommend Ubuntu, for anyone not overly familiar with Linux, it is the easiest to find guides usually for troubleshooting. I would go with 14.04 as it is the latest LTS(not counting 16.04 that just came out, as it changed a lot and could break things).

    I would recommend setting up with 2 HDD or 2 partitions, one for the OS and database and one for the images, this will avoid the accidental mishap of filling the HDD when capturing an image and locking yourself out of the system. I usually will setup a second drive and mount it to the /images folder before installing FOG this will help FOG install everything in the correct spots and not have to walk through moving the images store later on. Not sure of how many images you will have, but were I am right now, we have images for each model with over a dozen models and a 500gb drive is more than enough. Just a good thing to plan ahead on storage. Let me know if you have an questions along the way.



  • @ITSolutions I’ll do a fresh install and see what I can do from there, and I will definitely the trunk of FOG as well. Is there a specific Ubuntu or any Linux OS you would recommend using? Preferably the most reliable, as I am planning to carry this setup into a work environment.


  • Testers

    @CDown That maybe your problem there. As both Ubuntu and FOG have changed so much between the versions in question it is hard to start tot troubleshoot. Especially if this is a new install with no data to worry about I would recommend wiping and starting fresh.

    While you are at it I would also recommend installing the trunk of FOG as it is very stable and is better supported now and in the future. I have been using trunk for nearly a year now and I know many others have been for at least as long. It will also be more compatible with newer hardware as it is released. Not to mention the great new features that have been added to trunk.



  • @ITSolutions I know a complete wipe is always the best option, but I did not do a complete wipe, just an upgrade to 14.04 and 1.2 from older versions.


  • Testers

    @CDown Did you perform an upgrade to 14.04 and install FOG 1.2 over .32 or did you do a complete wipe of the old 12.04/FOG .32 and start fresh?



  • @Wayne-Workman said in Client boots through FOG menu and into windows:

    Why would you freshly install 0.32 ? Sorry but I can’t help you with that version. Please move to 1.2.0 or FOG Trunk preferably since this is a new installation. And use Ubuntu 14 or 15 please, or some other newer distribution.

    We have ample guides to assist you with this in our Wiki.

    After resetting the dhcp server the client does receive the correct DHCP IP , but TFTP times out. “PXE-E32: TFTP open timeout:”


  • Testers

    When you unplug the network cable to move it over to the new network you will need to restart the DHCP service
    sudo service isc-dhcp-server restart

    Or just restart the machine, when you get it moved off the “live” network to it’s segregated network location.



  • @Wayne-Workman said in Client boots through FOG menu and into windows:

    Why would you freshly install 0.32 ? Sorry but I can’t help you with that version. Please move to 1.2.0 or FOG Trunk preferably since this is a new installation. And use Ubuntu 14 or 15 please, or some other newer distribution.

    We have ample guides to assist you with this in our Wiki.

    I was following a youtube guide that used 12.04 and 0.32, was following it as closely as possible to avoid any problems.
    I upgraded ubuntu to 14.04 and FOG to 1.2.0.
    When I boot to the client it does not detect the server at the PXE screen and times out. I installed FOG while connected to the internet, after finishing the install, I plugged the Server box with FOG into a stand alone network switch where I have one client also plugged into it. I did set the static IP through FOG install, and through the UI of ubuntu as manual like the guides on the wiki say. I’m not for sure what I am missing.
    Is there any settings I need to change or add now that I am running FOG 1.2.0?


  • Moderator

    Why would you freshly install 0.32 ? Sorry but I can’t help you with that version. Please move to 1.2.0 or FOG Trunk preferably since this is a new installation. And use Ubuntu 14 or 15 please, or some other newer distribution.

    We have ample guides to assist you with this in our Wiki.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.