r7106 Client Unknown Authentication Error


  • Testers

    I just updated to fix the printer issue and have a new problem now.
    In every client I am seeing an error like this

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     4/7/2016 11:23 AM Client-Info Version: 0.9.12
     4/7/2016 11:23 AM Middleware::Communication URL: http://fog-server/fog/management/other/ssl/srvpublic.crt
     4/7/2016 11:23 AM Data::RSA FOG Server CA cert found
     4/7/2016 11:23 AM Middleware::Authentication Cert OK
     4/7/2016 11:23 AM Middleware::Communication POST URL: http://fog-server/fog/management/index.php?sub=authorize
     4/7/2016 11:23 AM Middleware::Communication Unknown Response: 
     4/7/2016 11:23 AM Service Sleeping for 120 seconds
    

    Specifically 4/7/2016 11:23 AM Middleware::Communication Unknown Response:
    This particular computer is my own. I tried resetting the encryption for the host and now it won’t authenticate.
    I saw the message on another computer that then got all it’s printers but kept getting this error.

    TL;DR
    Unknown response error keeps new hosts from authenticating, but if host was already authenticated the client works with the error posting.


  • Senior Developer

    All fixed and pushed.


  • Testers

    commented out if isset {...} stuff in index.php of management and it worked again.


Log in to reply
 

390
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.