iPXE Error - Nothing to boot: No such file or directory (http://ipxe.org/2d03e13b)

  • Hello FOG Server Professionals,

    I am at a brick wall here, because I have not been able to find a solution to my problem and I thought you guys might be able to help me. I have tried researching the problem via Google, but I cannot find anyone with my same issue and I cannot figure out why this is not working for me.

    Today on 04.01.16:

    1. I have re-installed Kubuntu 12.04 and ran the updates, upgrade, and build-essential.
    2. I have re-installed the latest version of FOG (Free Open-Source Ghost) files using the following video: https://www.youtube.com/watch?v=Si3kMajqXbE
    3. I AM ABLE to access the FOG Server through the web interface by static IP, but I AM NOT ABLE to pull up the quick registration interface when I network boot from another virtual box Win7Test machine and I need to do that to upload the image.

    I originally thought that there was a problem with the 66 and 67 settings, but the Network guy said that the Firewall handles the DHCP settings, so he set it up in the DNS, with my static FOG IP as the hostname and undionly.kpxe as the value.

    However, when I set Virtual Box to do internal network on the FOG Server and VMWin7Test, I get the following error when I try to network boot into the VMWin7Test Machine:
    Connection timed out (http://ipxe.org/4c106035)

    When I try to do Bridged adapter on both of those, and I try to network boot into the VMWin7Test machine I get this error:
    Nothing to boot: No such file or directory (http://ipxe.org/2d03e13b)

    What do you guys suggest/recommend?

    I had thought about doing the dnsmasq DHCP Proxy, but I really don’t think I should have to do that and I would actually prefer not to do that, because I should be able to do it via DHCP.

    Any help would be greatly appreciated.


  • George is right.

    Also - if this DHCP service isn’t run by your company - you can block it totally at the router level and just run your own as well. That’s another option.

  • Senior Developer

  • Moderator

    @upchurchj While its your option to shelve the FOG project, there are options already available to you to get around not being able to make changes to your company dhcp server. You can install the dnsmasq service on your fog server. The dnsmasq service is a DHCP Proxy service. When properly setup the dnsmasq service will provide the missing dhcp boot options without touching your corporate dhcp server.

    I know Wayne can point right to the wiki page, I setup the dnsmasq service during my proof of concept system in my home, where I use a home firewall which doesn’t have the ability to send out dhcp options 66 and 67.


    Just for completeness, you don’t need to pxe boot your target computers, you could use a usb flash drive to start the process. I understand this is not an ideal situation but it will work too.

  • @Wayne-Workman Hey Wayne, thanks for getting back to me so quickly. I went ahead and read through the install instructions for FOG Trunk that you posted. However, my question for installing that is, will I still be running into the same issue as before, what with not being able to set up the DHCP 66/67 settings. I spoke with the company that provides our firewall service, via chat support, and their technician told me that there is currently no way to configure those settings. I suggested creating a DHCP role on our server, in order to alter those settings, but the network guy said that having 2 DHCP’s would cause problems and setting up a separate DHCP for the FOG Server would be too much work. So, with that in mind, I am currently thinking about shelving the FOG Server and moving ahead with another imaging solution, but I would really like to get this to work, provided of course that it is in fact possible, considering my current limitations in this situation. If it is possible to set it up without the 66/67 settings, what advice would you offer me as far as my next steps for getting it to work?

  • @upchurchj said in iPXE Error - Nothing to boot: No such file or directory (http://ipxe.org/2d03e13b):

    If you can point me to a recently updated tutorial on that FOG trunk installation, I would be most interested in taking a stab at it!


  • Senior Developer

    This PCAP file (as well as the one he send me via mail) does NOT have the PXE information (DHCP option 66/67, next-server, filename). Sure the client is not able to PXE boot. Please talk to your network guy!

  • @Sebastian-Roth

    If you can point me to a recently updated tutorial on that FOG trunk installation, I would be most interested in taking a stab at it!

    1.) I have an internal static IP Address. They asked if I needed an internal or an external, but I was not sure, so they gave me an internal one. Do I need an external one?

    Here is that information you requested:

    2.) -rw-r–r-- 1 fog root 102037 Apr 1 13:43 /tftpboot/undionly.kpxe

    3.) I uploaded the display filter, on the pcap file, of “udp.port==67||udp.port==68||tftp” which you will see below:

  • Senior Developer

    Follow Wayne’s answer (newer tutorials and FOG trunk is the future) but for now we can see if we can make this work for you as a testing machine.

    • definitely use Bridged network if your DHCP is external (not on the FOG server) as you described - internal network won’t work!!
    • “No such file or directory” most probably means that the filename configured on the DHCP is incorrect (double check it to be “undionly.kpxe” - all lower case) or the file is missing on the FOG server - check with: ls -al /tftpboot/undionly.kpxe
    • dnsmasq is not needed of DHCP is setup properly by your college!

    Please enable packet capture on the client VM. Try netboot and upload the PCAP file to the forum. This will be the most helpful information you can give!

  • https://forums.fogproject.org/topic/3200/ipxe-boot-error

    Also, that video is very old (published in 2012). You might want to consider using a tutorial from our Wiki, and you might even want to try out FOG Trunk since 1.2.0 is getting pretty dated and this is a fresh and new FOG server build.

    As far as the problem goes, it’s probably still a DHCP issue. FOG doesn’t need a DNS entry to work, but absolutely requires that Option 066 and 067 get to the target hosts somehow.

    Also - if your just looking to test FOG out, you would greatly simplify your troubles by using a physical machine. I don’t know why people keep trying to use Virtual Box. I’ve got nothing against it, but we see a lot of issues every week with Virtual Box and none of those issues would exist with a physical box. It doesn’t need to be anything fancy, an old core 2 duo or Pentium 4 would do just fine as a test box.