Ipxe Could not boot no such file or directory



  • I have a new fog 1.2 install on Ubuntu 14.04 when I PXE boot I get the following error:

    [url]http://ip-address/fog/service/ipxe/boot.php[/url] … No such file or directory

    The file is there tftp and apache are running. I also restarted the tftp service.

    Any ideas?

    Thanks


  • Developer

    no problem



  • Figured it out I modified the document root in the Apache config to point to /var/www/fog. Changed that back to /var/www/html and things started working. Thanks would not have figured it our with out your help.


  • Developer

    i have no idea, sorry. what might work for you is to edit /tftpboot/default.ipxe to have the address without /fog and to make sure your fog settings (in the web gui) have the correct address as well. this will also require editing the config.ini of the fog client for any hosts you have the client on to have the corrected address as well. i can’t guarantee that is all that would need changed.
    absent making all of those changes, the fog web environment needs to be accessible at [url]http://ip-address/fog/[/url] instead of just at [url]http://ip-address/[/url]



  • Any idea why. I am comparing things with my other fog server and they look they same.


  • Developer

    the symlink doesn’t appear to be working properly then. if it was, [url]http://ip-address/fog/service/ipxe/boot.php[/url] and [url]http://ip-address/service/ipxe/boot.php[/url] would have given you the same results



  • The symlink points to the fog direcotry



  • [quote=“Junkhacker, post: 38753, member: 21583”]did the installer automatically put fog in the web root instead of in /fog, or is that something you changed?[/quote]

    The installer put it there it also created a symlink in the /var/www/html directory.


  • Developer

    did the installer automatically put fog in the web root instead of in /fog, or is that something you changed?



  • Nothing comes up in a browser if I go to [URL=‘http://ip-address/fog/service/ipxe/boot.php’][COLOR=#737373]http://ip-address/fog/service/ipxe/boot.php[/COLOR][/URL]. however, if I remove fog form the path the pages loads in a web browser. so [URL=‘http://ip-address/fog/service/ipxe/boot.php’][COLOR=#737373]http://ip-address/service/ipxe/boot.php[/COLOR][/URL] works.


  • Developer

    if you’re seeing ipxe load at all, tftp is working fine.
    does anything come up when you go to [url]http://ip-address/fog/service/ipxe/boot.php[/url] in a web browser?



  • This gets more odd. I have a second fog server at a different location that is working correctly. If I configure things so that clients on this network connect to that fog server they get the same error. I have triple checked my dhcp options and the ip helper address on the switches. That is working because I get ipxe to boot it is tftp that is having the problem.



  • [quote=“ArchFan, post: 38728, member: 19266”]Verify:
    DHCP options 66 and 67 are set to correct ip and filename
    filename should be undionly.kpxe
    ip should be the ip of the FOG server

    Make sure the firewall is disabled
    [CODE]
    sudo ufw disable
    [/CODE]

    Can you download the file from the FOG server to a client using TFTP?[/quote]

    DHCP options are correct firewall is disabled

    Having trouble downloading the file. Not sure if it is the server or if I do not know how to use the tftp command.



  • Verify:
    DHCP options 66 and 67 are set to correct ip and filename
    filename should be undionly.kpxe
    ip should be the ip of the FOG server

    Make sure the firewall is disabled
    [CODE]
    sudo ufw disable
    [/CODE]

    Can you download the file from the FOG server to a client using TFTP?


Log in to reply
 

429
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.