SOLVED SVN 6521 There is nothing to replicate

  • Moderator

    Hi, I decided to install a storage node to work with the FOG Server. I managed to set everything up and the main FOG Server is designated as Master node, but yet the image replication service claims there is nothing to replicate.

    I checked the image settings and all of them have replicate checkbox checked.

    The storage node is in the same group as the main server and is not a master node.

    I could of course copy over the files manually, but I’m worried the system won’t be aware that the node has the files and I’d really like the process to be automoted for future cases anyway.

    Any help would be greatly appreciated as usual 😉

    edit: Here are the logs (repeats every 10 minutes of course)

    [03-02-16 4:05:30 pm] * Starting Image Replication.
    [03-02-16 4:05:30 pm] * We are group ID: #1
    [03-02-16 4:05:30 pm] | We are group name: default
    [03-02-16 4:05:30 pm] * We have node ID: #1
    [03-02-16 4:05:30 pm] | We are node name: DefaultMember
    [03-02-16 4:05:31 pm] * There is nothing to replicate

  • @Quazz I know it’s not a nice bit of info, but this isn’t something I can fix within the code base, unfortunately.

    The “trick” i do to keep the GUI functional is simply not enough. The trick, btw, is basically if the image has no storage group associated, get the first created group (smallest ID in the database) and use that for representation.

    While it works to keep the GUI functional, it simply CANNOT work for replication. I imagine the same feat could be replicated on Snapins.

  • Moderator

    @Tom-Elliott Thanks Tom, that does indeed fix the issue. 👍

  • @Quazz, can you make sure the image you need to replicate is associated to a storage group directly? For example, login to your fog gui, go to images. Choose the image you need to replicate. Click storage groups, even if there’s a storage group applied, save changes. Restart the FOGImageReplicator service. It should start replicating that image.

  • @Wayne-Workman I don’t know if this is related but my Snapin Replicator log is showing

    [03-02-16 11:17:48 am] Interface Ready with IP Address:
    [03-02-16 11:17:48 am] Interface Ready with IP Address:
    [03-02-16 11:17:48 am] Interface Ready with IP Address: fog-server
    [03-02-16 11:17:48 am] * Starting SnapinReplicator Service
    [03-02-16 11:17:48 am] * Checking for new items every 600 seconds
    [03-02-16 11:17:48 am] * Starting service loop
    [03-02-16 11:17:48 am] * Starting Snapin Replication.
    [03-02-16 11:17:48 am] * We are group ID: #1
    [03-02-16 11:17:48 am] | We are group name: Office
    [03-02-16 11:17:48 am] * We have node ID: #1
    [03-02-16 11:17:48 am] | We are node name: Fog-Server
    [03-02-16 11:17:48 am] * Found Snapin to transfer to 4 group(s)
    [03-02-16 11:17:48 am] | Snapin name: HP-SDM
    [03-02-16 11:17:48 am] | Local File: /opt/fog/snapins/HpSDM.bat
    [03-02-16 11:17:48 am] | Remote File: /opt/fog/snapins
    [03-02-16 11:17:48 am] | Local File size: 145
    [03-02-16 11:17:48 am] | Remote File size: 0
    [03-02-16 11:17:48 am] | Files do not match
    [03-02-16 11:17:48 am] * Deleting remote file: /opt/fog/snapins

    it looks like it’s deleting, but not replicating afterwards

  • Moved to bug reports.

  • Moderator

    @Tom-Elliott Yes, it’s enabled. Do you reckon it’s a problem with the master node not knowing about the other node somehow?

    0_1456931453597_storage nodes.PNG

  • Is the storage node Enabled?