Strange registration messages



  • @george1421
    After new test, when I’m run in debug:

    • NIC is on everytimes
    • ifconfig no IP
    • ping no response

    If I run udhcpc -i eth0 or /etc/init.d/S40network stop && sleep 2/etc/init.d/S40network start, everything is working.

    @Tom-Elliott
    Ok, when I run your command, I get an IP :)


  • Senior Developer

    @george1421 I highly doubt the issue he’s seeing here has anything to do with the driver at all.

    My guess to what’s being seen here is the 802.11az issues I have seen. This, also, is my same suspicion to what @Wayne-Workman was seeing with his network and the random ports.

    The fix, for us, is to simply take another switch and connect it.

    802.11az is nice, when the OS is booted and running, and the system sleeps. When it sleeps it disconnects the NIC. Not all nic’s have this type is setup which is also likely why @aruhuno is not seeing this on other models of the system.

    The issue, as I’ve seen it occur, presents itself very slowly. You go to boot a system, sometimes TFTP is fast (usually after a cold boot) and get’s you into iPXE and into the FOS system just fine (albeit with slowed/lack of IP address obtaining). Other times the TFTP pxe process even seems to get hung up, but after 30 - 50 seconds it might get a DHCP anyway (people don’t like such minor delays usually though and FOS definitely doesn’t like it.)

    These are all guess on my part though, because it’s such a few and far between issue, it’s not something easily findable.

    @aruhuno, can you start the tasking in “Debug” mode (Create the tasking like you normally would, but before confirming check the box for “Schedule as debug task”.)

    When the client boots it should drop you into a linux shell prompt. From there, you can try to see if it will pick up an IP address after a small period of time. Just run: /etc/init.d/S40network stop && sleep 2/etc/init.d/S40network start` and it should try to get you an IP address again.


  • Moderator

    @Sebastian-Roth Does the FOS kernel contain the realtek driver that is part of the official linux kernel or does it contain the latest driver from realtek. I’ve seen several recommendations to use the realtek drivers over the linux kernel drivers.

    aruhuno, just so I understand this. You booted into debug mode and the FOS kernel did not pick up an ip address and the link light stayed off. You executed the udhcpc command (only) and the interface came up and it picked up an IP address. If this was an spanning tree issue, I think we would see the issue sooner in the booting process, since each time (during pxe booting) the transition between kernels happens the network adapter should be reset and the link dropped.

    If you watch the link light during the entire target device booting, the link light should momentarily shut off during PXE rom -> iPXE kernel startup and then when the FOS kernel starts.



  • Test with last lubuntu LTS: NIC recognized and works at boot.

    • kernel version is 3.13.0-24
    • lsmod | grep real return only snd realtek, no additionnal module is used for this NIC


  • @Sebastian-Roth: I have found that once the prompt , the network card is active. I have of course no IP , but it is already very good. The startup script not that be the problem? An IP request too early or something like that, right?

    I will try to start a 14.04.4 Lubuntu to see if the NIC is recognized or not.


  • Developer

    Those RTL8168/8169/8111 are making me nuts. Seen a similar behavior with one of these NICs but that was with FOG 1.2.0 where the network startup scripts were very different. The current FOG trunk network init scripts should actually bring the interface UP and wait till it’s up. I don’t understand what’s going on with those NICs. They tend to stay down…



  • @george1421: Ok, thanks!

    @Sebastian-Roth: When I show “Starting eth0”, NIC LED is off and never did become on!

    Now, result of your commands:
    cli

    After udhcpc -i eth0

    • NIC LED is on
    • have an IP
    • ping works

  • Moderator

    @Sebastian-Roth For sure you are right. If the kernel didn’t have the driver built in, there would be no eth0 adapter. The only thing I can think of is that the kernel has a driver close to the network adapter and was able to init the nic but still can’t talk. I remember something about some network boards required two drivers. One for the nic and one for the interface (name MII comes to mind for the interface).

    But I again would agree the OP should watch the link lights on this device to see if the link is being set after the FOS kernel already tried the network interface. If the link lights are on and the udhcpc command doesn’t pickup and IP address, we will have to dig deeper.


  • Developer

    @george1421 said:

    Isn’t there a lsmod command or something that should show if the realtek driver is loaded into memory?

    We have all the drivers compiled directly into the kernel. So you won’t see it with lsmod But I am sure it is properly recognized by the driver as we won’t see eth0 if not!!

    @aruhuno Please keep an eye on the NIC LEDs while booting up. Are they on or off while you see the “udhcpc … Sending discovery…”?? As well try debug mode again, wait for half a minute or so (check NIC LEDs) and try requesting an IP then udhcpc -i eth0

    As well, please show us the output of dmesg | grep r8169


  • Moderator

    @aruhuno This is great!! Nice details While I think I know the answer, but just to verify, on the target device is the link light on when you took this picture. From the picture it appears that eth0 is not picking up an ip address (what I suspected).

    Sebastian: Isn’t there a lsmod command or something that should show if the realtek driver is loaded into memory?



  • @Sebastian-Roth & @george1421:
    command response

    @Sebastian-Roth: The switches are configured correctly :)


  • Developer

    @aruhuno As well please run lspci -nn | grep Ethernet while you are in debug mode. Please take a picture of the commands and outputs on screen and upload it to the forum. Would be very helpful.

    We actually see the NIC being recognized (message “Starting eth0 interface” on the first picture). So it seams like it cannot get an IP via DHCP. Maybe it’s a spanning tree issue?


  • Moderator

    Ok then, do you know how to do a debug capture/deploy debug?

    Manually register the device with FOG.
    Then select either capture or deploy (which one is not that important now).
    Before you create the task make sure you select “Schedule this task as debug task”. Then submit the task.
    PXE boot that E73 again and the FOS kernel should start. You will see a bunch of commands displayed on the screen, at the end press enter and you should be dropped into a linux command shell. From there we need to check to see if the network adapter is working. you can do this by issuing the command ip addr show It should list the network adapters the FOS kernel has discovered.



  • @george1421 Yes, of course.


  • Moderator

    Did you fix the missing slash ‘/’ in the file path? You are not the first person to report this slash missing.



  • I spoke too soon , it does not work on the ThinkCentre with the same message…



  • @Tom-Elliott This is not a credential issue but directory…

    Bad value during install ?

    /var/www/fogservice/ipxe/
    

    Instead of:

    /var/www/fog/service/ipxe/
    

    Kernel is downgraded at 3.19.3 and everything works!

    I just want to clarify that whatever the machine used (Optiplex or ThinkCentre), the first screenshot remains true.


  • Senior Developer

    I guess I’m not understanding how this is a BUG?

    Also,

    Have you ensured the FOG FTP Credentials are correct? The credentials you need for kernel updating is located in:

    FOG Configuration Page->FOG Settings->TFTP Server->FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD



  • @Tom-Elliott

    Kernel version

    bzImage Version: 4.4.3
    bzImage32 Version: 4.4.3
    

    When I want to downgrade, I’ve the following message:

    Error: Failed to install new kernel
    

    On FOG 1.2.0 I had version 3.19.3.


  • Senior Developer

    If it were me, I’d start by seeing when the issue occurred/occurs.

    What kernel version are you using to boot the clients? (FOG Configuration Page-> Storage Node name should show bzImage and bzImage32 kernel versions.)

    Can you try downgrading the kernel version? Try 3.19 series and maybe 4.0 thru 4.3?


 

492
Online

8.5k
Users

12.5k
Topics

117.8k
Posts