Windows 10 Black Screen



  • I have seen this similar issue reported, but haven’t seen a fix.

    I can capture my Windows 10 image just fine, but when I deploy the image, all I get on the target computer is a blank black screen.

    I am running Ubuntu Server 14.04.3 LTS
    Fog Trunk SVN 6211

    Capture PC is Lenovo E555
    Target PC is Lenovo E555

    Please advise.

    I built the image using these settings:
    0_1454704734736_Capture2.PNG



  • This post is deleted!


  • @MRCUR said:

    KMS would be easiest for both Windows and Office.

    If you have a KMS server setup for MS Office, and if you have the KMS version of Office installed on your image. :-)

    We use a Windows KMS here for MS Office.


  • Testers

    @Wayne-Workman @Vanlue-IT-Guy KMS would be easiest for both Windows and Office. Then everything will activate on its own and you don’t have to worry about it through FOG or any other method. Office 2016 is very good about quickly and silently using KMS (Office 2013 sometimes took a considerable amount of time to do it in the background, often times alerting the user a few times along the way).



  • @Vanlue-IT-Guy said:

    My “problem” is Office. It retains the key, but still needs manually activated on the target computer.

    You can do it with a startup script via group policy, or a login script.

    I suppose it’d be possible to do it with a snapin, too.



  • @Wayne-Workman Wayne,

    Thanks for the quick reply. I think I have Windows activating ok. My “problem” is Office. It retains the key, but still needs manually activated on the target computer.



  • @Vanlue-IT-Guy said:

    Now I’m on to activating Windows and Office.

    The new client activates windows just fine. It’ll even use the product key you assign to an individual host via web management.



  • @Tom-Elliott
    Tom,

    I updated fog and found out while I was using two identical laptops, the BIOS versions were different. Once I updated to the same BIOS version, everything works! Now I’m on to activating Windows and Office. Do you have any suggestions or easy steps for this?


  • Senior Developer

    @Vanlue-IT-Guy Sorry,

    SVN is updated all the time man.

    The way to update what you have, cd to the trunk location.

    If you put your install in /opt/svn/trunk you’d do these steps:

    cd /opt/svn/trunk
    svn up
    cd bin
    ./installfog.sh -y
    

    You must always do the up from the root of the trunk folder (not within bin or packages as it only updates up the tree, not down).



  • @Tom-Elliott Tom, I would be happy to, but I just got it from SVN this morning. Is there a newer version already?

    How can I check quickly?


  • Senior Developer

    Can you please update?

    The init’s had a bit where the osid wasn’t being passed and this has since been fixed, as well as a few other issues.



  • Wayne,

    I don’t mean to seem dense, but I don’t think this is related to my issue at all.

    I don’t get any visible error output, I am using Legacy instead of UEFI, I’m not using a USB to Ethernet adapter and I’m not having a PXE issue.

    The process seems to work fine until it tries to boot into Windows. After seeing the Fog screen all I get is a blank black screen.
    No login, no error messages, nothing.

    I have tried also uploading my image as a Windows 10 Multi-Partion Single-Disk (not resizable) which works fine again on the capture, but gives me an error during deployment saying no osid passed.
    0_1454707208670_IMG_1543.JPG
    I tried this as it has worked in the past.



  • Below is a post from:
    https://forums.fogproject.org/topic/6525/pxe-boot-hp-x2-210-hybrid-tablet-windows-10-pro/109

    @Tom-Elliott said:

    While trying to figure this out, I noticed my screens had a ton more info that most others. Thinking it was just differences in the loglevel fields, I decided to test it by setting my loglevel to 0. When I did this the value was blank in db and to browser there was a MORE messages than with loglevel set to 4. I fixed this issue as I want to always have a value defined, and in doing so it actually gave the proper value.

    Why here do I write this? Because with a loglevel=0 set, it doesn’t return ANYTHING to the screen.

    Can you update the loglevel setting on your server to the highest value? Maybe we’ll actually see info.

    It sound a lot like your issue.


 

621
Online

5.4k
Users

12.6k
Topics

118.9k
Posts