SOLVED No network interfaces found (verifyNetworkConnection)

  • I’m on r6211.
    Host is in BIOS mode, it’s a Lenovo L530.
    FOG Server is running Fedora 23
    DHCP is a Windows 2012 R1 server.


  • I know you said @Tom-Elliott that this post is old and that @thyago should start a new thread.
    I just had the same problem and what worked for me was to have both network cards connected to the switch. (Computer was Dell R5500).

  • @thyago did you check your patch cable? Are you sure it’s working properly? Have you read through the whole post to try other things as suggested to see if it helps your situation.

    The solution for the problem was replacing a patch cable, for this instance. We have no idea about yours. As this thread was 2 years old I’d recommend starting a new thread giving us the details of the problem and things you’ve already tried.

  • @wayne-workman I’m having the same problem. Did you find a solution?

  • Moderator

    @Wayne-Workman Thanks a lot for letting us know!!

  • Ok…

    I’m feeling pretty ignorant at the moment.

    I got to messing with this again and was able to try out a new unmanaged 1Gbps Cisco switch with it and I went through several different configurations in my tests and kept getting inconsistent results.

    I have finally found out what the issue was. It was a bad patch cable the whole time.

    That’s pretty shameful on my part as a technician, but it would be more shameful to conceal my mistake and not report what the issue was.

    I do believe I exhausted every single other possible option before I realized it was the patch cable. Checking simple things first is hammered into all of us as troubleshooters, and the lesson has definitely been reinforced in me.

  • Network team says that “spanning-tree portfast” is set on all client ports in the building.

  • I’ve disabled all power saving features in Firmware - still no luck.

  • I just updated an Optiplex 7010 from A12 to A21.

    Early results don’t look any different.

  • @loosus456 That does help. I’ll update the firmware and see if it has any effect.

  • I know this isn’t going to help, but I had 18 OptiPlex 7010s in a lab, and several had this issue. I noticed that the ones that had the issue had a different BIOS version from the others. After updating the BIOS, the issue was resolved in this case.

    In another lab with 7010s, I had the same issue with a couple of machines, but it was unrelated to the BIOS version. Instead, the network connection just wasn’t “good enough” for FOG to see for some reason. In Windows, these machines could connect, but FOG just wasn’t having it for some reason. We replaced the patch cable at the the switch, and it resolved the issue. I figured that if Windows thought the connection was acceptable that FOG would, too, but that is most definitely not the case at all.

  • @Tom-Elliott Can you elaborate (further) ?

  • @george1421 I’ve actually seen this exact issue with our systems as well. Not very often, and the fix is indeed to put a managed switch between. Or, alter the firmware on windows to now put the nic into a “Power-saving” mode.

    The latter is not a simple thing and is only good for that instance of the OS, if your image doesn’t have those firmware changes in place, they will not hold.

  • Moderator

    @Wayne-Workman I agree that something is not configured correctly on the building switch. By putting an unmanaged switch in between it fixes (masks) the issue. Because the building switch is never seeing the port drop as the target computer transitions between phases during booting.

  • Testers

    @Wayne-Workman I would ask for verification that “spanning-tree bpdufilter enable” is set for the port OR that “spanning-tree portfast (int num) enable” is set.

  • More info on this.

    I removed the mini-switch from the equation, and tried to image the computer.

    It wouldn’t even get a DHCP lease, but the NIC lights did turn on after a long while… then it failed. PXE-M0F.

    Turned it off, turned it back on.

    It got DHCP proper, but then got the OP error.

    Turned it off, turned it back on.

    Same thing, OP error.

    I put the switch between the computer and the building network again, imaging works perfectly.

  • @george1421 said:

    As you were getting setup to video, did you restart the switch or plug the wiring going to the building at all?

    I don’t think I did, I think I just moved the switch to be on top of the computer. And of course I held the power button on the computer until it turned off.

    I’ll repeat this tomorrow and see if it’s repeatable.

  • @george1421 They are all catalyst switches - varying models but none are over maybe 4 or 5 years old (yay free government money).

  • Moderator

    If you have to register (with some kind of network controller) new out of the box computers before you can use them then you have a NAC/NAP (different name same function) that manages access for your network. Since you don’t know the name you probably don’t have this.

    When you say you have cisco throughout. Is that real cisco switches (catalyst series) or cisco small business switches (SG series)? The reason why I ask, is the SG series has a nasty feature that is turned on by default called smart port. That feature will try to determine what device is connected to the port then assign the device to the predefined vlan. This “feature” listens for the connected device to announce what it is. This listening phase is several seconds, much like stp learning phase. I’m not a cisco person, so I don’t know if the catalyst series has this same function. But this smart port has caused me pain several times in that with it on, any vlan I set of a port will get overwritten with the smart port setting.

  • Moderator

    Hopefully they have an idea what NAC is: