Installing new install of cloud 5786 setting up storage failed


  • Moderator

    I’m working on a new install of the fog trunk on a new Centos 7 install. This is direct install of the current trunk build.

    The install runs normally until it gets to setting up the storage and it fails

    * Setting up storage..........................................Failed!
    

    Now the one thing I DID do differently this time is to give the installer a different path for the images folder.

    What is the storage location for your images directory? (/images) /opt/fog/images
    

    I see that even though I told it to use the /opt/fog/images directory, it created the /images directory anyway. I’m not sure if this is the cause of the storage setup failure or not. In this build I created the /opt directory on its own partition and want to place all of the fog files in that location.


  • Senior Developer

    I’m fairly sure this has been addressed and fixed, though please let me know if I’m wrong.


  • Testers

    Confirming this same issue with build 5790 on Ubuntu 14.04. Fails the first time through, works fine the second time.


  • Moderator

    I have more to add to this. I did a clean install of fog this AM and it again failed at setting up storage. I selected all default settings and no monkey business with the files location and it still failed. After checking to ensure I didn’t do anything I reran the installer again with the same default values and it installed correctly.

    Additionally I discovered an issue that the ftp (OS) account was setup with the correct password (as indicated by the install script), the FOG_TFTP_FTP_PASSWORD value was set to the password given to the ftp user on the first install attempt not the second.


  • Moderator

    FWIW, if I leave the default storage location to /images the installer runs OK to completion.


Log in to reply
 

388
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.