SOLVED ChromiumOS r48 - EliteBook 8730w

  • svn 4405 cloud 5469 Fedora 21 Server fully updated.

    I’ve successfully installed ChromiumOS r48 onto an Elitebook, everything works except for the fingerprint scanner… pretty sweet.

    But I can’t take an image. I set the “Operating System” type to “Linux”. I’ve tried non-resizable and resizable. Neither finish. Videos are below.

    I booted a Ubuntu Live USB drive to get some information on the partitions that the ChromiumOS installer created on the drive. Here is that info, BEFORE the upload attempts (fresh OS install).

    fdisk -l

    Disk /dev/loop0: 1 GiB, 1101672448 bytes, 2151704 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk /dev/sda: 149.1 GiB, 160041885696 bytes, 312581808 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 21C29483-E2A3-1846-9D54-9F893C880647
    Device       Start       End   Sectors   Size Type
    /dev/sda1  8671232 312545279 303874048 144.9G Microsoft basic data
    /dev/sda2    20480     53247     32768    16M ChromeOS kernel
    /dev/sda3  4476928   8671231   4194304     2G ChromeOS root fs
    /dev/sda4    53248     86015     32768    16M ChromeOS kernel
    /dev/sda5   282624   4476927   4194304     2G ChromeOS root fs
    /dev/sda6    16448     16448         1   512B ChromeOS kernel
    /dev/sda7    16449     16449         1   512B ChromeOS root fs
    /dev/sda8    86016    118783     32768    16M Microsoft basic data
    /dev/sda9    16450     16450         1   512B ChromeOS reserved
    /dev/sda10   16451     16451         1   512B ChromeOS reserved
    /dev/sda11      64     16447     16384     8M unknown
    /dev/sda12  249856    282623     32768    16M EFI System
    Partition table entries are not in disk order.
    Disk /dev/sdb: 3.7 GiB, 4007264256 bytes, 7826688 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x6bc887e5
    Device     Boot Start     End Sectors  Size Id Type
    /dev/sdb1  *       63 7823654 7823592  3.7G  c W95 FAT32 (LBA)

    sfdisk -l -uM

    sfdisk: Disk /dev/loop0: cannot get geometry
    Disk /dev/loop0: 133 cylinders, 255 heads, 63 sectors/track
    Disk /dev/sda: 19457 cylinders, 255 heads, 63 sectors/track
    sfdisk: Warning: The partition table looks like it was made
      for C/H/S=*/256/63 (instead of 19457/255/63).
    For this listing I'll assume that geometry.
    Units: 1MiB = 1024*1024 bytes, blocks of 1024 bytes, counting from 0
       Device Boot Start   End    MiB    #blocks   Id  System
    /dev/sda1         0+ 152627- 152628- 156290903+  ee  GPT
    /dev/sda2         0      -      0          0    0  Empty
    /dev/sda3         0      -      0          0    0  Empty
    /dev/sda4         0      -      0          0    0  Empty
    Disk /dev/sdb: 487 cylinders, 255 heads, 63 sectors/track
    Units: 1MiB = 1024*1024 bytes, blocks of 1024 bytes, counting from 0
       Device Boot Start   End    MiB    #blocks   Id  System
    /dev/sdb1   *     0+  3820-  3821-   3911796    c  W95 FAT32 (LBA)
    /dev/sdb2         0      -      0          0    0  Empty
    /dev/sdb3         0      -      0          0    0  Empty
    /dev/sdb4         0      -      0          0    0  Empty

    parted -l

    Model: ATA TOSHIBA MK1656GS (scsi)
    Disk /dev/sda: 160GB
    Sector size (logical/physical): 512B/512B
    Partition Table: gpt
    Disk Flags: 
    Number  Start   End     Size    File system  Name        Flags
    11      32.8kB  8421kB  8389kB               RWFW
     6      8421kB  8422kB  512B                 KERN-C
     7      8422kB  8422kB  512B                 ROOT-C
     9      8422kB  8423kB  512B                 reserved
    10      8423kB  8423kB  512B                 reserved
     2      10.5MB  27.3MB  16.8MB               KERN-A
     4      27.3MB  44.0MB  16.8MB               KERN-B
     8      44.0MB  60.8MB  16.8MB  ext4         OEM         msftdata
    12      128MB   145MB   16.8MB  fat16        EFI-SYSTEM  boot, esp
     5      145MB   2292MB  2147MB  ext2         ROOT-B
     3      2292MB  4440MB  2147MB  ext2         ROOT-A
     1      4440MB  160GB   156GB   ext4         STATE       msftdata
    Model: USB 2.0 USB Flash Drive (scsi)
    Disk /dev/sdb: 4007MB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos
    Disk Flags: 
    Number  Start   End     Size    Type     File system  Flags
     1      32.3kB  4006MB  4006MB  primary  fat32        boot, lba

    df -h

    Filesystem      Size  Used Avail Use% Mounted on
    udev            1.9G     0  1.9G   0% /dev
    tmpfs           386M   11M  375M   3% /run
    /dev/sdb1       3.8G  3.0G  823M  79% /cdrom
    /dev/loop0      1.1G  1.1G     0 100% /rofs
    /cow            1.9G   27M  1.9G   2% /
    tmpfs           1.9G   80K  1.9G   1% /dev/shm
    tmpfs           5.0M  4.0K  5.0M   1% /run/lock
    tmpfs           1.9G     0  1.9G   0% /sys/fs/cgroup
    tmpfs           1.9G  1.1M  1.9G   1% /tmp
    cgmfs           100K     0  100K   0% /run/cgmanager/fs
    tmpfs           386M   76K  386M   1% /run/user/999


    sda       8:0    0 149.1G  0 disk 
    ├─sda1    8:1    0 144.9G  0 part 
    ├─sda2    8:2    0    16M  0 part 
    ├─sda3    8:3    0     2G  0 part 
    ├─sda4    8:4    0    16M  0 part 
    ├─sda5    8:5    0     2G  0 part 
    ├─sda6    8:6    0   512B  0 part 
    ├─sda7    8:7    0   512B  0 part 
    ├─sda8    8:8    0    16M  0 part 
    ├─sda9    8:9    0   512B  0 part 
    ├─sda10   8:10   0   512B  0 part 
    ├─sda11   8:11   0     8M  0 part 
    └─sda12   8:12   0    16M  0 part 
    sdb       8:16   1   3.7G  0 disk 
    └─sdb1    8:17   1   3.7G  0 part /cdrom
    sr0      11:0    1  1024M  0 rom  
    loop0     7:0    0     1G  1 loop /rofs


    /dev/sda1: LABEL="H-STATE" UUID="caf8356b-966d-4eb5-b8e6-1aa42c16a451" TYPE="ext4" PARTLABEL="STATE" PARTUUID="f3cc57aa-6618-db41-9dcf-1e58ea543419"
    /dev/sda12: SEC_TYPE="msdos" LABEL="EFI-SYSTEM" UUID="611B-13B9" TYPE="vfat" PARTLABEL="EFI-SYSTEM" PARTUUID="8fadaf09-4410-d648-ad2c-f83cc23c9f12"
    /dev/sda5: LABEL="ROOT-A" TYPE="ext2" PARTLABEL="ROOT-B" PARTUUID="5e33d60f-d6f4-9547-a1ae-9bf249f4a2de"
    /dev/sda8: LABEL="OEM" UUID="45ff89d3-1c24-45d7-85af-7141af55c9cc" TYPE="ext4" PARTLABEL="OEM" PARTUUID="0068d7b9-9143-794a-83c2-fa0416fc8c99"
    /dev/sdb1: LABEL="MULTIBOOT" UUID="0F0C-145E" TYPE="vfat" PARTUUID="6bc887e5-01"
    /dev/loop0: TYPE="squashfs"
    /dev/sda2: PARTLABEL="KERN-A" PARTUUID="2c14a430-2b92-ad4d-96ab-00138d90c71d"
    /dev/sda3: LABEL="ROOT-A" TYPE="ext2" PARTLABEL="ROOT-A" PARTUUID="12dd8be6-24b7-bc4c-b148-e1bd0b8164bd"
    /dev/sda4: PARTLABEL="KERN-B" PARTUUID="ca32d7ee-8bf9-c347-a1b2-c9cdc41b6f66"
    /dev/sda11: PARTLABEL="RWFW" PARTUUID="ac3cc1a7-a2b4-014e-a22c-4353e15d1a06"

    Multiple Partition Image - Single Disk - Not Resizable - Capture attempt:

    Single Disk - Resizable - Capture Attempt (error is at the very end):

    With the above attempt, I noticed that all the partitions did upload. All the files were sitting in /images/dev/<MAC> So I moved that to the proper directory name underneath /images/EliteBookChromium48 and then tried to deploy the image back to the host.

    Resizable image deploy attempt:

    Any help with this is appreciated… not sure where to go from here.

  • For those that are wondering, here are my brief instructions for installing ChromiumOS onto the Elitebook.

    Arnold The Bat - latest special build (x86 or x64)

    Burn to flash drive or hdd per his instructions:

    Extract with p7zip
    burn to drive using:
    dd if=ChromeOS.img of=/dev/sdX bs=4M

    extract using 7zip
    burn to drive using


    Go into chros shell with:
    Ctrl + Alt + F2

    Username is chronos
    password is password

    Install OS:

    /usr/sbin/./chromeos-install --dst /dev/sda

  • Right now I’m running FOG Trunk on Fedora 21 Server minimal with r6303 installed.

    I just tried uploading ChromiumOS Revision 50 from an EliteBook 8730w

    I can say with 100% certainty that Fog worked 100%.

    Revision 50 has 12 partitions, 3 of which qualified for resizing and resized properly.

    We just tested deploying it as well - worked 100%, every partition, all 3 re-sized ones too.

    For this laptop operating in Legacy/BIOS mode - the HDD exit type needs set to GRUB.

    As a side note - the device we deployed to asked us to re-enter WiFi information but the image remained enrolled - but there was an error about conflicting Device IDs - so FYI do not take an image while enrolled!!! I’d recommend taking an image IMMEDIATELY after OS install - don’t even let it boot for the first time.

    Thread Solved.

  • @Sebastian-Roth Not yet. I’ll be messing with this most of the day probably… today is the last day of the work week for me, thanksgiving break till Monday. 🙂 People here are soo checked-out. My phone rang once yesterday. Today will be even slower.

  • Senior Developer

    Have you tried my suggest on modifying your init.xz to see the real error behind “Failed to fill partition (add)”?? See my first post.

  • @Developers anything I should know before I try to create a new OS type in FOG ?

  • Much to my surprise, after a half-way completed image restore and failure… ChromiumOS r48 booted… wow.

  • @Sebastian-Roth yeah the image does not restore.

    It fails on /dev/sda5 Says something like “This is not a partclone image”.

    I’m going to go out on a limb and say this is probably the partition that failed to upload.

  • It did upload using svn 4408, but there was a “bitmap error” on one of the partitions. I’ll have to re-upload and record to catch the error, don’t remember where it was or exactly what it said.

    Here’s a screenshot of the image info after upload… pretty sweet if you ask me:


    I’ll try to deploy this to another EliteBook and see what happens… should be fast… stand by.

  • Senior Developer

    We just fixed an issue with Multiple Partitions - Single Disk. Please update to the very latest and see if this helps!

    Edit: As both upload and download in resizeable mode seam to fail with the same error you might want to modify your init.xz to see the actual error produced by sgdisk command. Edit usr/share/fog/lib/ (somewhere around line 645) and remove >/dev/null 2>&1 from the end of the sgdisk call(s). You should see real error message then. Hopefully we can figure things out then.