SOLVED SVN 5419 not loading bzimage correctly

  • After fresh install 5419 when it gets to load the bzimage the directory is…No such file or directory (
    doesn’t look like it’s looking in the correct place…(my guess anyways)
    this is just after the… ok

  • Senior Developer

    @Hanz inits do not rely on the fog client (hostname changer, printer manager, etc…) for booting the host. While it is possible to load ipxe https it is not enforced nor would I recommend it either.

    I don’t know what issues you were having or why but if you rebooted the host after re running the installer the only guess I would have is the inits were not finished downloading when the host was trying to use the files.

    For now I’m going to solve this thread as I’m fairly sure it is fixed after running the installer.

  • @Wayne-Workman Ok so I remembered Tom saying something about the inits being on the client…(thought that was wierd), but apparently after deleting host, installing client, and adding it via pending hosts, all works well now. My only guess is that it now involves security measures or identities.

  • @Hanz I have all the same stuff you have, I’m not sure what’s going on.

    @Developers @Moderators a little help?

  • @Wayne-Workman

    [bcs@fog-server ~]$ cd /var/www;find . -type l -ls
    393285    0 lrwxrwxrwx   1 root     root           18 Nov 18 08:19 ./fog -> /var/www/html/fog/
    4980760    0 lrwxrwxrwx   1 apache   apache         17 Nov 18 08:19 ./html/fog/fog -> /var/www/html/fog
    4981499    0 lrwxrwxrwx   1 apache   apache         50 Nov 18 08:20 ./html/fog/mobile/css/font-awesome.css -> /var/www/html/fog//management/css/font-awesome.css
    4981510    0 lrwxrwxrwx   1 apache   apache         35 Nov 18 08:20 ./html/fog/mobile/fonts -> /var/www/html/fog//management/fonts
    4981513    0 lrwxrwxrwx   1 apache   apache         34 Nov 18 08:20 ./html/fog/mobile/scss -> /var/www/html/fog//management/scss
    4981511    0 lrwxrwxrwx   1 apache   apache         34 Nov 18 08:20 ./html/fog/mobile/less -> /var/www/html/fog//management/less

    The symlink under /var/www looks to be new somewhere around SVN 5389 or newer possibly.

  • @Hanz and the output of: cd /var/www;find . -type l -ls
    FYI this command recursively searches for symbolic links inside of /var/www

  • @Wayne-Workman

    cpuid --ext 29 && set arch x86_64 || set arch i386
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme

    This error occurs after “boot.php…ok”

  • @Hanz and the output of: cat /tftpboot/default.ipxe

  • @Wayne-Workman Both locations have /fog as web root (as it always has been 99.9% sure)

    Output is

    [bcs@fog-server ~]$ ls -lat /var/www/html/fog/service/ipxe
    total 867284
    -rw-r--r-- 1 fog    apache  15395728 Nov 18 08:20 init_32.xz
    -rw-r--r-- 1 fog    apache  16329408 Nov 18 08:20 init.xz
    -rw-r--r-- 1 fog    apache   6837408 Nov 18 08:20 bzImage
    -rw-r--r-- 1 fog    apache   6609104 Nov 18 08:20 bzImage32
    -rw-r--r-- 1 fog    apache     21280 Nov 18 08:20 bg.png
    -rw-r--r-- 1 fog    apache     20933 Nov 18 08:20 refind.conf
    -rw-r--r-- 1 fog    apache    205192 Nov 18 08:20 refind.efi
    -rwxr-xr-x 1 fog    apache       679 Nov 18 08:20 boot.php
    -rw-r--r-- 1 fog    apache     25340 Nov 18 08:20 memdisk
    -rw-r--r-- 1 fog    apache   1839104 Nov 18 08:20 memtest.bin
    -rw-r--r-- 1 fog    apache      1372 Nov 18 08:20 advanced.php
    -rw-r--r-- 1 fog    apache    234697 Nov 18 08:20 grub.exe
    drwxr-xr-x 3 fog    apache      4096 Nov 18 08:20 .
    drwxr-xr-x 2 fog    apache      4096 Nov 18 08:20 backup
    -rwxr-xr-x 1 fog    apache 216637440 Nov 18 08:20 LiteTouchPE_x86.iso
    -rwxr-xr-x 1 fog    apache 623890432 Nov 18 08:20 Hirens.iso
    drwxr-xr-x 3 apache apache      4096 Nov 18 08:19 ..

    not sure why the red

    I will add that per /opt/fog/.fogsettings, on server, the webroot is set as “fog/”…buuuut once again, I haven’t ever changed this.

  • What is this setting set to? mine is /fog/

    FOG Configuration -> FOG Settings -> Web Server -> FOG_WEB_ROOT

    And this?

    Storage Management -> [storage node] -> Web root
    mine is set to /fog for that.

    And what is the output of: ls -lat /var/www/html/fog/service/ipxe

  • init sizes are correct, however I tried to add clam last night and in trying to edit init.xz and/or init_32.xz by using xz -d init{,_32}.xz and things went a little weird. Im not sure if it worked or not, although per Tom I did uncompress them since I lost the .xz extensions, so I deleted init.xz and init_32.xz and updated svn thinking it would replace correct init.xz and/or init_32.xz.

    It does look like new ones were downloaded, however I get the error mentioned at the top of this post.
    sizes are 15 and 16 M which look correct per other nodes.

    I don’t understand completely how init and bzimage are related (if they are) and how I could’ve messed this up.