Bugs in FOG 0.33



  • After posting the above report, It seems that each Image definition had its Operating System reset to “Please select an option”

    But upon checking the new db:

    select * from hosts;

    it shows that on the hosts with errors their hostImage is set to an ID that does not exist. e.g not in the drop-down list of images to choose from and not in the images table.

    As I set each to a correct choice, the errors at the top of the Images page went away. As I then visited each host’s page, the error there was also gone.

    It appears that the OS for each image definition did not get properly upgraded.



  • Hi everyone. THANK YOU FOR FOG! Seriously.

    Now that I realized there is a 0.33beta avail for testing, I am jumping in head-first. :)

    Hope this is the correct place to report bugs or bug-like issues. If not, please direct me to the correct place.

    I just grabbed 0.33beta today like so:

    svn co [url]https://freeghost.svn.sourceforge.net/svnroot/freeghost/trunk[/url] freeghost

    And ran the install script.

    When the web UI updater ran on first logon I got the following errors:
    [ATTACH]248[/ATTACH]

    As I went through the menus, I cam across the following related errors:
    [ATTACH]249[/ATTACH]

    And on a host’s page:
    [ATTACH]250[/ATTACH]

    Google was of no help, and I also found nothing similar when searching the forums here.

    Any help fixing this? Would love to get to putting 0.33beta through

    Thanks! And thanks again for FOG!

    edit: I have nightly dumps of the db, so I can easily restore a 0.32 fog db and run any tests requested if necessary.

    [url="/_imported_xf_attachments/0/248_FOG-0.33beta-SchemaUpdateErrors-20130222.png?:"]FOG-0.33beta-SchemaUpdateErrors-20130222.png[/url][url="/_imported_xf_attachments/0/249_FOG-0.33beta-ImageDBErrors-20130222.png?:"]FOG-0.33beta-ImageDBErrors-20130222.png[/url][url="/_imported_xf_attachments/0/250_FOG-0.33beta-HostDBErrors-20130222.png?:"]FOG-0.33beta-HostDBErrors-20130222.png[/url]



  • Heretics!!!
    [SIZE=6][B][FONT=sans-serif][COLOR=#000000]Philistines!!! ;)[/COLOR][/FONT][/B][/SIZE]

    [SIZE=6][B][FONT=sans-serif][COLOR=#000000][SIZE=3]Seriously, a year from now a new Windows 7 machine will probably be a special order item (if there are any left)[/SIZE][/COLOR][/FONT][/B][/SIZE]


  • Moderator

    I must admit I am not a fan of Win 8 :)



  • Because it’s Windows 8, the Windows ME of the modern era :) …ok, to be fair, just the interface is a little “different”



  • ssx4life, can you think of a good reason for not supporting Windows 8?



  • This might sound a bit silly, but do we really want to support windows 8? ;) (I’m 1/2 kidding here)



  • I downloaded .33 last week to try out Win 8 support. I created my image using basically the same process I used for Win 7 and it works just fine. Obviously there are some things missing in the UI (when I tick the shutdown option when deploying something, it doesn’t work, for example), but the actual process of taking and deploying an image seems to work just fine.

    I created the image in virtual box and customized it using audit mode. Then I ran sysprep (not fogprep – FP never worked for me in Win 7) and deployed it using the Microsoft unattend file. I’m running .33 beta on Ubuntu 10.04.

    I’ve created/deployed 4 different images (playing around with the unattend file). FOG worked perfectly every time.

    I’m not sure if adding Win 8 support is the biggest change for .33 or not. If so, then as far as I can tell, the hard part is done :)


  • Moderator



  • If there is an official tarball of 0.33 then it’s news to me. The command I use to pull down 0.33 from SVN is:
    [CODE]svn co https://freeghost.svn.sourceforge.net/svnroot/freeghost/trunk /opt/freeghost[/CODE]
    If you don’t add “/trunk” to the end of the URL it will pull down the entire history of FOG, which is probably over 1GB.


  • Moderator

    Around 50meg.
    You want to download the latest trunk. freeghost.svn.sourceforge.net/viewvc/freeghost/trunk/


  • Testers

    I am trying to download the Tarball, how ever it gets to about 800meg and then gives me a network error. will not resume either…

    1. how big is this file?
    2. is there any other site i can get this from? Anxious to install and test as well. Im trying to download from “[url]http://freeghost.svn.sourceforge.net/viewvc/freeghost/[/url]

  • Testers

    As a New Forum Member Im currently downloading this eval addition to see if I can offer any opinions on this new version. I also hope that there is headway made to get this new release finished soon… I know that with previous versions updates were avail. almost like clock work… and being this is a completely new version, i know and expect major delays based on GUI enhancements and Kernel Upgrades… Im very anxious for a more robust and up to date version. We are expected to roll out newer Win7 and now Win8 PC’s where we have had issues with capturing images in the past… we hope the new releases will solve some of our original headaches…

    I must however commend all of the community and the Development team and coders for all the Time and Effort put into coming up with a new (FREE) cloning software solution. Godd Bless the OpenSource file community.

    Thank you Very much
    Bill



  • As this point I’m not really sure. I’ve only been somewhat involved in the development process, so I don’t know where they’re at with the upgrade path from 0.32 to 0.33. The code is the best (only) documentation for that at the moment, so I’d say give it a try on a test machine and let us (the community) know how it goes.


  • Moderator

    okay, what is the recommended way to bring my hosts across? ie moving to a new ubuntu server as well as upgrading to 0.33.
    Build the new server as 0.32, import from older 0.32 server, then upgrade the newer server to 0.33

    note: I am aware 0.33 is in beta, just speaking on testing terms



  • The database schema has changed between 0.32 and 0.33, so you can’t just do a export/import because the tables no longer line up. The devs were working at one point on getting a conversion script together, but I’m not sure if that’s still happening or what state it’s in.


  • Moderator

    using SVN 898 I have also been unable to import my sql host file from my production 0.32 box, anyone able to test importing??


  • Moderator

    [quote=“falko, post: 9221, member: 48”]just to double check, when I set up my FOG 0.33 test vm, all I need to do is Import the Host Inventory cvs from my FOG 0.32 box? Following the format provided from the Web Interface cvs ‘Import example’ sheet?[/quote]
    Feedback, though I am guessing the DEVs are aware already. using the latest svn: 898 the above import attempt does not work.

    error [CODE]FOG DEBUG: FOGPageManager: Class: ReportManagementPage, Method: upload, Error: Method not found in class, defaulting to index()[/CODE]


  • Developer

    Ummm… If you need clone a ext4 partitions, you can do a RAW or dd image. This way is slower than a normal way.


  • Moderator

    The cloning package used by default does not support ext4 and I don’t think the conversion to a newer cloning package has been finished yet. I forget if it’s partclone to partimage or vice versa, but either way it’s going to take a lot of testing to make sure it doesn’t break existing functionality and may get pushed to 0.34 depending on workload and time tables.

    If you just MUST clone linux systems, they have to be ext3, or you can use a different product for now. That’s the best I can tell you.


Log in to reply
 

384
Online

6.2k
Users

13.5k
Topics

127.5k
Posts