Bugs in FOG 0.33



  • Good day guys ive been following the details about 0.33 almost daily and in my excitment downloaded the beta trunk thats has been mentioned in the forum here, when ive launched the installfog.sh the installer is for 0.32 is there something stupid im doing here or will i need to replace files once installed? sorry for the stupid question im just keen to see what 0.33 looks like so far


  • Developer

    I’ve problems under Centos and the FOg daemons: FOGReplicator,FOGScheduler and FOGMulticastManager.

    [CODE]
    [root@r800145 administrador]# /etc/init.d/FOGImageReplicator start
    Iniciando FOGImageReplicator: [ OK ]
    [root@r800145 administrador]# PHP Warning: date(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘Europe/Berlin’ for ‘CEST/2.0/DST’ instead in /opt/fog/service/common/functions.php on line 46
    [/CODE]

    The problem is the php function date(), if you don’t setup your timezone in php.ini, it crash.
    I setup my php.ini with my timezone values and don’t problems.
    But FOGShceduler daemon:

    [CODE]
    [root@r800145 administrador]# /etc/init.d/FOGScheduler start
    Iniciando FOGTaskScheduler: [ OK ]
    [root@r800145 administrador]# PHP Warning: require_once(/var/www/html/fog/management/lib/Imageable.interface.php): failed to open stream: No such file or directory in /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler on line 58
    PHP Fatal error: require_once(): Failed opening required ‘/var/www/html/fog/management/lib/Imageable.interface.php’ (include_path=’.:/usr/share/pear:/usr/share/php’) in /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler on line 58
    [/CODE]

    The file [B]/var/www/html/fog/management/lib/Imageable.interface.php [/B]don’t exists[B].[/B]

    [CODE][root@r800145 lib]# pwd
    /var/www/html/fog/management/lib
    [root@r800145 lib]# ls -la
    total 20
    drwxr-xr-x 5 apache apache 4096 may 4 21:47 .
    drwxr-xr-x 15 apache apache 4096 may 4 21:47 …
    drwxr-xr-x 5 apache apache 4096 may 4 21:47 jpgraph
    drwxr-xr-x 3 apache apache 4096 may 4 21:47 ssh
    drwxr-xr-x 6 apache apache 4096 may 4 21:47 .svn
    [/CODE]


  • Developer

    No problems found with Centos 5.
    [QUOTE][root@r800145 administrador]# yum search php53
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile

    • base: ftp.cica.es
    • extras: ftp.cica.es
    • rpmforge: mir01.syntis.net
    • updates: ftp.cica.es
      ============================================================== Matched: php53 ===============================================================
      php53.i386 : PHP scripting language for creating dynamic web sites
      php53-bcmath.i386 : Un módulo para aplicaciones PHP para utilizar la biblioteca bcmath
      php53-cli.i386 : Interfase de línea de comando para PHP
      php53-common.i386 : Archivos comunes para PHP
      php53-dba.i386 : Un módulo de capas de abstracción de bases de datos para aplicaciones PHP
      php53-devel.i386 : Files needed for building PHP extensions
      php53-gd.i386 : Módulo para aplicaciones PHP para usar la biblioteca de gráficos gd.
      php53-imap.i386 : A module for PHP applications that use IMAP
      php53-intl.i386 : Internationalization extension for PHP applications
      php53-ldap.i386 : A module for PHP applications that use LDAP
      php53-mbstring.i386 : Módulo para aplicaciones PHP que necesitan manejar cadenas multi-byte
      php53-mysql.i386 : A module for PHP applications that use MySQL databases
      php53-odbc.i386 : A module for PHP applications that use ODBC databases
      php53-pdo.i386 : Un módulo de abstracción de acceso a bases de datos para aplicaciones PHP
      php53-pgsql.i386 : A PostgreSQL database module for PHP
      php53-process.i386 : Modules for PHP script using system process interfaces
      php53-pspell.i386 : A module for PHP applications for using pspell interfaces
      php53-snmp.i386 : A module for PHP applications that query SNMP-managed devices
      php53-soap.i386 : Un módulo para utilizar el protocolo SOAP en aplicaciones PHP
      php53-xml.i386 : Un módulo para aplicaciones PHP el cuál utiliza XML
      php53-xmlrpc.i386 : Módulo para aplicaciones PHP que usan el protocolo XML-RPC
      [/QUOTE]

    The installed packages
    php53.i386 5.3.3-5.el5 installed
    php53-cli.i386 5.3.3-5.el5 installed
    php53-common.i386 5.3.3-5.el5 installed
    php53-gd.i386 5.3.3-5.el5 installed
    php53-mysql.i386 5.3.3-5.el5 installed
    php53-pdo.i386 5.3.3-5.el5 installed


  • Developer

    Are there PHP 5.3 packages yet?

    Last time i looked you had to manually compile php 5.3 for CentOS. Booooo


  • Developer

    I try the fog 0.33b installer under Centos 5. I found a “bug”: the packages are not right under this distro.

    [CODE]lib/redhat/config.sh

    packages=“httpd php php-gd php-cli php-gettext mysql mysql-server php-mysql dhcp tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ htmldoc perl perl-Crypt-PasswdMD5 lftp clamav-update”;
    [/CODE]

    The php-gettext not exists in Centos nor RedHat. And the php packages install an old version of PHP, and this 0.33b version don’t works, you must install php53 packages.


  • Developer

    861

    • Installer: TFTP: Removed ‘\n’ in pxelinux file
    • Installer: TFTP: Ubuntu: Installer now correctly detects /etc/default/tftpd-hpa file and installs if file found

    862

    • Task Status ID Updates in service script functions - image upload and download now work as intended - please verify
    • StorageGroup Class simplified

  • Developer

    860

    • Host: createImagePackage(): Now checks if a Storage Node was found before checking if it’s valid
    • Host: Updated layout, MAC now sits under Hostname
    • Tweaked icons on search results for Host, Group, Image and Snapins
    • Image: Now enforces OS requirement
    • Made ‘delete’ pages consistent between all Management Pages

  • Developer

    859

    • Storage Management Web UI Pages completed
    • schemaupdater: Added unique fields for tables: nfsgroups & nfsgroupmembers
    • Updated remove icon

  • Moderator

    wow development is fast, even if it has been quite up until now. Hats of to Blackout and the other developers + those testing.

    now ubuntu 12.04 Server is out i will give the 0.33 trunk a test


  • Developer

    857

    • schemaupdater: Added table: taskLog
    • Added Classes: TaskLog, TaskLogManager
    • Host: createImagePackage(): If task is upload, add ‘dev/’ to end of ‘storage’ kernel arg - fixes bug reported
    • Task: Added: removePXEFile() - Removes PXE File
    • Task: Added: cancel() - Sets Task to ‘Cancelled’ status and removes PXE File
    • Active Tasks: “red x” now Cancels Task instead of Destroying
    • Host + Group Management: Added ‘Deploy’ icon to row results
    • Host + Group Management: Renamed various links
    • Deploy: Update titles and buttons to reflect Task Type and Target

    #1 - Fixed
    #2 - Fixed
    #3 - Probably not fixed - please test again
    #4 - Related to #3
    #5 - These pages arent complete yet
    #6 - Will be updated on final packaging, thank you for reminding



  • I did a clean install of Ubuntu 12.04 with Fog 33b (trunk 856) today. I only had time for limited testing. These are the items I came across. Sorry if some are the same as reported earlier…I just didn’t have time to compare:

    1. Same issue with writing to the images directory. On an image creation task (upload), I get an error it can’t create a folder in /images/macaddressofclient. Looks like the /dev is being left out of the path.
      I made /images folder rw so I could continue testing.

    2. When I click on “Hosts Tasks --> Upload”, the page is a little confusing. The top says “Deploy Task: Upload” and the button to start it says “Deploy to hostname” where hostname is your client name. When I click on that, The next page says “Deploy image to host”…that doesn’t sound like an upload to me, so that is confusing.

    3. Image upload works with change in #1. The task finishes on the client. No error, just a single line repeats over and over:
      " *


    "

    I had to manually reboot the client. The task was still in the Task Management view and was listed in the mysql tasks table.

    The delete task button (red box with x) removes the task from the view, but it does not remove the task from the mysql tasks table. If you refresh the Task Management page in the browser, the task comes back. I had to go back into the mysql db and delete the task. (One note is that I was able to remove tasks from the Task Management page if they had not started on the client.)

    Also, the image file lives in a folder that is based on the mac address of the client, and not the task name that I assigned when I created the task. So to deploy that image, I had to change the name of the directory or the “image path” in the image defintion.

    1. Deploying an image finished and the computer rebooted. The task was not deleted though. Had to do it manually through mysql. Also, my image did not actually work, but I think that is my fault. The imaging process is still really slow for me. I can provide more info on this later if needed.

    2. All of the links on the “Other Information” page produce a FOG DEBUG error involving missing Methods in classes.

    3. A few tiny version-related things to note: When I run the installfog.sh installer script, it still says version 0.32. Also, in the init.gz file used to boot the client, the /usr/share/fog/lib/funcs.sh file has the 0.32 version in the “displayBanner()” function, so you see that version when the client boots up and is about to start the task.

    Cheers, astrouga



  • I don’t manage to upload an image from a host. When I’m in the upload menu I have only the choice to press the blue button :
    “Deploy to host”.
    In the .32 release there is in “basic tasks / upload” a grey button named : “upload image”



  • Blackout, I’ll wipe my server and do a new install this morning. I’ll let you know how it goes.

    Thanks for all the hard work!


  • Developer

    Need some imaging tests if possible as I’ve made a bunch of State ID changes.

    I’d like to know if you can deploy -> boot -> image and have the task removed automatically.


  • Developer

    854

    • FOGBase: Cleaned up logging functions - made more readable and less scary looking :)
    • Group: Deploy: Hostnames now link to edit page of Host
    • Updated edit icon
    • JavaScript: FOGAjaxSearch: Fixed template issue not showing zeros

    855

    • JavaScript: Clean up unused JavaScript & tidy HTML for JavaScript - FOG now finds the JavaScript it needs automatically
    • JavaScript: Condensed JavaScript
    • AJAX Files: Removed unused AJAX files - these are deprecated as FOGPage now handles these requests
    • Logging tweaks
    • SystemUptime() function moved to FOGCore
    • Dashboard: Fixed disk usage, image history and bandwidth meter

  • Developer

    853 is up

    • Renamed GroupMembers Classes to GroupAssociation Classes
    • schemaupdater: Unique field setup for ‘groups’ and ‘groupMembers’ tables
    • FOGManagerController: buildSelectBox(): ID is now listed after the object name
    • Lots of ‘State ID’ changes for Tasks and Service Scripts - needs testing by imaging
    • HostManagementPage: Action box to assign hosts to groups now works again
    • HostManagementPage: Checkbox toggle works again

  • Developer

    @astrouga

    I have committed the missing class files - sorry!

    #2 - this is by design, /images/ should be read-only.

    The dir it’s writing to should be /images/dev/ i.e. /images/dev/mac_address

    There must be a bug that is not adding the dev directory to the path.

    #3 - good to hear, ill look into the service scripts more.

    #4 - Web UI code is yet to be created

    #5 - was missing ‘task type id’ from the link - also fixed this problem in group manager

    #6 - not sure why the disk info fails - will look into this more when i look at the dashboard again

    Keep the bug reports coming! It helps knowing where i should focus my efforts.



  • Thank you.
    I’m starting the installation.



  • I just download a tarball of the trunk from:

    [url]http://freeghost.svn.sourceforge.net/viewvc/freeghost/[/url]

    851 is the latest.

    –astrouga



  • Where can I find the FOG 0.33 release ?
    I would like to test it and report eventual issues.


Log in to reply
 

458
Online

6.1k
Users

13.5k
Topics

127.2k
Posts