• Hi All,

    Recently we have started getting an odd issue with a very select number of computers. Over the past week 2 out of 10 computers we have imaged with FOG have failed in the inventory stage and will not procede to imaging.

    8 of the computers where the same hardware (from the same batch) of which 1 failed. The other 2 are laptops of the same hardware of which 1 failed in this following way.

    Everything looks good when doing a full or quick registration however at the end of the inventory collection, when it attempts to send to the server, we get the error in picture linked below and it just sits there forever.

    The final line says:

    • Attempting To Send Inventory … Invalid Host

    The two machines that this is happening on have not been registered to FOG before and I have attempted updating FOG and updating (as well as downgrading) the kernel used as well, with no success.

    Any advice what to try next or assistance in resolving this would be much appreciated.

  • @Wolfbane8653 thanks for the help. I thought there might be issues running both svn and git but it went smoothly. Thanks again.

  • Developer


    SVN is preferred due to the clear build numbers (r3985, 3986,3987) but since that is currently down. Please use the git method for now.

    Run the update and Tom should now have this issue fixed.

  • i tried to manually import a host. that was successful but when i look at the host list the one i just imported is not there and when i reboot the system it still shows as not being registered.

    i also cant update to the latest trunk as sourceforge is still having issues. this is of course happening at the worst possible time. I work in a school and we have multiple staff and classrooms that need to be imaged asap.

    is there anything i can do to get this working?

  • I am getting similar errors, invalid host and the white screen.

    I am on svn 3781, ubuntu 14.04.2

    some additional info. I was trying to upload an image from my imaging vm which has been registered since i setup the server. I scheduled the task but the system didnt boot to the network (its a vm and boot settings got cleared for some reason) so after setting it to boot to network again i let it boot up but the task didnt start. I looked at the task list in fog and i saw the task listed so i rebooted again and the process didnt start so i looked at the tasks again and it was no longer listed. i went to recreate the upload task but the host had disappeared. I looked at the image that had been assigned to that host and the host was still listed but when i clicked on it i got the blank white screen. I tried to re-register the host which failed with the invalid host error, i was using the same name for hte host so i tried registering with a different name which also failed.

    I havent updated to the latest svn yet. let me know what if any additional info is needed.


  • Developer


    can you turn on display_errors in apache (php.ini) and goto the same pages / do same process where you get blank white screen and post error

  • I’m getting a similar error.

    attempting to send to inventory … invalid MAC!

    I look in the DB and the host does show up, and a mac shows up in hostMAC table.

    I’ve also deleted everything in the hosts and hostMAC tables and still get the same error.

    I also get a white screen when I try to register a client through the web interface.

    When I try to go to FOG Configuration -> Log Viewer, I get an empty drop down list after a very long wait. Where “Apache” normally would be, that drop down list is empty.

  • Developer

    @tlawson you have hosts and/or hostMacs with an ID of 0 in your database, delete them from your database and you should then be ok

  • @Lee-Rowlett Thanks for the update. I have pulled commit 18be28c669b02a8372230d29de8524e24acc58ff on the dev-branch and the issue has either changed or a new issue has emerged. It is saying Invalid Mac Address. I have done a bit of a google and not found anything applicable to this situation. Is this just the new message for the same issue or something else entirely?

  • Developer

    This has been resolved in the latest revision - update using github to resolve this issue


  • Hate to bump but this is still happening and I am not confident blaming it on the specific devices for an RMA but we cannot just waste the devices by not imaging them either.

  • @Wayne-Workman FOG Version 3771 on ubuntu server 12.04 LTS using undionly.kpxe and have have checked and there is nothing conflicting and the server has been rebooted during this time period. Also this isn’t an inconsistent thing. These two specific machines are failing the same way over multiple days, though I do understand the need to ask and be sure.

  • What version of FOG? What distribution and version of Linux? What boot file are you using (undionly.kpxe is most common)?

    Please double check that you’re FOG server IP isn’t accidentally assigned to anything else on your network… yes… really check, put some effort into it. You’d be amazed how many inconsistency issues are caused by IP conflicts.