I know what's wrong, I just don't know how to fix it!



  • I’ve added a new disk to the fog server, virtually completed it. I’ve created a storage node and added it to the storage group. They all appear as they should in the GUI. But my images are failing with the following error.

    This is displayed in the image listing. Both the storage node and group are called “2nd 4Tb Disk”

    test (My image name)
    2nd 4TB disk:Windows 7
    Multiple Partition Image - All Disks (Not Resizable) 0.00 iB FOGFTP: Login failed. Host: 10.10.1.5, Username: fog, Password: *******, Error: ftp_login(): Login incorrect. Yesterday, 9:17 am

    The problem is my storage node is failing to login. I tried the user / password listed in fog configuration->fog Settings->TFTP Server->FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD.

    I tried /opt/fog/.fogsettings, the value from mysqluser is blank, the password isn’t, but it failed with the blank username and password listed.

    I need to put the right username and password in. My question is where do I get the correct password from?

    Thanks again for your help, it’s much appreciated

    Yours

    Julian



  • The problem was that the master node check box wasn’t selected. As it was a new storage node, it needed selecting.

    Thank you all for your help. It’s much appreciated.

    Julian



  • Tom kindly fixed it for me, I’m very grateful. I want to document it properly in case anyone else has the problem, which I’ll do tomorrow, its 23:45 here and after a week of trying to get it to work I need some beauty sleep!!

    Thank you all for your help, it’s much appreciated, sleep well.

    Yours

    Julian


  • Moderator

    @Julianh

    You have an FTP server. Your FOG server is an FTP server.

    On your FOG server, if you go to Terminal, you should be able to use FTP from there, and test moving files, uploading files, etc.



  • I don’t have a ftp server to test it with, so I used ftp.kernel.org, being a public site, I couldn’t actually finish the upload,

    220 Welcome to kernel.org
    Name (ftp.kernel.org:image): anonymous
    331 Please specify the password.
    Password:
    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> put /tmp/test.txt
    local: /tmp/test.txt remote: /tmp/test.txt
    200 PORT command successful. Consider using PASV.
    550 Permission denied.

    But this is as far as I got.

    Is there any other test you’d like me to perform?

    Thanks

    Julian


  • Moderator

    @Julianh
    Thank you for your screenshots, but can you test that Wayne-Workman ask for ?

    @Wayne-Workman said:

    Can you try to use FTP from the FOG server itself? If it works, then that is a valuable troubleshooting piece.


  • Moderator

    Any updates?



  • Here are some screen shots of the storage node and image details, any suggestions?



  • image.jpg



  • image.jpg



  • This post is deleted!

  • Moderator

    Dumb question but, your Windows firewall is off, right? Like… totally off? Exceptions for stuff like TFTP don’t really work… I couldn’t get them to work anyways… maybe FTP might be the same… best to turn it off.

    Also,

    Can you try to use FTP from the FOG server itself? If it works, then that is a valuable troubleshooting piece.



  • I have to get it working with the front end, although the mv command would work, In the long term I won’t be the only one using this so it needs to work fine, unfortunately.

    Here’s the text from the windows ftp to the fog server,

    ftp> open 10.10.1.5
    Connected to 10.10.1.5.
    220 (vsFTPd 3.0.2)
    User (10.10.1.5:(none)): fog
    331 Please specify the password.
    Password:
    230 Login successful.
    ftp> pdw
    Invalid command.
    ftp> pwd
    257 "/home/fog"
    ftp> cd /images2
    250 Directory successfully changed.
    ftp> put test.txt
    200 PORT command successful. Consider using PASV.
    425 Failed to establish connection.

    I redid this, I noticed that it didn’t transfer the file, but logged in. This suggests file/directory permissions, but my previous post shows what they were set to, are they wrong? Or should the directories be set to root root, rather than fog root?

    Incidentally the machines being imaged have 2 drives in them
    I’m getting desperate, I’ll have to explain to my boss why this isn’t working tomorrow, any suggestions?


  • Moderator

    Well, a simple work around would be something like this:

    [CODE]mv /images2/dev/MacAddressHere /images2/EXACT_Image_Name_You_Chose[/CODE]

    And when I say exact, look at the path in your image definition (in the web UI). Normally, stuff like underscores and whatnot are truncated, the actual file name that it should be will be in the PATH section.

    But, can you verify that when you used FTP to transfer a file, can you verify you were accessing the correct storage node?

    Did you ECHO some text to /images2/dev/text.txt and then try to move that via FTP to /images/text.txt ??



  • The problem is now, how do I get the images named correctly and in the images2 directory instead of being named the MAC address and in the /images2/dev directory.

    Thanks

    Julian



  • I had a 4tb disk in the server, that I installed fog on. The OS and images are on this disk. I ran out of space, and added another 4 Tb disk to the fog server. It’s this new disk I’m having problems with, the old disk works fine.
    The new disk is mounted as /images2.
    There is no NAS involved, it’s all local, which it has to be. I’m not allowed to use anything except the 1 server, and must keep it on the network the clients are on, it’s not allowed to connect outside, to another NAS box for example.

    Thanks

    Julian


  • Moderator

    @Julianh

    You are likely running FOG 1.2.0 ? You wouldn’t have storageftppass= I think. That’s a more recent thing in FOG Trunk.

    When you say you “added a disk”, could you please elaborate?

    Did you physically add another hard drive into the server itself?

    Or are you using a NAS ?



  • I’ve spent 5 hours going through this, and still can’t see it.
    I’ve read through the guide Wayne suggested, and can’t seem to find the problem,

    My .fogsettings are; (passwords changed)

    ipaddress=“10.10.1.5”;
    interface=“eth0”;
    routeraddress=" option routers 10.10.1.1;";
    plainrouter=“10.10.1.1”;
    dnsaddress=" option domain-name-servers 8.8.8.8; “;
    dnsbootimage=“8.8.8.8”;
    password=“11111”;
    osid=“2”;
    osname=“Debian”;
    dodhcp=“y”;
    bldhcp=“1”;
    installtype=“N”;
    snmysqluser=”“
    snmysqlpass=“22222”;
    snmysqlhost=”";
    installlang=“0”;
    donate=“0”;
    fogupdateloaded="1"
    image@fog1:/opt/fog$

    I’ve checked the storage node, and the management username and management password are fog and “11111”

    I’ve ftp’d from windows to the fog server, and sent a file from windows to the fog server, using the credentials fog and 11111. The file transferred fine.

    I’ve reset the folders with

    sudo chmod -R 777 /images2
    sudo chown -R fog:root /images2.

    The results of the command

    ls -laR /images2 are below;

    drwxrwxrwx 4 fog root 4096 Jun 1 22:32 .
    drwxr-xr-x 28 root root 4096 May 28 23:13 …
    drwxrwxrwx 3 fog root 4096 Jun 2 21:47 dev
    drwxrwxrwx 2 fog root 16384 May 28 20:16 lost+found
    -rwxrwxrwx 1 fog root 0 Jun 2 17:43 .mntcheck

    /images2/dev:
    total 12
    drwxrwxrwx 3 fog root 4096 Jun 2 21:47 .
    drwxrwxrwx 4 fog root 4096 Jun 1 22:32 …
    drwxrwxrwx 2 fog root 4096 Jun 2 22:03 e03f49af16b2
    -rwxrwxrwx 1 fog root 0 Jun 2 17:43 .mntcheck

    /images2/dev/e03f49af16b2:
    total 34999444
    drwxrwxrwx 2 fog root 4096 Jun 2 22:03 .
    drwxrwxrwx 3 fog root 4096 Jun 2 21:47 …
    -rwxrwxrwx 1 fog root 512 Jun 2 21:47 d1.mbr
    -rwxrwxrwx 1 fog root 212396255 Jun 2 21:47 d1p1.img
    -rwxrwxrwx 1 fog root 10085091757 Jun 2 22:03 d1p2.img
    -rwxrwxrwx 1 fog root 512 Jun 2 22:03 d2.mbr
    -rwxrwxrwx 1 fog root 25506898197 Jun 2 22:40 d2p1.img

    /images2/lost+found:
    total 20
    drwxrwxrwx 2 fog root 16384 May 28 20:16 .
    drwxrwxrwx 4 fog root 4096 Jun 1 22:32 …
    image@fog1:/images$

    The only thing I can find is I have no storageftppass= line, but if this was the fault, wouldn’t it affect the creation of images on the original disk, which works fine.

    I have to build images next week, or my company won’t be able to run a course, and I’ll really be in trouble.

    Can anyone help me out?


  • Moderator

    Sounds like you now need to troubleshoot FTP.

    Take a look at this: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    Let us know if you figure it out, or if you need more help.

    Here’s a hint… Credentials :-)



  • Thank you Wayne, your suggestion has made a big step forward.

    The machine now uploads an image, but unfortunately it’s created an image in the /images2/dev directory, in a directory that is the MAC address of the machines lan card.

    The image size is also 0 in the list of images
    The command ls - l gives

    root@fog1:/images2/dev# ls -l
    total 4
    drwxrwxrwx 2 root root 4096 Jun 2 22:03 e03f49af16b2
    root@fog1:/images2/dev#

    I thought it may be permissions, so issued

    chown -R root.root /images2

    But that didn’t fix it

    Its the final stage that moves it from the /images2/dev to /images2 and renames it. So close…

    Anyone know the next step?

    Julian


Log in to reply
 

375
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.