AD Join/Rename on client .0.8.1


  • Testers

    It appears that with new client the AD join feature is not functioning. there is an error stating something (im no longer at work to see the log exactly) to the effect of missing AD information so its not attempting to join the Active Directory. otherwise the NEW Client works as Described! Awesome…

    Old Clients V.032 and .0.7.x to .0.8.0 will need to be manually removed prior to installing .0.8.1 I’m looking in to a way to use GPO to remove the legacy version and possibly to remove the directories/fog reg entry for the newer client version so that i can push out the msi with command line aurguments for silent install in the back ground.
    If anyone has figured a way to do this easily in an AD enviroment let me know just message me please :P

    Bit of Info about the Fog as a CA…
    Must install client with the IP address of the FOG Server instead of the DNS name since the cert authority ties to the ip address when it dish’s the cert out to the client.


  • Moderator

    I’ll try it tomorrow.


  • Senior Developer

    Fixed and v0.8.2 released


  • Senior Developer

    Did you press the “Reset Encryption Data” button?



  • @Jbob

    Now I get Authentication > CommunicationHandler Response: Invalid Security Token after I restarted the fog service.



  • @Jbob

    Awesome, give me 5 mins n I’ll let ya know


  • Senior Developer

    Alright I think I fixed it. Can you replace your Modules.dll with this copy: Modules.dll (You will need to re-name it to exactly “Modules.dll”), and re-try the Debugger? (Make sure to reset encryption data prior to use).

    If this works I’ll release v0.8.2 shortly.


  • Senior Developer

    This post is deleted!


  • @Jbob

    I got anxious and ran the debugger.exe and the AD settings were correct and it gave the same error Required Domain Joining information is missing.



  • The issue that I’m getting with 0.8.1 for the AD join is “Required Domain Joining information is missing”. I also ran the debugger and is see’s the correct domain join information, but it still gives me the error. I’m currently on SVN 3384.


  • Senior Developer

    Can you:

    • Download this file Debugger.exe to the FOG installation folder on a 0.8.1 client? (Program Files(x86)\FOG).
    • Stop the FOG service on that machine
    • Go to the FOG web portal and find the host you are testing on. Click it, and if there is a “Reset Encryption Data” button on the top, press it
    • Run the application (may require admin privilages)
    • Type the following commands (replace the mac section and the server url with the correct information for the computer you are running it from):
    configure mac XX:XX:XX:XX
    configure server http://fog-server/fog
    authenticate
    hostnamechanger
    
    • You should see a print-out of the AD information the client is using (it will be highlighted in Blue). Is everything correct?
    • Click the “Reset Encryption Data” button on the web portal again to let the actual client function.

  • Senior Developer

    You can use DNS as long as you only use http. The IP is only needed if you ask for ssl and you don’t have a valid certificate.
    As for pushing out the client via GPO, you do not need to remove the old registry keys. v0.8.0 will overwrite them.


Log in to reply
 

411
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.