Windows 8.1 & fog 1.2.0



  • Hi,

    I’m trying to deploy an image (Dell Latitude E7240) with fog 1.2.0.
    I can upload and download the image into the fog server, all ok, but when the system restart with a download image from the server windows does not start.

    Recovery. Your Pc needs to be repaired …

    Please anybody knows hot to solve it?

    Thankyou in advance
    [ATTACH=full]1733[/ATTACH]

    [url="/_imported_xf_attachments/1/1733_error.jpg?:"]error.jpg[/url]


  • Moderator

    @it_man The svn build is where you need to be if you want UEFI support. While uefi support was in 1.2.0 it worked marginally well (sporadic at best). There has been great efforts to get the uefi/gpt issues ironed out with the recent push of uefi only systems that just hit the market.

    If you can tolerate a little instability the trunk has many new features you could take advantage of. If you detect a bug in the trunk build it is usually fixed in 2 days or less.



  • @need2 Which update fixed that EFI partition backup issue ? I can’t find anything in the 1.3.X changelog.
    I have the exact same issue in 1.2.0 and it’s quite surprising that so few people talk about it.
    Windows 8/8.1 should have been the main real-world use of FOG for years now, right ?
    And new computers have shipped with UEFI enabled for years as well.
    So, no other choice than to use SVN builds ?


  • Senior Developer

    @jwalters this is svn or 1.2.0?



  • I am having this exact same issue. I can successfully pull the image from a Windows 8.1 laptop, but when I try to restore it I get a non-booting PC. PITA to have to go through the BCD repair every time. I have tried doing the BCD repair and then re-uploading the image. When it’s restored it still fails. SecureBoot and UEFI are both turned off.


  • Moderator

    From what I can tell FOG had a bug a few revisions ago that caused issues with Windows 8.1+ imaging. Would mess up/not capture the EFI partition. But that should be resolved in the trunk now.


  • Moderator

    @Jose-Ramon said:

    So, there are any solution to made a correct fog image, and upload it on a server?

    That happened to me recently with a Lenovo Laptop. Other things have been happening at work, and [U]a lot[/U] of them. I haven’t re-investigated yet.



  • I did this and it fixed my two issues…
    [LIST]
    []Make a UEFI Windows 8 boot disk
    [
    ]Go into the Advanced options and run the Command Prompt
    [*]Enter diskpart to use the DiskPart tool
    [/LIST]
    [COLOR=#282828][SIZE=13px][FONT=Menlo]DISKPART> sel disk 0

    Disk 0 is now the selected disk.

    DISKPART> list vol

    Volume ### Ltr Label Fs Type Size Status Info


    Volume 0 E DVD-ROM 0 B No Media
    Volume 1 C NTFS Partition 195 GB Healthy Boot
    Volume 2 WINRE NTFS Partition 400 MB Healthy Hidden
    Volume 3 FAT32 Partition 260 MB Healthy System
    [/FONT][/SIZE][/COLOR]
    [LIST]
    []Then assign a drive letter to the EFI partition (I used J)
    [/LIST]
    [COLOR=#282828][SIZE=13px][FONT=Menlo]DISKPART> sel vol 3
    Volume 3 is the selected volume.
    DISKPART> assign letter=j:
    DiskPart successfully assigned the drive letter or mount point.[/FONT][/SIZE][/COLOR]
    [LIST]
    [
    ]Exit DiskPart tool by entering exit
    []run the following at the normal command prompt (one line at at time)
    [/LIST]
    [COLOR=#282828][SIZE=13px][FONT=Menlo]cd /d j:\EFI\Microsoft\Boot
    bootrec /fixboot
    ren BCD BCD.bak
    bcdboot c:\Windows /s j: /f ALL[/FONT][/SIZE][/COLOR]
    [LIST]
    [
    ]exit and reboot
    [/LIST]



  • Yes,

    I’ve configured Legacy Boot and Secure Boot disabled.
    With these configuration I’ve uploaded the image on the fog server.
    After, with the same configuration I’ve downloaded the image on the laptop.
    After first boot, I’ve activated secure boot to enable.
    And when the system starts 0x0000225


  • Senior Developer

    I’m trying to understand how your picture has any impact on what the system is doing.

    My understanding from the error message you are getting is that the system is expecting Secure boot.

    You’ve disabled secure boot and performed the image, but are you setting it back once the imaging is done.



  • Hi,

    The picture is how I define the image in a fog server before upload from a laptop.
    Are OK?


  • Senior Developer

    What is the picture doing?



  • [ATTACH=full]1740[/ATTACH]

    [url="/_imported_xf_attachments/1/1740_image.jpg?:"]image.jpg[/url]


  • Senior Developer

    What is the “next” settings that you’re talking about?



  • Hi,
    I’ve reuploaded after fix, and when I dowload the image on the lapto I got the same error.I use next settings in order to create image on a fog server, so it’s correct?

    [ATTACH=full]1739[/ATTACH]

    [url="/_imported_xf_attachments/1/1739_image.jpg?:"]image.jpg[/url]



  • This post is deleted!

  • Senior Developer

    Reupload after your fix here should do it.



  • Hi again,

    I’ve followed the next steps and the PC works ok.

    [SIZE=4][B]Fix #1: Rebuild the BCD[/B][/SIZE]

    You can rebuild the BCD by following these steps to access the bootrec.exe tool:
    [LIST=1]
    []Insert your install disc
    [
    ]Click on [B]Repair your computer[/B] after you go through the language and time settings
    []Select your Windows installation drive, which is usually C:, and click [B]Next[/B]
    [
    ]Choose [B]Command Prompt[/B] when the [I]System Recovery Options[/I] box appears
    [*]Write the following command and press Enterafterwards:
    bootrec /rebuildbcd
    [/LIST]

    So, there are any solution to made a correct fog image, and upload it on a server?



  • [quote=“Tom Elliott, post: 43093, member: 7271”]When you imaged it, did you turn off Secure Boot?[/quote]
    Yes, secure boot is disabled.
    I’m using FOG 1.2.0 on ubuntu 12.04.
    Sorry, but I’ve searched more info in forums without any solution.

    Thanking in advance


  • Senior Developer

    When you imaged it, did you turn off Secure Boot?


Log in to reply
 

364
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.